N-track problems that remain unresolved

hey guys, these are problems I’ve been having with version 4 and some with v3 even, that haven’t been fixed. I’ve written to Flavio several times concerning them, and only once have I received a response. I thought I’d throw them on here to see what you think, as well as encourage Flavio to look at them :)

I still can’t use any directx plugins in LIVE mode-

I start n-track. (I’ve reverted to default settings and then configured n-track how I like it)
I add a blank mono audio track.
I arm the track for input of one of my sound card’s inputs.
I open the effects list.
I insert ANY DirectX plugin-including YOURS.
I close the effects list box.
I close the effect’s box.
I click on LIVE mode.
N-track crashes.

If I don’t click “don’t send” (for the error report) after a bit a directx error pops up, it says:

"Track insert - DirectX Filter sync
An error occurred during a DirectX plug-in’s processing. This error may happen when the plug-in is not compatible with the format used. For example if the plug-in works only on stereo signals you’ll have to activate the “expand mono to stereo” option in the track’s properties dialog box. You may also need to remove and reinsert the plug-in that cause the problem"

First off I’m usually not using a stereo plugin-I’m typically trying to use your compressor-which crashes N when using the EQ settings method of loading plugins as well-

I’ve tried using stereo plugins and expanding the mono track to stereo. I’ve tried using stereo tracks and stereo plugins.
I’ve tried using mono plugins on mono tracks.
No DirecX plugins work.

Vst plugins work fine-I do however get an error for vstscan.exe
when it finishes finding the vst plugins, this error pops up:
vstscan.exe has encountered a problem and needs to close. We are sorry for the inconvenience.
If you were in the middle of something, the information you were working on might be lost. Close"
The vst plugins DO show up in my effects list afterwards though, so no harm no foul.

I’ve written you several times in regards to the compressor 1.1 graphic window and you’ve never bothered to write me back about it, so here goes again.

load up n-track
open an effects list.
load FASoft Compressor v1.1
move the threshold slider up (raising the threshold limit)
move the ratio slider down (increasing the ratio)
the graph’s nodes will lock and ignore the slider’s positions until you move the threshold slider back down.

while the new picture for the graph is definitely cool looking, you didn’t bother to change the color of the text that pops up telling you the in and out point of the nodes and they are virtually impossible to read due to teh lack of contrast. either the text needs to be changed, or the picture needs to be darkened.

Thanks for the otherwise stellar program.

I was having all kinds of problems and did a complete format and now everything works great :)

It takes me about 4 days to do a format. I’ve got a LOT of programs that need to be loaded up. I went as far as getting an external hard drive to back up my drive, so formatting takes much less time, but it’s not worth it just to get n-track to play nice.

I have not had the same problems you have discribed with n-track4 per say, but upon reading other posts on this forum and following a suggestion to use Power Tracks Pro for MIDI recording and then transporting to n-trk, I have encountered another error that might be related to your situation(maybe?) I am unable to test playback of demo songs in PTPro as I get the following error and freeze-up:

"access viiolation in 0000000, dxirewire.dll . . ."

I questioned PGMusic support about this and they told me to change drivers and that PTPro was not compatable with ReWire. I said I wasn’t running ReWire, blah, blah … anyway a file search led me to n-track studio sub-directory. This file is causing me all kinds of problems and I don’t know if I can just delete it or not without effecting N-track. Are you using or do you have PTPro installed on your machine?

nope. I don’t have it or rewire.