N-Track v8 Won't Launch - Help!

Version 8 Won’t Launch on Win 10 PC

I’ve purchased a new Dell Inspiron with plenty of space, memory and processing. It has Windows 10. I’ve downloaded N-Track Version 8 for Windows, the 32 bit version. When I try to launch it all it does is show the Blue cassette logo with the big 8 and that never goes away from the screen.
The program itself never opens. Tried rebooting, removing, reinstalling, and nothing works. I don’t believe that it is the fault of my computer because I have since purchased Ableton Live 9 Standard along with some Toontracks instruments and plugins which all work perfectly. I do not like Ableton’s user interface as well as N-Track, so I really want to N-Track after all. I’ve been a long time N-track user and I understand and like N-track’s interface that I had with versions 6 and 7 on my old computer.
I want to purchase version 8 but I can’t if it won’t even open.
Any suggestions? Thanks.


try launching n-Track with the Ctrl key pressed. This makes n-Track avoid opening audio devices upon startup.
Then try to see if changing the audio device in the Settings -> Audio devices box makes any difference.
Please let me know if this fixes the issue.


Thank you, Flavio! I didn’t get a chance to try your suggestion. After trying several times over the last few weeks, last night I tried to launch it again and I left the splash screen there while I decided to ignore it. I went to bed. I got up this morning and N-Track was open on my computer! Since then, it opens every time I try to launch it. Maybe it just needed enough time to finish loading? I don’t know but now it’s working fine every time and I didn’t do anything but let it sit there overnight. Thanks for your help!