New track only recoreds some of the time

driving me nuts since the latest upgrade

I have version 4.1.5… since I installed - when I try to record a new track it does’t record- some of the time - other times it does fine… what am I doing wrong?


what am I doing wrong?

Dunno. Tell us exactly what you are doing and then we might be able to make some suggestions.


Well… I have some tracks already down and am trying to add more. I just hit the record button - I have it set to ask for a file name, so I do that, then I get the “ready?” box and click it - sometimes it records, sometimes it doesn’t.

I’m not sure about this, but it seemed to fail mainly when I had recorded a bad track, dumped it using undo, and tried another one - then again, I tried a new track name and it did the same thing. I also tried inserting an blank audio track - no soap… does that help?

I uninstalled and went back a few versions… works fine with that, so its something with the latest version

Hi Lane:
If it were my setup. … I would uncheck nameing the file till after the track was recorded… Then, I would import the file to the timeline… It’s gonna be called “New Song”… The file will be found where you directed it to go… in the preferences… If the file works for you in the song… Then… rename the “New Song” after you have decided that the track works… So… don’t check the “Name the file before the track is Recorded”… in the “Settings”/ “Preferences”…

IT might be worth a try… ???



Well… I have some tracks already down and am trying to add more. I just hit the record button - I have it set to ask for a file name, so I do that, then I get the “ready?” box and click it - sometimes it records, sometimes it doesn’t.

A few more details please… What does it do at this point to “not record”? Do you get an error? Does it drop back to the normal operating screen after clicking “ok”? Or does n-track go through the motions of recording a track and then there’s nothing there at the end? Or somthing else I’ve not thought of?

Bill - good to see you again - I’ll try that, thanks,

Mark -no errors, etc. It acts like its recording normally - timeline moves along as usual, etc. Window says “recording”. With the new feature that shows the waveforms of the track being recorded, I can see right away if its there and, some of the time, it is just blank. And again, its intermittent - or being caused by something I’m not recognizing…

could it be as simple as you not enabling your recording inputs? maybe you’ve set them to record to track 1, and when you go to make track 2, it’s still set to record to track one… of course that SHOULD overwrite track 1 and you’d notice, but is it possible something along those lines is occuring?

Well… anything’s possible. Perhaps something has changed with the new version regarding enabling tracks? What I have always done is just used the record button to start a new track and its always recorded fine… is there something new in this version that makes it necessary to enable differently? Also, I would think that, if it was the input, I would see a flat waveform on record, but I don’t, theres nothing there at all… ?

And when you stop recording, do you get a wave box with a flat line, or no wave box at all? If you’re using “record to new track”, do you get the new track ro not?

Hi Jeff…
When I stop, and it hasn’t recorded, I do not get a wave box and flat line… however, I DO see just a sliver of an edge of what looks like a wave box thats slid clear to the left… I can’t expand it and it does not seem to have any sound inside. Strange…
When recording to a new track - hmmm… I’ll have to try it again but I THINK that it also was empty, no wave box…

Make sure that you have selected recording audio and not MIDI. Or if you have a blank track already inserted make sure you arm it (i.e. click the button on it so it starts recording on that track).

Hi Lane and All:
I’m lurking on this topic and I see there is no resolve… as yet… At least, I don’t think, there is…

Another question I have, is…

Is the issue a hardware? or a software , one? Or… some combination of the TWO?


How could Lane BEST make that confirmation or determination?


Assuming it’s not what Staggerlee mentioned (good idea, but I think Lane’s posts rule that out because n-Track wouldn’t ask for a file name), sounds like a DAW software bug, though whether it’s n-Track or drivers is hard to say.

Should have started with this: be sure you’re using the latest drivers from the soundcard manufacturer’s website, and not the ones on the CD that came in the box.

Let us know what soundcard it is.

Finally, after recording does it create the file? How big is it (from Windows explorer)?

After recording and showing that thing on the left, did you try zooming all the way in? (Turn on the grid, click on the timeline at zero to set the vertical “pointer” there, and zoom in 20 or so times.) Does the thing take on any shape then, like a wave box with some data in it?

If it’s creating a wave file and it’s relatively small, email it to me. Maybe there’s a clue in the wave file (most likely not, but what the heck). I can dump the WAV header and look at it.

I suspect we’ll get down to some hard facts and submit a bug report to Flavio. The fact that it doesn’t happen on a previous release could be very significant.

Actually, I’ve had the same occasional problem with the build 2042. Soundcard is EMU 1820, latest drivers (1.82). It does create a file, but I haven’t checked the size from (XP sp2) explorer. Anyway, judging from what shows in nTS, there’s a second or so of silence.

Seems that you can see when it’s really recording, as nTS generates the wave outline on the screen. When there’s the problem, no outline.

So far, this haven’t been a big problem (annoyance, of course), but I haven’t had time to really dig into the matter, as I needed to get something recorded.

Between the two occasions I noticed this, I clean installed Windows and all the software to the computer.

OK, both of you guys should submit a bug report. Be sure to include the latest build number you used where the problem doesn’t happen, and include the details like the fact that a short silent wave file does get created.

I have this problem, or a similar one. Starting with build 2046, I have had a wavefile disappear during recording. The drawn waveform would be going along just fine while recording, then disappear altogether. The red RECORDING indicator in the time window would still blink and a wave file would get recorded on the disk. But, when I stopped recording there would be a track, but the waveform area would be blank - no box. If I rightclick the track and select properties, then “selected wave file properties”, I get an error “Error opening wave file. Select another filename?” But, if I open the actual file with another wave program, it opens and plays fine.

I am now on build 2062 and still have the problem.

So far, in an attempt to isolate the problem, I noticed that it has only happened when recording the third track and each of the tracks is over 2 minutes. I tried shorter tracks and the problem did not happen, though it may have just been a coincidence. For instance, I record a track for 2:10. Then I record a second track for 2:10. Then, while recording a third track for 2:10, the waveform disappears and I have the problem as described. I tried 10 second files, 20 second files and 2 minute files and no problems. Again, a coincidence, or is file length related?

I will continue testing to see if I can isolate this further. The only other change is that I have begun using the “ask for names of wavefiles to be recorded” feature. I need to see if the problem happens when not naming the file in advance.

This problem seems a bit different than what Lane or Mwah speak of. I actually get a full length wave file on the disk, just not in nTrack.

I am running Windows XP SR2, dual core 2.8GHz Intel, X-Fi soundcard, latest drivers. Other recording and playback audio software has run flawlessly with this setup.

Sounds like you have some pretty specific circumstances – file a bug report and Flavio should be able to recreate it and fix it. Let us know what happens.

Forgive me if this question sounds dumb, but could it be possible that you have some volume envelopes active on the track, or some parts being silenced? I had that once when I was re-recording a track trying to use the existing track settings only I forgot to get rid of the volume envelopes first.

Please note that I started a separate topic about my particular recording problem that I mentioned above. I have isolated the problem. If nTrack does an autosave while you are recording, the recording fails. I don’t know if that is the cause of the problem in this thread, but it is worth checking. See my “Track loses connection after record” topic for details.