Newbie Dweeb Problem w/SB Live!

MIDI records OK, plays back crap.

I have been trying to get n-Track, Anvil Studio, Voyetra Record Producer, Cakewalk, et al, to work with my SoundBlaster Live soundcard. I can record MIDI files (audio works fine, but don’t need it right now), but playback sucks. A 30 second piano file starts out fine for the first 5 seconds, then the pitch changes and it ends up sounding like a Hawiian therimin (sp?) giving birth. All drivers have been updated (including ATI video drivers). Using Win XP SP2, AMD 2500 XP CPU, 512M DDRAM XP2700, MSI KT4AV mobo, VIA chipset, and the SB Live! soundcard. Already tried changing banks from SB Synth whatever to GM. Controller is defaulting to 0, and live sound during recording does not exhibit this pitiful wailing sound.

Already had a Cubase/Sonar/Ableton keyboard hotshot check it out and he can’t figure the thing out either. Soundcard performs without any problems whatsoever in all other apps.

If somebody could help, and they need more info, I’d be glad to supply it via personal e-mail, but would like to see replies here on the forum so that others might benefit.

My only guess is that windows is changing the sampling rate during playback. in the control panel/sound devices, turn off windows sounds.

Also, make sure you’re recording at 48Khz only. SoundBlaster records/plays back at that sampling rate, any other rate is up/down sampled by the card itself to match it (if you record at 44.1 you’re signal goes in, is recorded at 48, downsampled to 44.1 and sent to the audio program, during playback, it’s converted back from 44.1 to 48 khz and sent to your speakers.)

setting your sampling at 48 khz eliminates all sorts of buggy problems with SoundBlasters.

I probably know less about MIDI than any living person, but with analog audio the only way to go with the SBLive is the kX project.

http://www.come.to/sblive

Not only will the kX drivers help to decrease latency in your recordings, they will also:

1. Help you lose weight and maintain your weight loss.
2. Help to get over shyness with the opposite sex.
3. Contact all your creditors and consolidate all your bills into one easy monthly payment.

And of course, the kX drivers are now low in carbs.

OK, guit, I already tried the sample rate at 48kHz. No good (i.e. no change), with the Win Sounds disabled. I’ve got the Bank Select Method set to Controller 0, as recommended by the SB and keyboard (Casio) instrtuctions. Record from: is set to SB Live! MIDI Port [E800]. These are what some of the settings are supposed to be. They ain’t gettin’ the job done, so I’m hitting every combination available to see what changes. So far, not much. I did go in and disable the ATI Rage Theatre Sound, but it had no effect.

For Doug, the kX drivers worry me a little, but I’m not having a bit of problem with audio recording or playback, so I’ll postpone that move for now.

This stuff ain’t that complicated. Maybe the Casio CTK-491 keyboard is f****d, but other people have been using them for composing without any problems.

Playback in MIDI, say a simple recording of running up and down the scales for about 45 seconds, sounds OK for about the first 7 to 8 seconds, then it gets ‘droopy’ and even sticks a few stray notes in there. I’m a drummer, not a piano player, so a few stray fingers are not out of my norm, but I can’t see stray notes appearing 2 or 3 octaves away right out of nowhere.

I’m still open for suggestions. It’s supposed to be fun, but I don’t feel funny.

When you playback are you using the SB Live sounds or the Casio keyboard inbuilt sounds?

In the midi preference try ticking "Keep midi devices open"
I need to have that ticked or N crashes.

Also what driver are you using in XP for the Sb Live? The WDM or the MME driver? use the WDM if you aren’t already.

HTH
Rich

OK, Rich, I’ve got the SB SoundBank picked, and ‘Keep Devices Open’ box is checked. The driver for the SB is WDM (aka Creative EMU10k1 Audio Processor). There might be some proprietary nuance in there but I haven’t seen it mentioned anywhere.

The playback still does the same thing. I went into Anvil Studio and tried various settings there. No good. I tried Pro Tools Free running under Win 98 compatability. Can’t get there from here.

I also set the ‘Input to output echo’ to NO MIDI ECHO. No change.

The resulting playback sounds like a stuck key, as I am using the PC speakers as monitors. A piano patch, for example, will sound fine for about 2 measures then goes into a church organ reverb overdrive sound. The notes from the speakers while recording do not give a clue as to anything being messed up.

I’m going to try n-Track on my old Win 98 computer, but I can’t remember what soundcard it packs. I still think this is not an unsolvable problem. Thanks to everybody for their words of wisdom. Still open to more ideas.

If it’s happening in a anumber of different applications (I’m assuming using a different midi part in each app) and also with a number of different sound sources (SB Live synth, Casio, midi mapper etc.) then it sounds like a hardware/driver type of problem.

If it works OK on the other PC it might be something to do with the VIA chipset on the current one.
I’ve never used a VIA chipset but have read numerous stories of problems with DAWs and VIA chipset MoBo’s…

Maybe even put your SB Live into your other PC.
If that works OK it points the finger even more at the MoBo on your current PC…

Rich

Just found this which may be of help… (I’m bored at work at the moment :))

http://forums.tweaktown.com/archive/index.php/t-472.html

Paticularly this post…

The 4-in-1 Driver from VIA is absolutely essential for reliable and trouble-free operation of your VIA chipset based motherboard. Here’s the order you should install your operating system:

1) Remove ALL adapter cards except the video card
2) Install the Operating System the usual way
3) Install the VIA 4-in-1 Driver
4) Install the video card driver
5) Install the sound card, then the driver
6) Install DirectX 8.1
7) Install all other adapter cards, one at a time

Hope this helps :)

In reference to THIS ^

there’s a FAQ on the VIA site that says you should install the
4in1 drivers BOTH BEFORE & AFTER installation of the SBLive

here 'tis

VIA FAQ :

Question:
I am having trouble with a system using a VIA chipset including a 686b southbridge and a Creative Sound Blaster Live card.

Answer:
When the 686b southbridge was first released, motherboard manufacturers and VIA discovered a problem when trying to transfer files between the primary and the secondary IDE channels on motherboards using ultra-DMA, when a Sound Blaster Live was plugged in and drivers activated. This issue was caused because too much noise is transferred across the PCI bus by the Sound Blaster Live driver set. In an attempt to fix this issue, some motherboard manufacturers modified their BIOS. In some instances, these modifications to the BIOS caused a data corruption error even when not using a Sound Blaster Live. VIA released a patch which resolves this issue, which is incoroporated in the 4in1 drivers from the 4.31 version onwards. Motherboard manufacturers were advised to change the modifications made to thier BIOS to elimate the data corruption issue. If you are experiencing data corruption or lock up when transferring files between two IDE drives:

1) Make sure you have the latest BIOS from your motherboard manufacturer.

2) Make sure you have the latest 4in1 drivers

3) Make sure when you set up your system that you install the 4in1 drivers both before and after you install the SBL to make sure that the drivers see your SBL and install the correct patch. The patch will only install if the SBL is installed

The ol’ VIA chipset backdoor blitz, huh? Thought about it, but my mobo was sold to me by a pretty sharp game addict. I would presume this should indicate good sound with lots of intense video, so I got it (MSI KT4AV).

The chipset, BIOS, EIEIO, and everything else are pretty much updated, as I just built this new system last month.

I’ll try it, and absolutely try the SB in the older Win 98 PC. Just went thru the ‘Live!center’s MIDI pages’ but did not really find a related mention of the problem.

Muchas gracias for digging up the 4-in-1 info.

Sound like MIDI data is being lost/corrupted either during record or during playback. It may echo fine while recording. Do you know for a fact that the recorded MIDI data is exactly what you played? This check won’t fix the problem obviously, but it help knowing that it’s just a record problem or a playback problem…and incorrectly recorded MIDI file will always playback wrong for example. (Does the problem happen with all MIDI files, or just recorded files?)

The MIDI files that I record have a real scummy wailin’ alien sound to them upon playback, but they don’t sound that way going in while I’m monitoring the input through the PC speakers. The playback just goes completely nuts.

Any imported MIDIs or WAVs playback without one single solitary glitch.

Gonna check for IRQ sharing for the SoundBlaster. That might explain why the playback sounds like a stuck key sometimes. Still can’t understand what would make the playback switch to a different instrument right in the middle of a composition, or the pitch change.

>>EDIT<<

SB Live! was changed so it didn’t share any IRQs. No help. Playback still sux. I turned up the PC speakers for monitoring during recording and did hear faint stray notes. I looked at the Events list but didn’t see anything weird. Going to try and disable the speaker output on my Casio keyboard (if possible). Using a CTK-491 for the controller with MIDI IN and OUT plugged in.

Use just one MIDI cable going from MIDI Out on the Casio to MIDI In on the computer. Don’t connect the Out from the computer to the Casio. You might be having a MIDI feedback loop going.

Wave playback is irrelevant in this scenario. This is strictly a MIDI problem. What you hear while recording is probably irrelevant too. The data is getting corrupted when or before it is stored in the MIDI file.

Do you have a MIDI file sample you could post or email? Seeing what’s in a file that shows the problem might help figure it out.

Unfortunately, even seeing the corruption after the fact (MIDI file) may not help solve the cause, but at least it can help confirm MIDI corruption in the file. Events that look right in the event list might not be the whole story.

OK, phoo, I already tried that MIDI cable trick. No difference that I could tell. Sometimes there sounds like a loop starting but it’s in the data and not the connections.

You’re right about the recording being corrupt. I turned down the sound on the keyboard and use the PC speakers as monitors, as I should have from the beginning. The distorted playback is coming from the recording itself. I can hear it over the speakers as simple piano notes transform into a torture chamber soundtrack. Garbage in, putrid garbage out.

The Casio CTK-491 keyboard may be the bad guy in all of this. Looking at the Events page for a simple track, I can see Program Changes, Sustain On, Portamento (WTF?), and other changes that just should not be happening.

The Casio user’s guide says that only General MIDI sounds will work with the keyboard, while also mentioning that its own onboard sounds are not compatible with GM. The booklet goes on to state that songs are best processed using only Channels 1,2,3,4, and 10, without a lot of ‘busy’ tracks. There go my 32nd notes.

The thing that is making me suspect that the Casio settings are not correct (and there ain’t much to do there) is that the problems are occurring in every program I’m trying to use, i.e. n-Track, Anvil Studio, Voyetra Record Producer, et al.

I can post a small sample of the playback wherever you need it to be to get a listen. It would be something such as playing one note at a time, middle ‘C’ and up, until the warping starts.

Sure do appreciate someone looking at this. I’m stumped.

Have you tried this…

Download a midi file from the net and try and play that back using N- track or any other app and route the midi to your SB Live synth.
Or just compose something using the piano roll - whichever is easiest.

If that plays back OK then I’d say yes what you are playing on the casio is not what is actually being recorded…

Rich

MIDI files downloaded from various sites have all played back without any problems using n-Track.

I’m not too sure what you mean, Rich, when you say ‘route the MIDI to the SB Live synth’. In other words, use that sound bank for my downloaded MIDI?

And I haven’t even looked at the Piano roll yet. Is that easier than using a standard keyboard as a controller?

I will sure as heck give it a try. Can’t believe people are still hanging in there with me on this thread. What a nice place!

Yes - use the SB Live soundbank to playback the midi file, not the casio (in fact just unplug the casio whilst doing this testing just to be sure :))

Piano roll is not easier or harder - it’s just different.
It’s probably more suited to doing things like simple drums or bass lines or pads.
It can be more accurate if you want to place notes precisely, but won’t get the nuances of a playing on a real keyboard.

If downloaded midi files play OK and it’s only midi tracks that you record using your casio keyboard as a midi input then I’d say that there is either a problem with the keyboard itself or you may need to adjust some setting in on the casio if it has any midi options.

My Roland keyboard I can just plug into my midi port and record without having to change any settings on either the keyboard or n-track

Rich

Alrighty, Rich, here’s what I’ve got: MIDI track composed in Piano Roll - playback normal. The only banks available to me are GM banks. I’ve got the output set to SB Live! Synth A. I haven’t figured out how to switch the bank yet.

The Casio keyboard controller has 2 MIDI control settings - Keyboard Channel and ToneMap (which can either be N or G).

I’m just a drummer wanting to get some song ideas down and have a format where my keyboard Jedi knights can tweak them into decent enough compositions.

Probably won’t go the $$$ Roland/Korg/Alesis route as this is only a ‘something to do’, but with everyone looking at it, this problem really looks like a keyboard controller input. Thanks to everyone.

A cool drink waitin’ for all who helped if you’re in town for the Derby. 1st Saturday in May.

JPX

Yep…something is corrupting the MIDI stream coming from the Casio to the MIDI In. That could be corrupted data coming out of the casio in the first place, a bad MIDI cable, a bad MIDI to Game Port adapter (this may be your only MIDI cable), a hardware issue with the SB Live, or a driver issue with the SB Live.

<!–QuoteBegin>

Quote
Looking at the Events page for a simple track, I can see Program Changes, Sustain On, Portamento (WTF?), and other changes that just should not be happening.

Exactly. That is classic MIDI event corruption. MIDI events are serial, with no times tamps and no error correction. If even on little bit is dropped (or noise introduces a blip) every event after it may be corrupted, and what you see is what you get when that happens. MIDI events are nothing more than 3 little parts with each part value being 0 to 127. Loose one part and the rest get offset, but still look like valid events at the receiving end.

Kind of like this (very much pseudo-events when any three letter combination of A B or C are valid parts in the 0 -127 range):

ABC ABC CBA CBA ABC ABD CBA CBA … same pattern (original un corrupted stream)

AB[C] ABC CBA CBA ABC ABD CBA CBA (let’s drop that first C)

ABA BCC BAC BAA BCA BDC BAC BA{A} (no events look like the origial stream but all are still valid events - the last one is filled in with the next event {A})

ABA BCC AC B[A]A BCA BDC BAC BAA (let’s drop two more events)

ABA BCC ACB ABC ABD CBA CBA A{BC} (all still valid, but that last event is like an original again)

AB[A] C[C] A[C]B [A]C [A][D] CBA CBA ABC (drop a lot more - yeah I’m being select for example purposes this time)

ABC ABC CBA CBA ABC {ABC CBA CBA} (look familiar?)

ABC ABC CBA CBA ABC ABD CBA CBA … same pattern (original un corrupted stream)

Superior explanation there, phoo, you should write a ‘MIDI for Serious Dummies’ book. Clear explanation of the process, which is why I like to see this thread still active.

How about this? I ran a DirectX diagnostics for my soundcard, and got errors with: mono-16bit, hardware buffer, stereo-16 bit, hardware buffer, and on up. Never ever heard any problems with playback, no matter what the file type or freq.

Now then, the Creative Labs diagnostics ran through its paces and came up with no errors. Likewise the MIDI connection checker/tester.

DirectX latest version is installed, along with updated drivers for the SB Live!, and the Device manager shows no conflicts, plus my sound card is not sharing any IRQs. Onboard PC sound is disabled (natch).

I’m gonna see if I can find some kind of different keyboard to use as a test controller, just to make sure the Casio ain’t pooped out. Is is possible to use the audio output for headphones and run a cable into Line in on the sound card? I know it’s not MIDI, just wondering if it might fry something.

JPX