Newbie here, hoping someone here can help

I can record/playback just fine via my soundcard, but I can only record via the USB ports.

Under advice from a few different magazine articles, I bought a ART USB Dual Pre so that I can make cleaner/clearer recordings, so…can anyone dummy it down for me as to how this is accomplished via the USB port?

I think I may have mentioned that I’m a newbie with a Capital N! :)

http://www.head-fi.org/t/258551/how-does-usb-audio-transfer-work

plug it in,

it should show up in “soundcard settings” as a card, select it,

press record, see what happens.

you should get two mono or stereo tracks.

Quote: (dontcare @ Apr. 16 2013, 8:38 AM)

plug it in,

it should show up in "soundcard settings" as a card, select it,

press record, see what happens.

you should get two mono or stereo tracks.

Thanks, that was exactly the info I needed! :D

Apparently I spoke too soon…just got through buying the program and followed above directions, but getting nothing. Obviously, I’ve done something wrong…

Going to Settings -> recording format -> ? (soundcard format? 32 float?, Enable Live input processing?)

playback format ->? (32 float?, apply setting to all channels?)

Can’t figure out what I did to make it work previously… :angry:

Thanks in advance for anyone who points me in the right direction (I’m so-o-o-o-o clueless!)

Hi, Terry. Can you see the ART on the list in Audio devices?

Quote: (TonyR @ Apr. 20 2013, 3:53 AM)

Hi, Terry. Can you see the ART on the list in Audio devices?

I went to Settings -> Devices -> found 3 choices, each, for input and output:

(Audio Playback Devices)
MME: Realtek HD Audio rear output
MME: Windows Default Playback Device
WDM-Realtek HD Audio rear output

(Audio Recording Devices)
MME: Line In/Mic In
MME: Windows Default Recording Device
WDM - Line In/Mic In

Nothing that specifically says ART.

Have you looked in n-Track menu Settings > Audio?

Quote: (bax3 @ Apr. 20 2013, 9:29 AM)

Have you looked in n-Track
menu
Settings > Audio?

Sorry, I should've clarified "Settings -> Devices", so, yes.

Perhaps Audio Playback: Windows Default and Recording: USB Audio Device?

Or is there a better setting(s) I should use?

VERY much appreciate all of y'all trying to clue me in, btw!

Oops, I meant to write “Settings -> Audio Devices” above…my bad.

I am still not clear, but I think you are saying that the USB unit is showing up in the Settings > Audio of N-Track. Windows will have an audio setting in the Control Panel under Sound. The settings here Should show up in N-Track > Audio as
"Windows Default Playback Device" and “Windows Default Recording Device”.
Here are somethings to check:
1) Open Windows Control Panel and make certain that the Sound is set properly.
If it has been set to the USB card, try setting it to the internal sound card on the motherboard. This is to see if some other program is taking over the sound card and maybe it can’t be used by two programs at the same time. What you set in Windows shows up as Microsoft Default Settings in n_Track. Normally, you can select it, but any other sound card listed in n_Track can be selected as well.
1) Open Settings > Preferences and make certain that the Sampling Frequency (Hz) is set to something the card can handle - If the specs on the USB card say it works with 44100 I’d suggest setting it there. There are reasons you might want other settings, but 44100 is a standard for Cd burners/players so it is just easier and will work for most all recordings.
In Settings > Preferences, Click on Midi and then the Midi Devices button and be certain that Microsoft GS Wave Synth is Not selected.
2)Open n-TRack Settings > Audio and see if the USB device listed with the protocols/drivers that it can use ( such as ASIO, WDM and MME . Try the MME as it is the oldest and most reliable and sometimes works when other drivers will not.
Both Playback and Record must be set to the same setting MME playback and MME Record. This rule is the same for any other protocol
See if things work now . . .
3) If MME works, try WDM - it has less latency if you are trying to match playback to new tracks. ASIO has the least latency, but with some computers has the most problems.
Hope this helps
Bax

Quote: (Terry Allan Hall @ Apr. 20 2013, 8:02 AM)

Quote: (TonyR @ Apr. 20 2013, 3:53 AM)

Hi, Terry. Can you see the ART on the list in Audio devices?

I went to Settings -> Devices -> found 3 choices, each, for input and output:

(Audio Playback Devices)
MME: Realtek HD Audio rear output
MME: Windows Default Playback Device
WDM-Realtek HD Audio rear output

(Audio Recording Devices)
MME: Line In/Mic In
MME: Windows Default Recording
Device
WDM - Line In/Mic In

Nothing that specifically says ART.

The three devices you listed in each recording and playback pane point actually to the same device.
This list doesn't seem to include any USB device. Try unplugging and plugging it back on and see if it appears in the audio devices list.
If it doesn't please check if the device requires device drivers to be installed.
Once you are able to select the USB device please select 16 bit or 24 bit recording format in the Settings -> Soundcard's settings -> Recording format box.

Flavio.
Quote: (Flavio Antonioli @ Apr. 20 2013, 3:35 PM)

Quote: (Terry Allan Hall @ Apr. 20 2013, 8:02 AM)

Quote: (TonyR @ Apr. 20 2013, 3:53 AM)

Hi, Terry. Can you see the ART on the list in Audio devices?

I went to Settings -> Devices -> found 3 choices, each, for input and output:

(Audio Playback Devices)
MME: Realtek HD Audio rear output
MME: Windows Default Playback Device
WDM-Realtek HD Audio rear output

(Audio Recording Devices)
MME: Line In/Mic In
MME: Windows Default Recording
Device
WDM - Line In/Mic In

Nothing that specifically says ART.

The three devices you listed in each recording and playback pane point actually to the same device.
This list doesn't seem to include any USB device. Try unplugging and plugging it back on and see if it appears in the audio devices list.
If it doesn't please check if the device requires device drivers to be installed.
Once you are able to select the USB device please select 16 bit or 24 bit recording format in the Settings -> Soundcard's settings -> Recording format box.

Flavio.

Will do...thanks!

Yep - the ART should be on the audio device list. Did you install the software (drivers) for the ART before you plugged it in? I’m curious as to what happened between you being able to record and not being able to.

Quote: (TonyR @ Apr. 20 2013, 7:23 PM)

Yep - the ART should be on the audio device list. Did you install the software (drivers) for the ART before you plugged it in? I'm curious as to what happened between you being able to record and not being able to.

This is the info I have on it. I've used it w/ the built-in Sound
Recorder, built-in on my computer, and it seems to work fine there (of course, it's a very limited, mono recorder, with no way to overdub or
much else).

USB Dual Pre



The USB Dual Pre is a full-featured high quality dual portable preamplifier and computer interface packed into a compact rugged case. It is designed to work over a wide variety of applications from remote field recording to desktop/studio tracking. Each of the two low noise input channels has up to 48 dB of clean gain with signal present and clip LED indicators. Inputs can be either XLR balanced or 1/4-inch TRS. Each of the 1/4-inch TRS outputs is buffered low impedance balanced.

The USB Dual Pre can be externally powered from the mains via a supplied 12 Volt DC adapter, or from an internal 9 Volt battery, or from the USB bus itself, or any combination of these power sources. When running off of the battery alone, you should get in excess of 50 hours of operation when phantom power is off. Battery life drops to around 20 hours (depending on microphone) when phantom powering from the battery alone (still enough time to get through a session).

The built-in low noise +48 Volt phantom power supply allows you to power up to 2 microphones as well as the preamplifier when running from any power sources including the USB bus.

For monitoring, an 1/8-inch TRS mini headphone jack with level and monitor mix controls on the rear allow for latency free local monitoring of the inputs while recording as well as playback monitoring of the USB bus. The monitor mix is also routed to the 1/4-inch TRS balanced outputs. This lets you use the 1/4-inch outputs as either preamplifier outputs or as the monitor feed to your powered monitors.

The USB interface is fully compliant with the USB 1.1 specification and uses USB adaptive mode for playback and USB asynchronous mode for record. It will work with the USB audio device drivers built into Windows 98SE/ME/2000/XP/Vista and Apple OS9.1/OSX computers with native USB support. No special drivers are needed.

The compact black anodized all aluminum case with rubber sides make for a rugged design. The USB Dual Pre will provide years of trouble free service and its high quality audio channels and versatile powering options make the USB Dual Pre the obvious choice in a wide variety of applications from Podcasting/Broadcasting to Tracking and Monitoring.

With the USB Dual Pre, your laptop, and a pair of quality condenser microphones you can do some serious remote recording.
http://artproaudio.com/discont....ual_pre

Hope I'm not being too much of a bother.

try ASIO4ALL

I’ve had problems like this with USB devices in the past, one tried to re-install and find the device every time it was unplugged.

if you are using Windows 7 read this FAQ

The default setting for the input is 1-channel / 16bit/44.1K. In “Properties”, change this to: 2-channel/16bit/44.1K.

State your problem in the topic.
Then, other people will know if it’s a problem they’ve solved - and, thus, help you.
Or, they’ll know it’s where the solution THEY’RE looking for is.

MUCH better than looking at a list of issues, where you have to OPEN each one to know if it’s what you’re looking for, or about an issue you know something about.

sometimes it helps to plug the USB device in and out,

restart computer, etc,

I had one USB device I had to have windows recognize it and load drivers every time i used it!