nTrack crash related to EQ window?

I had a copy of nTrack studio 4.1 (I forget which build I’m afraid), which was working fine until recently. I started playing around with the options available in the right click menus on the EQ plot. I noticed some strange problems at this point - it seems if you select certain options under Frequency Spectrum -> Display -> Peak Decay, they don’t update properly, and for some reason the ‘thick plot’ option gets set in the Frequency Spectrum -> Display menu. My EQ plot is now stuck with ‘Hold Globally’ and ‘Manual’ selected under peak decay settings.

Worse, now when I load a song and play it, as soon as n-Track tries to render the frequency spectrum the whole application dies (I’m guessing it is the frequency spectrum since when it is not on screen, n-track works fine).

I downloaded and installed build 1969 in the hopes it would repair the problem but it didn’t.

Is there something I can do such as deleting config files that might totally reset n-Track?

Edit: I have now tried the following:
1 - rename ntrack.cfg to ntrack.cfg.old - ntrack took some time to run the next time, but still the problem.
2 - Select ‘revert to defaults’ from the settings dialog - no effect whatsoever, n-track even remembers where my song files are when I use the open file dialog.
3 - complete uninstall/reinstall - no effect whatsoever as above.

I still have my registration numbers, I just need a way to kill off ntrack completely and get a clean install!

Since resetting the defaults didn’t do the job. Uninstall and search for ntrack and fasoft in the registry and delete those keys, but only after uninstalling. ntrack2.cfg is also a file to search for and delete. Deleting that is about the same as resetting the preferences though. I don’t think it’s 100% the same. It will be in a hidden folder associated with the user account as logged in. It used to be in the same folder as ntrack.exe but not anymore.

Sounds like a good bug for Flavio to tackle next week.

I fixed the problem for now by completely deactivating the frequency spectrum plot. I can still see and edit the response curve so all is fine. The spectrum plot probably ate unnecessary CPU anyway.

What’s more worrying is the weird sticky menu problem.

Do I need to do something to bring this to Flavio’s attention? (Like email him), or will he read this and get round to it eventually?

best way to be sure - fill out the feedback form:

http://www.fasoft.com/feedback_form.html

although i submitted a few reports that i’ve received no response on yet… he might be away or something right now.

Yeah, no rush - I can still use n-track. Did he create the whole thing from scratch himself, and does he now maintain it himself or are there other people on the development/bugfixing side? If it’s just Flavio then he’s got a real big task on his hands, and can’t possibly be doing everything at once.

<!–QuoteBegin>

Quote
I fixed the problem for now by completely deactivating the frequency spectrum plot. I can still see and edit the response curve so all is fine. The spectrum plot probably ate unnecessary CPU anyway.

It’s sort of unfair to blame video drivers on something like this, but a lot of times upgrading the video drivers has solved this kind of thing.

Search for a video utility caller PowerStrip. There’s a feature in it that lets you see and set what the video latency is. It’s under Adapter information. setting Latency to 64 has helped on some machines.

Yes, it’s just Flavio.