Ouch , need help bad

cant open a song ive recorded

Hi Everyone :D

I have an ouchie. I was wrapping up a full arrangement of a song I have been working on for the last 5 weeks and doing the final mix down and was almost done. My CPU usage was very high but everything was fine and I played it back multiple times, each time I opened and closed the .sng file with no problems. Then I decided to try just one last plug in :(
I put it on the master track ( it was a very subtle reverb ) and closed the song with out playing it. 5 minutes later when I tried to open the song, no dice, i can’t open it.
I get an error message that says " ntrack.exe has encountered and error and needs to close " . There is a technical report that is enclosed of course, but I don’t pretend to understand what it is telling me.
This is a Big ouchie for me and I really need some help.
OH, by the way, all my other N-Track files open up just fine AND all my wave files from the song I just finished and cant open are still there I can see them.

Should I try importing them into a new .Sng file ? is this possible ? If so this might solve my problem because I wont add the reverb to the Master track this time of course.

What do you think guys ?


Desperate Ted

Yes, it’s very possible to import the files into a new sng file.

Only one problem,
Unless you started each track at 0:00 they will all come into the new track at 0:00.
Which means you will have to slide them all into position.
Hopefully you have at least one file in the mix that starts at 0:00 like a click track, so you know were to begin at least.

Let us know how it goes,

any more problems with it just post,

good luck


jerm

Thanks Jeremy,

I did have a click track but I deleted it near the end of the track recording because I was so tight on CPU overhead. Ouch, what you are saying makes perfect sense and it also tells me this may not be my best option.

I may have to see if someone has an idea of how to rescue the original .sng file


Thanks Jeremy

Any more ideas Guys ?

Well as long as you remember the bpm you shouldn’t have that much trouble making another click track.
But your right, if there’s alot of seperate files it can be a real drag!

Here’s another idea but it might be far fetched.
Maybe if you uninstalled the compressor plug it would force the program to open, but with an error message, saying (unable to load pluggin). Just throwin’ stuff out there. Probably would be more trouble than it’s worth, if you can’t get the compressor plug back(if you don’t have it on disk somewhere.)

That’s about All I can think of, hang in there,


jerm

Wow ! Now thats an excellent idea, that might work Jeremy.

Maybe if the plug in doesnt fire I can get in, Aha !

I can easily reload the plug in later, its a Freebie on the Web. I was using it on several tracks but I replaced it with Freeverb thru most of the tracks later on.

Super suggestion Bud, I am going to ponder it a bit and field any more ideas that come in also.

Thanks !

Ted

deleted

deleted

You might try contacting Flavio. He might be able to download your project file and fix it. ???

This is also a good time to remind people to save VERSIONS of a project (before effects, after effects, etc)

Dave T2

Thanks davet2,

I have sent Flavio an Email regarding this problem and i am crossing my fingers. I also tried the solution above that Jeremy mentioned. Unfortunately the song still wont open, but it was a good idea.
I think that the .sng file is corrupted which is my fault, because I was pushing my CPU way too hard. I think it was the last bit of extra processing from that last plug in that did it. I dont think the plug in itself was the problem, I had already been using it with no problems until then.
I WILL be doing more frequent backups in the future I guarantee you , hehe.

Thanks for your help,

Ted

Ted,
You might also try that new 1775 build, since it includes the fix from 1774 which is related to crashing when opening .sng files. phoo (another poster in this forum, as you may already know) says it was a memory corruption bug he reported which could have been causing all kinds of other random problems. Anyway, might be worth a shot?

Tony

Hi Scantee,

Well guess what. I came home from work today and thought you know i should upgrade to the newest build or version of n- track because I am still running 4.0. I have been hearing people say that the newest build maybe more efficient CPU wise and I could use the additional overhead.
I didnt think this would have any effect on my problem but I thought well, lets give it a try.
IT OPENED MY DEAD SONG. Oh my god, a new lease on life !
The open problem is when I push play nothing happens. My older songs play fine just like before. So, I think maybe there is still a problem with the .sng file. HOWEVER, at least now I have a map that I can use to exactly duplicate the song in a new song folder if necessary.
I can use it to line up all the tracks with and replug in all the effects and their settings, volume levels, volume envelopes drawn, etc, ,etc…
So I feel MUCH better.

I would still be delighted to get any additional feedback from anyone.


Thanks Scantee,

Ted

It won’t play? Can you mix it down?, remove any effects?, resave it?

According to phoo, it was a memory corruption bug, only one side-effect of which was Explorer.exe (and N-track?) crashing when opening certain .sng files. What else it fixes remains to be seen, I guess (memory corruption bugs often cause seemingly random errors). I only recommended upgrading in your case because 1774 sounded like it might be directly related to your situation. Glad it helped some, Ted!

And of course, BIG thanks to phoo for finding and reporting it, and Flavio for squashing it!

I’m gonna try it out 1775 right now…just because :D

Tony

There were two bugs I was seeing that are probably related. One was when opening a song file. In past builds this might do all sorts to random funky things. That’s what got me looking into it. This cleared up in later builds, but the way I detected it as being a memory thing was still an issue, even after the symptoms seemed to go away. So, because it was still there when opening a song it could still cause problems occasionally even though I hadn’t seen any obvious symptoms in weeks.

The other bug I ran into was similar, but happened occasionally after importing a wave or cloning a track. That was the one where explorer.exe would crash out from under everything. In earlier builds I did see that happen when opeing a song sometimes, but not very often.

I’m pretty sure this was the same bug that seemed to cause an ActiveMovie window to partially open occasionally, or cause a random app to run. Like I said, really odd stuff can happen, including virus like symptoms. I knew it wasn’t a virus. Small memory corruption (overwrites) is how viruses get their own code to run.

It’s quite likely these two bug are related since opening a song and importing or cloning a tracks will add new tracks to the current song in memory. The way I was detecting the memory corruption wouldn’t allow to get past the first point to corruption so I couldn’t confirm it.

To be far, the actual error being reported was invalid memory access. That could be reading freed memory, which generally won’t cause any problems, unless the value read is out in la-la land, like reading a pointer and using it (majorly big boom), or basing something on a variable that isn’t valid. Of course it could have been writing to freed memory, which would stomp on whatever was there and all kinds of havoc could break loose when that memory is used later.

Regardless, that particular problem is fixed now. The test tool I was using did not detect any memory problems with 1774 doing the limited stuff I was doing last night, and that includes adding and deleting tracks, opening songs, etc. I haven’t put it through its paces yet, but so far VERY good.

If y’all remember I said the memory thing would probably be a hard problem to pinpoint. That’s why I say be patient many times. Flavio would fix it if he could find it, and that’s not always as easy as finding the symptom with a test tool.

HOWEVER, at least now I have a map that I can use to exactly duplicate the song in a new song folder if necessary.
I can use it to line up all the tracks with and replug in all the effects and their settings, volume levels, volume envelopes drawn, etc, ,etc..

Ted, you can use "Edit-->Song Information" to get a textural representation of some of the song's parameters. Cut and paste into a text file, hit print, and you've got a paper copy of your song's numbers.


Mark

try reg clean you can download it for free. i think i may sound bogus, specialy since i haven’t had your prob Ted but give it a try. cause when i have errors on N i just run reg clean & then the error dissapears. reg clean fixes errors on the reg i think (hence the name) not sure will work though. but it wont hurt to try.

peace…

Hi Guys :D

Hi Lemon:

No, unfortunately it wont play. It wont mixdown ( I am guessing you mean render down to a stereo wave file ). I think it has to be able to play to do that. I was able to remove the last plugin I installed though, and i can do most other things you would normally do with a song. I just cant play it.
Very Trippy I think.

Hi Scantee:

Thanks again for your input and feedback, and yes thank goodness phoo shared his insights and bug detection with us.

Hi Phoo:

Thank you for the excellent and extended explanation, i know much more now than I did.

Hi Mark A:

Great to hear from you again. Wow, I had not noticed that all that song info was available like that. Very cool, thanks Bud. I am sure it will be very helpful if i have to piece the song back together again.

Hi Dean:

Thanks for your registry cleaning tip, it might help. I am glad to hear that is working well for you, thats good news :)

I should repeat one thing that might be important:

I am pretty sure that the problem was not a bug but rather me pushing my CPU way too hard (93%). I think when it freaked out under the load it corrupted the .sng file and i have since found out 4 of the wave files may have been corrupted. When I try and click on these 4 wave files I get a message that says " cannot access wave file, FMT chunk is missing " The other files open fine. I am guessing that FMT refers to format chunk, i dont really know.

But anyway that is where things stand for now. I have already began reassembling the song in a new .sng file while i wait for Flavio’s Email.

Thanks Again Everyone, if you have any more ideas dont hesitate to post
:D

Ted

Hi Ted,
if the FMT chunk was corrupted the wave file can’t be opened because the information about sample rate, bit sample size, etc. was lost. If the wave is very, very important, it´s possible to rebuild the FMT but you have to love bits and bytes.
You can have tec. information here: http://www.sonicspot.com/guide/wavefiles.html