Playback in 4.0

Play back of files in older version

I have been using 2.0 for a while, and have recently upgraded to 4.0. Although i can open up the files created in 2.0 they will not playback in 4.0. All the correct playback facilities are checked but still no sound.
I can individually import all the wave files into 4.0 and these will then playback, but this is going to be painfully slow, and then i will need to line up all the wave files in synch with each other.
Does anybody have any suggestions?

I know its a bit of a pain, but have you tried opening them up and resaving them in v3 as an intermediary step? It sounds like there’s some minor incompatibility between v2 and v4 sng files. You could also pack the song into *.sgw format (assuming this was still an option in v2) and send this to

Thanks John,
I’ve tried saving it in V3 first and strangely enough it works on some files but not on others. I have learnt that i need to remove all the effects first (these were causing some conflict for some reason).
Whats happening now though, is that i can open up the V3 files in V4 and play them fine, but once i’ve saved them again as a v4 file i cannot open them back up.
Any other suggestions would be most welcome!

Sometimes upgrading might overwrite your plugins, making them think they are unregistered again (and thus muting their output at times).

To rule out the effects, you can always hit that green “Fx” button at the top-left of the timeline to disable all FX processing…

It’s a bit of a long shot, but how about opening a new blank song in v4, then using the “Track/Import Tracks from .sng file” option to bring all the tracks across. Then, assuming this has worked, save the new v4 song and see if you can reopen it.

Failing this, you need to send a bug report to attaching an example of the problem v2 .sng file.

Best of luck