playback meter showing nothing

although i am able to record using sb audigy wdm in and out, it shows nothing on playback meter, so i can’t see if it’s going in the red?

Playback and record meters? Either way, make sure it’s enabled. There’s button that will be green on the bottom if it’s enabled, or gray of it’s off. Meters can also be turned on an off by right clicking the meter and selecting Turn on or Turn off from the popup menu.

woops, i’m officially an idiot:)

Yer not so idiotic. Changing the (some) settings will automtically disable them sometimes. It’s rather easy to overlook actually. :)