PLEASE HELP!!!  (Lag problem)

I realize this seems to be a common problem here, but I’ve tried all of the remedies suggested and am still having major problems. Let me give you a little bit of background.

I’ve been using NTrack v. 2.0 for many years now without a problem. About two weeks ago, I started to have those synchronization problems when recording overdubs. The old tracks I recorded are still fine, but when I try and record an overdub, I get a horrible lag. It’s not a steady lag, either…the lag counter oscillates wildly between numbers, usually around -200. To give you an idea, the lag counter resembles a stopwatch. When I try to record a brand new song, I have the same problem.

I’ve tried most of the suggested remedies now. I’ve played with the buffering, disabled the system timer, tried mono and stereo recording, mono playback, etc I’ve also tried updating my soundcard driver (NVIDIA nForce), but it told me that the latest update had already been installed. I’m actually wondering if the update is precisely what screwed up NTrack.

Flavio suggested the “keep audio open” option, but I can’t seem to find this. Was this option not available in v. 2.0?

I am desperate for help! I was just about to finish recording an album! Would anyone like to walk me through this step by step? I’m on AOL Instant Messenger and could give you my screen name, if that would expedite things.

Let me know if you need more info about my system, etc.

Hi,
in Audio devices, Advanced, uncheck “Keep Audio Devices Open”.
It worked for me.
Good luck
Kind regards
Henrik :;):

PS: Dear Flavio, please reconsider to make this the default setting :)

Henrik,

I don’t seem to have that option. My version of the program doesn’t even seem to have the “Audio Devices” menu. The closest thing I have is one called “Wav Devices,” but there’s no option in there to keep audio devices open.

Quote (IAmSpartacus @ May 16 2005,06:34)
Henrik,

I don't seem to have that option. My version of the program doesn't even seem to have the "Audio Devices" menu. The closest thing I have is one called "Wav Devices," but there's no option in there to keep audio devices open.

Hello again,
try this way:

“File” (at the top of the screen) ,
“Settings”,
“Preferences”,
“Audio devices”,
“Advanced”,
uncheck “Keep audio devices open”

Good luck Henrik
:)

I don’t have a “Settings” option under “File.”

Hey spart,
I’ve seen your thread hear for a while now, but I was hesitant to respond since I wasn’t shure what was causing the problem.
Being one of the few members still using older versions I though maybe I could help since I have the app in front of me.
I think your right though that is a really old version even older than mine…congradulations! you stumped the booey!
I think you can upgrade to 2.3 for free! As far as the link, I’m not shure I always get it from Flav, when I need to install it on a new system.
I’m still using 2.3 and I’m pretty shure it has the “open devices” options. ???
Best advice I can offer, is email Flavio, and sk if there’s a free upgrade to 2.3 available for you.
Wait a day or two for a responce and either you’ll get one, or you’ll panic, and be back here! lol :laugh:

try and stay possitive


jerm

Please tell me, is it working with the upgrade?

Welp I just check it, and no, that option isn’t on 2.3 at least not in the manner in which henrick’s finding it in his version.

But you know the more I think about this one the more I think it’s not the missing option that’s the problem. I obviously haven’t been using this option for years now, and haven’t had the lag problems Sparts encountering. It would hurt him to upgrade if he can though.

After reading his initial post again, the one thing that comes to mind that might cause such a dilema would be the “snap to” settings.
I have read from other threads of a simular problem caused by the snap to settings not being set at 0. (as they probably were for the other tracks that all seem to be Ok.)
I think you can access it by Veiw > Settings> Punch in settings?
As far as wherer henricks tryin to get you in your version I think its…File>Prefrences>wav. Devices> should list whatever you got but I know there’s know "keep devices open option on 2.3 there anyway!
Doesn’t mean it’s not in the program, just not there!
:D

Serioulsy though it’s MHO that you have aonther issue to work out other than “keep devices open” since you don’t seem to have that option. I’d mess around with other things. If you reloaded your soundcards driver you may have reverted things back to default setting inside ntrack. You might have to do whatever you did intially when you first got N, in order to record in the same manner as your original tracks.

best wishes

jerm

I’ve noticed that certain plugins can cause lag when placed in one of the aux channels. Specifically - SIR reverb.
So then… my suggestion is to remove any effects you have loaded and see if the problem goes away.
:cool:

Thanks for your responses, everyone. This whole thing has been really disconcerting and I hope I can remedy it soon so I can finish my album. I’ve already been working on it for a solid year!

I’ll check out the “snap to” settings and see if I can find the solution there.

As for effects…I’ve been piling on effects for months now with no problems whatsoever, so I doubt that’s it.

Folks, please continue to post any and all ideas you might have. Thanks a bunch!

Can anyone tell me if the following buffering settings look suitable?

Live Input/VU Meters
Buffers Size: 5120
Buffers #: 4

Playback Buffering
Buffers Size: 14336
Buffers #: 5
Preload Buffers: 8
Disc Loading Buffers: 3

Recording Buffering
Buffers Size: 1022
Buffers #: 16

I tried checking “snap to 0” but it does nothing.

Quote (IAmSpartacus @ May 19 2005,21:05)
Can anyone tell me if the following buffering settings look suitable?

Live Input/VU Meters
Buffers Size: 5120
Buffers #: 4

Playback Buffering
Buffers Size: 14336
Buffers #: 5
Preload Buffers: 8
Disc Loading Buffers: 3

Recording Buffering
Buffers Size: 1022
Buffers #: 16

Kind of hard to answer that question without more information about your system.
Especially processor speed. There's just so many variables out there with slower and faster results to make an accurate diagnosise, even for a computer wiz, which I am not.
If those are the default settings, I'd say they are fine, but if you altered them somehow, and your processor isn't able to handle the additional load....trouble will follow. Again if your running on a 1G or better I wouldn't think that's it.
It would also help to know how many tracks your using in the files your having problems with.
I've notice with slower processors, you are limited to the amount of tracks and effects you can run at a time without lag.
I wouldn't disregard Johns statement about the effects just yet. But again if your running on say a 2.6G you probalby could get away with say 24 tracks 24 effects depending on the type of effects being used, possibly more...don't have a 2.6 to test it this theory of mine on. lol!
I think John mentioned reverb on the aux channel as possible culprit. It would make sence if you have reverb on a track as it's being recorded, it's not going to be in time with the other tracks, since once it's recorded the aux channel will probably ad the effect during playback causing the new track to be delayed twice over....a noticable lag might occure.

???
As far as I know there two or three kinds of lag a computer can create.
One is caused by the inablity for the processor to keep up with the number of tracks it's trying to playback....while recording. Happens with slower PI's even some PII's under say 300mhz.
One way to remady this is to mixdown all the tracks to a single file...then start a new project file and import it, now you have one track playing...and your proccesor can now devote it's CPU to the new tracks you want to record without lag. you can always bring the new tracks back into your old file for a final mixdown later.
Another kind of lag is caused by a conflicting music program interfering with Ntracks ability to record in real time. (Fruity loops and winamp are common causes at least from my experience.)
The third kind of lag I've encountered is caused by not having the soundcard syncronized with the computer clock..or somethin to that affect. There's some option you can click somewhere..it's been years since I've had to..."use system timer"..."use soundcards timer"...somethin' like that comes to mind.

Dat's about alls I gots to say about dat....
:D

keep plugin'

Thanks for sticking with me.

I’m not sure of the exact specs of my computer, but I just got it last year. I’m not sure how fast it is, but I know it’s pretty much up to date and I wasn’t having a problem with the program until a few weeks back.

My songs tend to have around 15-20 tracks, with a little reverb. But like I said, the problem occurs when I try to record a brand new song as well, so I don’t think effects used on the tracks I’ve recorded is the issue.

Anyone here up for IM-ing me and giving me some live tech support? :) PM me and I’ll send my screen name.

Whoa! I think I’m almost there! I tried enabling the system timer again and it seems to be helping, although it works sporadically. Sometimes I go to overdub and there’s a lag…other times, no lag.

The main problem I’m having right now is that when I record a new track, it mixes it with the old one, so the new track has two parts on it. There must be some sort of “bounce” option that’s selected somewhere. Any ideas?

Yep had that problem too a couple years back. I posted in here and got a couple of solutions.
The way I ended up fixing it was re-loading windows, it just fixed itself. Why did I do that?..welp truth is the answers I got were over my head! All kinds of techinical terms and such, and me being a laymen just wasn’t workin’. But I’m shure there’s another solution…
C’mon guys! help this dude out!

keep shinin’
jerm

What kind of soundcard are you using? It sounds like you have a setting in your souncard’s driver that has changed to “record what you hear” or something similar. What sample-rate are you recording at?

Quote (John @ May 23 2005,15:36)
What kind of soundcard are you using? It sounds like you have a setting in your souncard's driver that has changed to "record what you hear" or something similar.

Oh, of course! I completely forgot my recording software was set to "Stereo Mix." Thanks!