Popping and stuttering

Popping and stuttering

n-Track version: 5.0.2
Operating system: Windows XP
Soundcard: PreSonus INSPIRE 1394
Video card: 256MB nVidia Geforce 7300LE TurboCache
CPU: XPS 410 Intel ® Core™2 Duo Processor E6400 (2.13GHz, 1066 FSB)
Other hardware: Hard Drive 250GB Serial ATA 3Gb/s Hard Drive (7200RPM) w/DataBurst Cache

I have the following problem: For the track configuration with 5 full tracks that span the entire song and 4 tracks that begin half way through the song (9 total tracks). The program runs fine (~15% CPU usage) until it gets near the tracks that start in the middle of the song. When it hits these tracks, the CPU usage goes up to 30% for a short time and popping and stuttering is heard. In order to fix this, I have:

1) Disabled all startup programs and services.
2) Changed the IRQ of my FireWire card.
3) The SATA drive does not have the option to turn on DMA.
4) I plugged in a fast USB drive with the same song on it and it behaves almost identically as the internal drive.
5) Played with the latency of the sound card (2-25 msec)

The disk controller on the computer is a raid controller; however I only have one disk.

Nothing seems to help. This is a new, fast Dell computer, with a fast disk. Any suggestions would be appreciated.
Thank You

N tracks CPU meter does not tell the whole story - to see what is CPU use is actally taking place download CPUmon from the link below -

http://www.den4b.com/downloads.php

its a free app and shows total CPU use including the normally hidden windows use -

you could be hitting 90+% very easily -

you say “Soundcard: PreSonus INSPIRE 1394”

is it firewire or USB and drivers used ?. all helps -

Dr J

It is a FireWire interface

Are you running any effects (plug-ins) on the tracks? Sounds like your processor can’t keep up. If you are running effects, you can remove them or freeze them for the time being.

Sometimes I mix everything down to one track while I am adding new tracks. Mixdown each individual track for use later. Even the shorter tracks will be for the full-length songs once mixed down. For the final mixing, you can reimport the single tracks. This will drastically reduce the CPU resources.

Keith

Thanks for the reply

I can turn off the effects for the entire song by cliking on the little green FX icon in the upper left-hand corner of the track listing window next to the waveform display. This does not help.

My guess is that the n-track opens the wave files and begins to buffer them shortly before they appear on the timeline. So in my particular situation I have 4 files being opened up simultaneously while my other 5 tracks are playing and this causes the CPU spike and the subsequent popping. My questions are: am I correct; is my disk drive preforming up to specification; and is there something I can tweak on the computer.

Tim

There is an issue with Firewire and XP SP2. Go search the MS Knowledge base for the cure. It has something to do with the default FW buss speed being set too low. I don’t remember the details now.

You have WAY more horsepower than I do. My PC can playback 15 stereo tracks or there abouts before I have to start freezing my effects and VSTi’s. Lately I have been running Reaper instead of n. I don’t have to freeze or anything with it and I have some tunes with 20+ tracks loaded with plugins… I wish Flavio would fix n-Track. :(

D

from Presonus support page FAQs -

Q: I have a PC computer and am getting clicks/pops/drop outs in playback. What can I do?

A: These issues are often common at first. There are a few settings to adjust to smooth out the audio performance.

1. Right click on your My Computer icon and select Properties. Click the Advanced tab, click the Settings button under Performance, click the Advanced tab, then set to Background Services under Processor Scheduling.

2. Click Start menu, Control Panel and double click into Network Connections, if you have a Wireless Network Connection, right click and ‘disable’ this while you are running the Inspire 1394.

3. Within Cubase, click Devices menu, select Device Setup, and select VST Multitrack. There you have “number of disk buffers”, set this to 10 and “disk buffer size”, set this to 128 or 256. Then click the ‘Expert’ button and set “audio priority” to VERY HIGH and UNCHECK “multi processing” if applicable. You may also want to increase any related settings within other recording software.


Dr J

There is a firewire patch for SP2 available from Microsoft at
http://support.microsoft.com/kb/885222.

You may need to download and install this patch if:

You cannot install your PreSonus interface
Your PreSonus interface installed but the sync light remains red
Your PreSonus interface installs and syncs but audio recording and playback performance is very bad regardless of settings.
If you have these issues, download and install the patch, restart your computer and then reinstall your PreSonus interface

Dr J

(MORE SPECIFIC INFO ) from Presonus -


Inspire 1394 » PC ID #1027Why am I getting pops, clicks, and/or drop outs in my audio while using my PreSonus interface on my PC?

These issues are often common at first. There are a few settings to adjust to smooth out the audio performance. Please note, if your system does not meet the system requirements of your chosen DAW software, these issues may not resolve.

Right click on your PreSonus interface icon in your system tray just to the left of the time. Set the CPU setting to HIGH. If HIGH setting does not improve performance, try LOW.
Right click on your My Computer icon and select Properties. Click the Advanced tab, click the Settings button under Performance, click Advanced tab, then set to Background Services under Processor Scheduling.
Click Start menu, Control Panel and double click into Network Connections. If you have a Wireless Network Connection, right click and ‘disable’ this while you are running your PreSonus interface.
If you are using Cubase LE, click Devices menu, select Device Setup, and select VST MULTITRACK. Set the number of disk buffers to 12; set disk buffer size to 128 or 256; and click “APPLY”.
Make sure you are set to the Presonus ASIO driver. Then click the ‘Expert’ button and set “audio priority” to VERY HIGH and uncheck “multi processing” if applicable. You may also want to increase any related settings within other recording software.
Lastly, right click on My Computer icon, select Properties, click Hardware tab, and then click the Device Manager button. In here, extend the IDE ATA/ATAPI Controllers. Double click on the Primary and Secondary IDE Channels and click Advanced Settings tab. Here you will see Device 0 and Device 1. You’ll see “Transfer Mode” (which is usually set to DMA if available) and you will see “Current Transfer Mode”. Current Transfer needs to be set to UDMA (Ultra DMA) mode. If either Device on the Primary or Secondary Channels are set to PIO mode, this could be your problem. PIO mode is an older legacy and slower transfer mode for older drives. If either is set to PIO mode, first make sure the “Transfer Mode” is set to “DMA if available”. You can change PIO modes by either entering BIOS and setting the IDE Controllers to’Auto’, the Current Transfer Mode should change. If not, in the Device Manager, as long as the “Transfer Mode” is set to DMA if available, you can right click on the Primary/Secondary IDE Channel listed and ‘uninstall’ it. Once ‘uninstalled’, reboot your computer and it will refresh.

NOTE: Entering your computer’s BIOS is specific to your computer. Check your computer’s manuals and documentation on how to do so. If you have a device set to “PIO mode” and you are uncomfortable with changing these settings, contact a local PC repair technician or techsupport@presonus.com to assist you.


Dr J

I know I’m about 12 months late for this topic, but try turning off your network adapter(s). I get horrible popping and clicking if I leave my PCI card network adapter connection active when I try to record. Oddly enough, it doesn’t happen when I use a usb adapter plugged into a USB 2.0/Firewire combo PCI card.