problem importing waves


This is my first post, and I am hoping to tap your considerable knowledge. I am a just now starting to use N-track (or any other recording software for that matter). First some background: I have a dell P4 2.4 Ghz, 512K ram desktop and use the M-audio mobilepre sound card for recording. I have the latest version of the drivers for that software and the latest version of N-track.
Now the problem: I am having problems importing .wav files that I have created using the demo version of Leafdrums. Last night I laid down a drum track with the program, converted it to a .wav file and tried to import it into to N-track. I was notified that I had to import it at the same frequency or things would get ugly (i.e. the pitch and speed would be off, which I found out is true). So, I choose to convert the .wav file to the frequency that N-track uses (I converted a 44100 kHz file to a 48000 kHz). This took a long time and at the end, when I tried to play it I recieved a message stating that my AISO drivers cannot handle that particular frequenct and so on. Can some one give me some suggestions on importing this wave file. Thanks!

Set n-Track to use 44.1KHz sample rate (in Preferences) and don’t bother with the rate conversion, and you’ll be fine!

What lear said.

You won’t hear the difference between 44.1k and 48k. I can barely tell the difference between 44.1k and 96k. But I don’t exactly have “golden ears”!


MY opinion is that the ONLY reason to do 48k is if your soundcard does only 48k internally and does sample rate conversion on the fly to 48k no matter what. That would be a Creative card in most cases. Stick to 44.1k unless there is some other really good reason not it. Going 96k up to just before CD burning or compressed wave creation may be one good reason. As TG mentioned, there isn’t much difference in 44.1 and 48.

Thanks for your help. It imported fine, but was still much sped up in temp and pitch. I normalized it and that seems to have fixed it. I have to normalize it every time I open it, which is weird, but normalizing always sets it at the proped speed. Thanks again.

Is this not a 16 vs 24 bit problem ?

in what sense? can you explain?

Sound cards can work at different bit rates and different sampling rates. CDs are 16 bit, 44,100 hz, but most recording nowadays is done at 24/44, 24/48/ or 24/96. n-Track supports others as well. You want all the parts of your setup to be doing things the same way.

“normalizing” should not have helped your problem at all - nomarlizing is a term used to describe changes in overall volume of a track or a set of tracks. It only changes volume. Dunno why it would have affected pitch. You need to make sure that the properties of the file you are importing are the same as n-Track is set up for. What does leaf export at? Isn’t it 16/44? What do you have the sound card set up for? 24/48? that’s sort of like playing a tape recorded at 15 ips at 30. :)

It’s possible that the wave file header is incorrect or confusing, and that merely by rewriting the file n gets it sorted out. That’s a rather weak explanation, but I can’t think of any other reason normalizing would fix it.

Here’s a test. Drag the “end handle” to the left just a little, making the track a bit shorter. Then use Edit->Trim. That rewrites the file, and might fix the problem too. If so, then it’s clearly nothing to do with normalization per se (of which we’re sure, but this proves it).

Are you saying you have this problem when you record the file at 44.1 kHz, and import into N set at 44.1 kHz? If so, record a short file and email it to me (address in my profile) and I’ll analyze the wave file header and see if anything turns up.

I had that problem when I first got a Gina24 and ADA8000 Berhringer preamp. I set n-Tracks to 44.1k and recorded something. I then switched over to the Layla20 and played it back and the pitch and speed was all screwed up.

The problem was that there is a 44.1-48k switch that needs to be set to whatever the app is set to. The interface sends the data to n-Tracks and it accepts it as being whatever we said it was, so that’s how the file header get written. n-Tracks, because it is syncing to the soundcards clock, doesn’t care what the clock is REALLY running at.

Fixing the waves was easy. The headers needed to to be edited to say 48k. When a wave editor resamples and doesn’t do anything to keep the pitch or length the same as the original all that is done is changing the sample rate info in the header. It’s MUCH harder to keep the pitch and length the same, and errors and artifacts can be introduced.

The fix for my system was to set the sample rate switch on the hardware to 44.1k. Maybe there is a comparable setting in the Audiophile, software or hardware.

Did you get things working, thompsoi? ???