Problem...recording just stops

Haven’t used N in a while (been using mostly Audition). Tried using N to record a show tonight. It just stopped after about five minutes. Pushed record again, it stopped again after another few minutes. System is:
Vaio/Athlon 1.7Ghz Laptop
200GB firewire drive
Windows XP Pro SP1
*Layla 24 w/cardbus adapter

Was recording six tracks simultaneously. The audio that did record looks fine.

*Last time I used N I don’t think I had the Layla. I was using an M-Audio Quattro.

I finished the concert with Audition just fine (as I do most nights). I like Audition but I thought I’d try using N-Track again since it writes directly to .wav files which would save me some time and aggravation at the end of each night.

Anyone have any suggestions?
The Frugal Audio Guy

mine stops by itself too. I running a Layla as well actually, maybe it’s a sound card problem. the more tracks I run the sooner it stops. I’ve talked to Flavio about it but we didn’t come up with any solution at this point.

Is this V3.3 or 4?
I’ve done a few recordings in 3.3 where I’ve recorded a whole practice session
1 or 2 mics and a DI’d guitar and they ran for about 30 - 60 minutes no problem

Haven’t done much with 4 yet but have not uninstalled build 1680 and will be trying it out next itme I want to record some stuff


Version 3.3. I’m suspecting that it has something to do with the way I have the Layla control panel setup. I’m choosing the Layla within N as ASIO. I haven’t had a chance to check again yet. I’ve also recently written a batch file that shuts down a bunch of Windows services. I run the batch file before doing audio work to help keep XP stripped down to fighting weight. DOes anyone know if there are any particular services that N-Track might depend on?

The Frugal Audio Guy

I have a Layla20. I never got it working well with ASIO, and only when the 6.08 beta drivers was I able to use ASIO at all. Try it with the MME drivers and see if it’s any better, then try WDM.

In the Echo Console make sure Synchronize Wave Devices is NOT checked. If it is and you try to record on only specific pairs of inputs, not all 4 input pair, but pair 3-4 for example, n-Tracks will appear to hang when you click the playback/record button. The reason is that when Sync Wave Devices is on they all sync to the 1-2 pair, and daisy chain down from there.

I’ve never had sync issues between pairs of inputs when this was off. They all use the same clock anyway.

I also have a Gina24 in the same machine as the Layla20 (at home), and a Layla24 at work (not even in a machine right now), and they work about the same, though ASIO is definitely better with the Gina (I use the Pure devices on it almost exclusively). I don’t know about the Layla24 too much. Since it’s at work I don’t get to use it very much. It seems to be just about identical to the Gina24 in most cases, just more I/O.

Hey Frugal. I’ve done some experimenting this morning and here’s what I’ve figured out.

WDM has too much latency, even with the buffering settings really low-but is more stable.

ASIO is much better latency wise, but tends to stop recording after a while.

But the stopping seems to be linked to the Purewave mode and NOT the WDM mode in the echo console (Settings->Advanced).

so I set my ECHO console up with WDM mode and set up N-track with the 1-ASIO Echo WDM drivers and I recorded 10 tracks with LIVE input on all of them but no effects enabled yet. I’ve got the buffering at 1024 which is still much less latency than the WDM drivers and also BARELY perceptible-less buffering typically causing skipping of the audio and N can’t recover from it-I have to Ctrl+Alt+Del.

In Purewave mode I get about 6 minutes before it stops at 10 channels. At 16 it would usually stop even sooner. But using the WDM mode doesn’t seem to have any problems at all.

I’m going to try 16 channels now and see if it’ll go a while.

by the way, I’m running the newest build or V4

I just did 16 channels with LIVE input processing on them all without a hitch (had to increase the buffers to 2048 to accomodate all those tracks though)

the wdm mode in the asio drivers seems to be the ticket.

I suspected this. I think I still had the console setup in PureWave mode for all inputs. I just came off the road so my gear’s in one place and I’m in another but as soon as I can I’m going to try it as you described.