Problem w/ 4.1 Beta 2

.NET beta breaks other apps

I installed the 4.1 Beta 2 package and the new .NET beta release. n-tracks works just fine, but I noticed that some other apps began to mis-behave, in particular Datnz Retrospect Backup. It fails to initialize. It was clear that the new .NET release was responsible, but the problem went away after I un-installed and reverted to .NET 1.1. Hmm…

Jason

Frustrating as it is, unfortunately that’s the problem with beta software (.net). In this case, it’s not Flavio’s fault - just one of those things. In fact, even when .net is out of beta, I bet your backup software won’t work until the manufacturer gets it to work with the new .net version. (Check their website, there may be an update for it.)

We come across this kind of problem every day at work - the world of IT is full of non-standard “standards”.


Mark

When you installed .NET 2.0 you should leave the 1.1 version. Keep both of them on your system. Programs that want 1.1 will have it, and the n-Track Beta will have 2.0 that it needs.

Quote (andycoburn @ July 30 2005,04:28)
When you installed .NET 2.0 you should leave the 1.1 version. Keep both of them on your system. Programs that want 1.1 will have it, and the n-Track Beta will have 2.0 that it needs.



Installing .NET 2.0 left 1.1 in place (along with a hotfix). Likewise, getting rid of 2.0 left 1.1 alone.

I repeated the experiement, and 2.0 is causing the problem. I’ve contacted the Dantz folks about this but haven’t heard back yet.

I’ve decided not to install the new beta. The new Beta says it requires the new .Net Framework so you have to download it and install it. The new .Net Framework says it requires Windows Installer 3.0 so you have to download it and install it. The Windows Installer 3.0 warns you to completely backup your PC. I think I’ll stick with what I’ve got.

Quote (jwarren @ July 29 2005,16:04)
I installed the 4.1 Beta 2 package and the new .NET beta release.

Is the .Net v2.x beta required by n-Track Studio, or is v1.1 still ok? I’m only using v1.1 and I haven’t tried the beta of n-Track Studio yet. I’m just curious.

–Sean

.NET 2.0 beta is required for the latest beta n-Tracks…betat is beta and should be treated as such.

Quote (phoo @ Aug. 01 2005,11:53)
.NET 2.0 beta is required for the latest beta n-Tracks....betat is beta and should be treated as such.

Ok, thanks. I was just curious.

--Sean