problem with live input

Hi all, this is my first post to the forum.

I have installed the last version of n-track 4.05 (build 1845) and I have a problem with the live input.

I open a new VST instrument (native pro 53).

If I click with the mouse in the piano of this VST (in the monitor screen) I hear the sounds , but I can´t hear anything when I play from my external midi piano.

I only hear what I´m playing from my external piano when I start recording.

Can you help me?


Sounds like a monitoring problem.
Don’t know much about midi unfortunatly.
I’d goof around with the soundcard settings, and the monitor settings and see if you can’t fix it.
I had the same problem once, I couldn’t hear my guitar through the computer speakers…if I was recording, ya, if I was playing a track, ya, it worked. But if I was just sitting idol, no.
Then I got to thinkin, what do I need to hear myself through the speakers, if I’m not recording or playing? Is the sound at that point really important? I came to the conclusion…no, since I can hear it easy enough through my guitars amp, hence the end of that problem.
For you though, an the whole midi keys thing…I can see why it would be nec, to hear yourself without palying or recording…at least to get a feel for what’s gonna come out!
Hang in there bro, lotta knowlegeable people in here…someone know’s the answer and time will tell if they will…


Hi Jeremys and thnx.

The problem is that N don´t receive any midi information from my midi keybord untill I press the REC button in N-Track.

Once that I´m recording, I have no problem.

This didn´t happen with anothers 4x versions of N. Is just a problem of this last version.

My audiocard settings are OK, I play without problem in Fruityloops using the latests ASIO drivers with a good latency of 10 ms.

I suppose that it is a problem of this version of N-track.

Anyone else has this problem?

Thnx all.

Make sure the “LIVE” button is lit up. Also, try clicking the Midi Echo button off and on.

Hope that helps.

Yeah, I haven’t heard too many good post about this version. Still seems a little shakey from what I’ve read so far.
I’d stick with a version you know works on your system till all the bugs are worked out of this one.
Although based on your post it doesn’t seem like it’s the version itself, since your not crashing, or
having pops click ect. But rather a setting of some kind that was on the previous version, that you may have to set manually on the newer one.
Myself, been using 2.3 for 6 years now without incedent, other than the ocassional question, “what does this button do?” :laugh:
There’s so many things I don’t use since I only record live instruments, it’s just a glorified digital 8 track recorder I use to preserve ideas till I can afford to go into a studio that has the 1/4 in reels I prefer.
…now hold on a second…you mentioned everthing works fine in fruity loops…that’s settin’ bells and wistles off for me.
Ntrack and fruity are notorious for having conflicts, I have personally been a witness to that. For some reason my older DAW wouldn’t let me use the two programs simetaniously, something about only having one soundcard and two apps going I think…always caused problems, for me anyway.
Perhaps Fruity is your default midi device? So N can’t complete it’s funtion until it is made the default…again I know nothing about midi, just thinkin’ out loud. Also it would be helpful to list your systems statistics. IE Operating system, processor speed, soundcard…ect.
this will give a potential reader more to go on, and maybe someone with experience with simular hardware and software will chime in.

hang in there…

Thnx cmw and Jeremy.

I have finally fixed the problem (with the help of Flavio :) )

This is the post that I received from him …perhaps it may help anyone else with a similar problem.

"You can hear VST instruments output when in Live input processing, i.e. when the Live button on the toolbar is pressed. Also make sure that the “Keep devices open” option is set in the File/Settings/Preferences/MIDI/MIDI devices dialog box."

All the problem was the “keep devices open” option was off after I instaled the 1845 N version

Thnx flavio.

Answering to Jeremy. (and sorry for my english :))

I use N-Track Studio from the the firsts ones versions when it was only called “N-track”.

Each new update has been better than the previous one. Sometimes they came with bugs but flavio is really fast solving they.

At the begining , like you do, I started recording only live instruments , that is the reason why I started using Fruityloops. (first recording the drums with FL and then exportin each .wav to n-track)

Currently I have a Pentium III 933Mhz Celeron, audigigy2 and 1Gb Ram.

This last version of n-track let me record everything inside (for example you can record a guitar and the main voice and after that you can add the drums and pianos with a VST instrument as sampletank)

Working with FL as a VST of N doesn´t let you use the secuencer of FL so you only get 16 new tracks.

In the other hand the secuencer of N is not so powerful as the FL one.

So I everytime I start recording a new song a I have to decide if use one or other secuencer. Usually if the drums line is complicated I start with FL. if not , I do all the work with N-T.

In conclusion, N-Track changed when introduced the ASIO drivers. I can handle more than 30 track with effects with a really low latency. (you can play a battery with the keyboard following a guitar live recorded line)

I recomend you to update your N version and use a sound card that support ASIO dirvers. Also get the most amount of RAM that you can. It´s incredible what a bit more of RAM can do.