Problem with "wave devices advanced settings"

“Keep Audio Devices Open” issue

If I go into “Settings->Audio Devices->Advanced”, and uncheck “Keep Audio Devices Open”, hit “OK”, hit “OK” again (to get back to the settings menu), and then go back into “audio devices->advanced”, the “Keep Audio Devices Open” is checked again.

This is creating quite a problem for me when I try to use Cool Edit. It’s not allowing me to play the tracks. I can only guess that it’s n-Track keeping the devices open.

Is this something related to my using ASIO drivers?


I could be wrong but I think this is another quirk of ASIO, that they are always open. If that’s the case then what you se would be expected.

That’s interesting. What’s the difference between ASIO and WDM drivers? The drivers I got for my SeaSound Solo were written by an outside party (since SeaSound went belly up), so I’m not sure how well they’re going to work. I just upgraded to Windows XP on my studio PC, so I’m at their mercy because the only drivers the original company came up with were for Windows 98.

The drivers support both ASIO and WDM, but I can’t seem to get the WDM drivers working. It keeps telling me that the output format isn’t supported. So, I switched back to ASIO drivers. They seem to work okay (except for a little jumpiness during the start and stop of playback), but then I can’t use any outside audio programs.

Any idea why the use of the ASIO drivers would require keeping the device open?


Yes something to do with ASIO.
If I use WDM I can uncheck that kepp audio devices open box.

If I use ASIO it keeps going back to checked.

It is an ASIO thing where only 1 application can access the ASIO device at a time

(if you open winamp or something like that it won’t playback either)

ASIO works better for me so I get aound this by using my Edirol DA2496 in n-Track with ASIO and using my SB Live for playback in Cool Edit.


It keeps telling me that the output format isn't supported
When does that happen? If it's not until you try to play or record, try choosing WDM and then clicking the hammer under the meters and trying each format (24 bit, 24-bit left justified, etc.) Be sure to set it for both record and playback. (Turn off the record meters and LIVE mode before choosing WDM. I think that happens anyway, but do it just to avoid problems.)

Rich - good idea! I’ve got a built in sound card - I might give that a spin for my out side apps.

learjeff - I’ll give your suggestions a try.

Thanks, guys! I’ll let you know what I find out.

Well, WDM drivers - right out. BUT, I’m farily convinced that the “Keep audio device open” setting issue is a bug (or missing feature). I’m using the ASIO drivers in fruity loops and it has the same option. It works there. I can use fruity, stop the playback, go into another audio program (like Cool Edit) and things work just fine there, so I’ve ruled out it being an ASIO thing.


To the best of my knowledge, CoolEdit AKA Adobe Audition DOES NOT support ASIO. You must use WDM or MME drivers with those apps. I posted that question on the Adobe forum and the reply was…“NO Audition does not support ASIO at this time.” You must be using the WDM driver for CoolEdit and your soundcard driver is not making it available while n is running?


PS Someone said above that ASIO is always open. This is correct. However, the host application must be able to release the driver in the background when another app has the focus. That’s probably why you can’t uncheck “Keep devices open” in n-Track. I think its part of the ASIO spec.

PSS You might try adding more channels. I see on your graphic that you have 2 IN’s and 2 OUT’s selected. Add a couple more and see what happens.