problems with 24-bit recording

soundcard driver and synch issues

so I noticed there were a few threads floating around right now that are describing similar problems, but instead of hi-jacking one of them I thought I would just start a new one…

OK, I’m using n-track v4 (a few builds behind the most current) and I’m having trouble trying to record 8 tracks simultaneously at 24/44.1

I’ve tried using both WDM and ASIO drivers for my soundcards (a pair of Delta 44s). With the ASIO drivers, there are are pops and clicks in recorded audio, even with max buffer setting. With the WDM, there are no pops and clicks but there is noticeable drift between the tracks after a few minutes.

What gives here? Do I need more processing power? I have a 1.9GHz P4. I would think that should be enough.

Should I try to resolve the synch issue with WDM or the pops and clicks with ASIO?

I’m gonna go back and double check some of the settings mentioned on the other thread…

thanks.

Can you be more specific about the trouble you are having?

keep in mind that I am recording 8 tracks simultaneously… But the problem is that I’m getting pops and clicks in the recorded audio using the ASIO driver, and I’m having sync issues with WDM (noticeable drift after a few minutes, no pops and clicks though). So basically, neither one is working for me.

So, its either figure out how to sync with WDM, or figure out whats causing the clicks with the ASIO.

I updated to the latest n-track build, and I opened a project that I’ve been working on and played it back with the WDM drivers. The ASIO didn’t work so well, they gave me very jerky, stuttery playback.

I have been at this all day, trying every configuration/system tweak that I can think of. Nothing really seems to help. Maybe I need to update/reinstall drivers? I checked M-Audios website, and they don’t have ASIO drivers. I was thinking of trying ASIO 4 ALL…

by the way… I’m even getting the pops and clicks when I record w/ASIO in 16-bit now.

Where do you have ASIO set buffer wise? Set it to something crazy high like 100 or 200 ms and you should have no pops or clicks unless your machine is an absolute dinosaur or something else is awry. There are certainly ASIo drivers for a M-Audio Delta 44s. ASIO is included in the WDM driver package. (I have a feeling you are adjusting the WDM buffers and not ASIO. Be certain you are tweaking the correct thing.) As for WDM, uncheck “Keep devices open” in the audio device properties and I bet you will be fixed. (Where’s that wiki at?)

Now I may be lying, but I remember reading somewhere that you should adjust the buffer size in the control panel of the interface, not from N-track preferences if you’re using ASIO drivers.

varakeef is right, you have to adjust the ASIO buffer settings in the ASIO control panel on the soundcard, and the problem is that you can’t set it any higher than 2048 samples. I think if I could set it just a little bit higher, then I would be OK. Unfortunately, I can’t.

I’m pretty sure I tried recording with “keep devices open” ticked and unticked, and I had sync problems with both of them. I’m not sure though, I tried so many different things. I’ll try again with the new build.

Maybe I need to re-format the partition and start over from scratch.

TF,
Do you have both deltas synchronized (the clocks for the A/D converters that is) in any way?
I wouldn’t know if that is possible at all, but if they’re not, you cannot use them simultaneously without running into sync trouble.

I don’t know for sure. There is an option in the Delta 44 control panel to sync multiple cards, which I have selected. The thing is, they are perfectly synced if I use the ASIO drivers, so I know its possible.

How can I determine the speed of my hard drive? I have two hard disks, one of them is a newer WD which I know is at 7200 RPM, and the other is the Maxtor that came with the PC, and its about 3 years old. I’m trying to determine if I would get a performance boost from putting the virtual RAM on the Maxtor or something. I tried recording directly to the Maxtor and still got some pops/clicks.

If I have 768 MB RAM, how big should my pagefile be? I currently have it set to 1150 MB.

anybody think this could be an IRQ conflict?

another thought… is it possible to set the ASIO buffers too high? I’ve never actually recorded with the buffers set this high before, although I have been using these settings to mix…

anybody have any ideas here? I spent yesterday evening messing with PCI bus latency settings, and nothing… swapped one of the cards to a different PCI slot and disabled a few USB ports to free up IRQ resources, no difference.

I really think the problem is the ASIO drivers suck.

I may just ditch these cards and get a firewire interface, something like the Yamaha i88X. Firewire interfaces will work with n-Track, right?

I still think your cards aren’t properly synchronized.
At least that would explain all the problems you describe:

When using ASIO, both cards use the same driver (you can only use one ASIO driver at a time, right?). When you start recording, the lag between the two cards will start growing. Once the lag “outgrows” the buffersize, you get a pop/crackle/dropout.

When using WDM, both cards have their own driver, so you’d get the situation where the lag grows to values that you’ll be able to notice very well.
But you won’t necessarily get the crackles.

If I’m right, you won’t have problems if you record 4 channels with one card (using ASIO and with the other card disabled).
If you record 5 channels using just one channel of the second card (still using ASIO) you would get crackles.

If I’m wrong, don’t ditch the cards. Send them to me :)

EDIT: I took a quick look in the 44 manual and I don’t think it is possible to sync two deltas: no s/p dif or word clock i/o.

according to some other users at homerecording.org, they have been able to sync two Delta cards successfully, although I can’t imagine what I’m doing differently…

quoted from another board:

<!–QuoteBegin>

Quote
XP uses kernelsync so you don’t need to lock the cards with the S/PDIF ins n outs…on the delta control pannel make sure both cards are set to INTERNAL for master clock and MULTIPLE CARD SYNC under driver devices. I have my 3 delta cards locked this way and everything works fine.


I can’t even get it to work at 16-bit now. I’ve even rolled back to an older version of n-track that I’ve recorded a few projects with. I think I may need to re-format the partition and start from scratch.