Problems with multiple instances of sfz

NTrack 4.1 crash on save, multiple sfz

I’m having crash trouble when using multiple instances of the sfz soundfont player in N 4.1 (build 1980). I first encountered the problem in N 4.0.5 and upgraded to 4.1 to no avail.

Has anyone else seen this?

I’m trying to put together a handbell piece, and I have three different soundfonts for the different performance techniques (ring, thumb pluck, mallets) that are all needed for the piece. I have three MIDI tracks and I’m trying to route them to three sfz instrument channels.

All is well with one instance of sfz, but soon after adding the second or, worse, a third, N crashes on save or on exit with the dreaded “N-Track encountered a problem and needs to close” dialog.

The crash doesn’t happen every time, but with three instances of SFZ, I only have to click save a couple of times before it goes down.

As long as I stick to just one sfz, everything works fine.

I’m running:
N 4.1 (build 1980)
Windows XP SP2
M-Audio Firewire Adiophile (24-bit)
Sfz (dll reports version 2.0.0, downloaded yesterday)

Why don’t you render the 3 tracks to .wav files instead of trying to run 3 vst instruments? It will free up lots of processor power for other things.

You can keep the MIDI files (just mute them) and if you need to change anything, re-render it to a wave file.

May be you could combine the three soundfonts to one with three programs?
You can have different programs for each midi channel in sfz, so you’d only need one instance.

Test-wise you could try sending the midi through midi yoke to three stand-alone instances (or three vst instances in another host), to see if the problem goes away then.

42,
I was having a similar problem until I realized that ONE instance of sfz has SIXTEEN channels. I think you can route Midi1 to channel 1, Midi2 to channel 2 and midi3 to channel 3 etc. That way you only use one instance of sfz up to 16 channels.
I think that is correct. Someone tell me if I am wrong…

cliff

I think I said what hansje said…sorry.

I’ve seen the same problem with V3.3: two copies of sfz causes crash.

Seems that I did this some time ago without problems, though.

Does not checking “Multitread audio processing” have any effect on this, or changing the DSP priority?

Thanks for all the suggestions. I ultimately finished the project I was working on by rendering each track to a WAV, as Jeff suggested.

I fiddled with sfz a bit, but it doesn’t look like the free version of sfz supports multiple soundfonts loaded simultaneously and I can’t find any documentation for how to create a single soundfont with mutiple programs.

I will play with this some more this weekend, and I’ll try changing the thread settings to see if it helps.

I use the Edirol Virtual Sound Canvas (VSC) which allows for 16 different inputs. I thought that SFZ was similar in that you could use up to 16 channels.
You probably already know many of the following steps, but who knows, maybe there is another newbie (like me) who is having the same trouble. It took me a while but now that I am getting the hang of it, it is the coolest. I will try to tell you how I do it.

After you have added SFZ as a new instrument:

Record MIDI trk 1.

Right click on MIDI trk 1 mixer, look at “output to…” and make sure it is going to SFZ

Again, right click on MIDI trk 1 mixer.
This time click properties.
Click Channel 1 (to correspond to the channel on SFZ.)
Click the up arrow on the “bank” button so it reads 0-General Midi.
Make sure ‘output port’ is SFZ.
MIDI trk 1 is now playing through SFZ Channel 1
-------------------------------------------------------
Now,
Click ‘View’, 'Mixer"
On the Synth mixer, open the effect SFZ.
Change the channel to Channel 2
Change the Program to your choice
Close SFZ.

-------------------------------------------------------
Record MIDI trk 2.

Right click on MIDI trk 2 mixer, look at “output to…” and make sure it is going to SFZ

Again, right click on MIDI trk 2 mixer.
This time click properties.
Click Channel 2 (to correspond to the channel on SFZ.)
Click the up arrow on the “bank” button so it reads 0-General Midi.
Make sure ‘output port’ is SFZ.
MIDI trk 2 is now playing through SFZ channel 2
----------------------------------------------------------

You can do this for all of the channels except channel 10 which is the channel for drums.

Generally speaking, I try to route the MIDI trk number to correspond with the Channel number on the Synth. I just tried this with three channels and it worked fine.

I am pretty new at this stuff (MIDI & SoftSynths) but I think I have given you all of the correct steps. In any event, I am just about (not quite) 100% certain you can do at least 15 different channels with ONE instance of your Soundfont player.

Hope this helps

cliff

:cool:

Quote (phoo @ Dec. 02 2005,18:34)
Does not checking “Multitread audio processing” have any effect on this, or changing the DSP priority?

Nope. No effect. The crash actually occurs when I save the song or when I exit n-Track, so I would not have expected this to make a difference.

I did play a bit with multiple programs, and this does work. The sfz will play sixteen different MIDI tracks to sixteen different programs easily. However, this only works with the free version of sfz if all of the programs you want are in the same soundfont. In my case, I’ve got three different soundfonts, each with a single program. The documentation of the sfz web site clearly states that the commercial version (sfz+) will load multiple soundfonts, but the free version will not.

So, until I find the tools and the motivation to edit my soundfonts to put the programs I need in the same font, I’ll just record one track at a time to WAV.

Thanks, all.

James