Problems with my Layla3G

I just installed my new Layla3G audio device. It appears to be working correctly from it’s Concole app & I can hear microphone input, but when I try to record in nTrack I get an error trying to open the wave input device. I’ve tried setting various audio formats (which it tells you to do) but nothing works. I had a similar problem with the Gina24 when I selected 24 bit, but 24 unpacked left-justified always worked.

I’m using the WDM drivers & the device seems to be working correctly. Any ideas would be appreciated as I was hoping to use this device for a live recording in a couple of days.

Try the MME devices since you are doing 24 bits (plain stereo, not justified or unpacked - though I don’t know if that maters) and using PureWave (Echo’s ASIO type devices). I know only one of the types (WDM, ASIO, MME) will work because of the way Echo implemented PureWave.

I mentioned this in the other part of the forum. I’ll be getting into this in the next week or so. So I should have a better answer in a few days. I keep forgetting what the trick is. I’ll post what I find the this thread.

I’ve never had a problem doing 96/24 with the WDM drivers with my old Gina24 (which I’m selling). I’m not familar with MME. Echo only gives me WMD & ASIO drivers I thought?

I’ve contacted Echo this morning & they don’t have any idea what’s happening. They want me to try different audio software (a total bummer).

I may try the ASIO drivers but I’d prefer to use WDM. I’ve written Flavio to see if he has any ideas.

Quote (Mr Soul @ Sep. 14 2005,11:57)
They want me to try different audio software (a total bummer).

Isn’t the perfect solution?
And the IT workers (myself included) claim that they don’t know why the users complain about support …

Did you try different software? That would rule out it being a hardware problem. Seems like a reasonable request. Your other post implied that you thought it was a hardware problem. This is a way to help rule that out.

<!–QuoteBegin>

Quote
I’m not familar with MME. Echo only gives me WMD & ASIO drivers I thought?

Drivers yes. …MME are the devices options in the n-Tracks defaults. You have them, though they my not show up if you have unchecked “show MME devives”. That check should default to being on, so those should show up.

<!–QuoteBegin>

Quote
Did you try different software? That would rule out it being a hardware problem. Seems like a reasonable request.

This reminds me of a recent story. I was setting up a wireless network in my house (studio) and I was having problems with a NetGear wireless adapter, i.e., it crashed Windows 2000! I called their tech. support & got a very fine fellow (in India). He asked me if I had another computer in my house that I could install the card into & see if Windows crashed. If it did, then it was mostly likely the NetGear card that was the problem. Needless to say, I told him that I wasn’t going to do that.

It would be a reasonble request if 1) nTrack didn’t work with my Gina24 & WDM, and/or 2) the WDM drivers for Gina24 & the Layla3G were radically different (they are not).

<!–QuoteBegin>
Quote
Your other post implied that you thought it was a hardware problem.

I was concerned that it might be, but playback works fine, so I doubt that the Layal3G is bad.

Flavio contacted me & gave me some things to check, but he asked me to try 4.1. So that will be the “other” software I’m willing to try - 4.1!

Echo Audio ships Tracktion but I hate that UI. I still have an earlier version on my machine & I never was able to figure it out.

Does anybody here have a Layla3G that they are using with nTrack?

Phoo,
I agree with you that would be a reasonable request but:
1) Echo support team should download NTrack demo version and test it.
2) Echo support team should have a much more controlled test environment than the final user.
So, I can agree with one answer like: “We didn’t have problems with NTrack” or “we had problems with NTrack”.

Cheers,

<!–QuoteBegin>

Quote
I agree with you that would be a reasonable request but:
1) Echo support team should download NTrack demo version and test it.
2) Echo support team should have a much more controlled test environment than the final user.
So, I can agree with one answer like: “We didn’t have problems with NTrack” or “we had problems with NTrack”.

My dealings with Echo is that they do use n-Tracks, though not officially, and they do have a more controlled test environment, yet like any company can’t cover the full range of hardware available. No company can. Their request is absolutely reasonable given the scenario, and Mike never said in this post that he did try other software. They wouldn’t have asked him to do that if he had told them that it worked fine with other software. Not all software it creted equal as we all know. Even the netgear scenario is reasonable to ask when trying to rule out hardware faults.

Mike’s problem sound exacty like the config issues I have with the Gina24. There’s no doubt in my mind that it’s the same thing, even if his Gina24 use to work fine – installing a new card may reset the defaults. It’s frustrating to find the right combo or input and output devices and config, which must usually be matched (same type for input and output, be it WDM, MME, DS, GuitarPort or ASIO…whatever), and it must be hooked up with what ever the driver supports under the hood. The Gina24 and LaylaG3 drivers, which similar, are not the same drives as are the Gina24 and Layla24, but likely do have the similar limitations and the docs point that out.

Gina24 drivers under WDM Wave do not support all applicates at 24 bit, but should under PureWave. I can’t speak for the LaylaG3 and the ReadMe PDF doesn’t mention PureWave at all as does the Gina-Layla24 PDF, but the symptom sure seems the same.

This is explained a bit in the LaylaG3 Use Manual under Appendix C: http://www.echoaudio.com/Downloa…ual.pdf

Also look in Appendix E: PureWave versus WDM

The Wave Device Configuration (Echo Console) is where to select PureWave instead of WDM, and when that is done select MME in n-Tracks. (I’ll look into this tonight when I get home as the Layla24 in my work machine is now in the test lab…humble grumble…I’ll get it back…SOOOOOONNN).

I agree that we would expect n-Tracks to work in 24 bit mode with WDM without having to do what the manual suggests, but my experience is that their workaround to use PureWave works with n-Tracks and allows me to record at 24 bits with my Gina24. Look at the list of applications in the docs that Echo suggests to use with PureWave. You’d think most of those would work in 24 bits with WDM as well.

Phoo - I appeciate the attention that you’ve given this thread & to my problem.

Echo was noncommital on nTrack, i.e., they believe that Echo owners use nTrack, but they wanted me to use Tracktion.

<!–QuoteBegin>

Quote
Mike’s problem sound exacty like the config issues I have with the Gina24.
Yes - I believe it may be a config. problem. The only thing Echo could think of me trying is to make sure that PureWave wasn’t turned on (even though they indicated that WDM is the default). Their only other suggestion was to try a different version of nTrack or different software. They didn’t seem to want to log the error, or talk to their engineers, or to try nTrack.

You set PureWave in EchoConsole and MME for both in and out in n-Tracks and it didn’t work?

We should be able to compare screen shots of the configs when I get mine going in the Gina24 again.

I did try PureWave/MME and I was getting input to nTrack but the recordings were all garbled and slowed down like they were in the wrong frequency sampling. However, when I changed the buffering to HIGH (I had it on MEDIUM), things were OK. The only problem now is that I’m getting no Audio (through the Layla3G) while I’m recording?

I also tried the ASIO drivers & they appear to work somewhat, i.e., I get input into nTrack. However, I’m not familar with ASIO so I don’t know how to set the bit-depth for example.

I don’t know. I use PureWave and MME and it works fine, just like it did before.

This is my whole fullsize screen with most config dialogs open. Maybe something will click.

The screen shot is pretty big - dual monitor and 1600*1200 – the file size is about 700k.

Thanks phoo! I have it configured exactly how you have except that I don’t use digital inputs. As I indicated, it’s working now but I don’t get any monitoring while I’m recording or at rest.

That would be settings in the EchoConsole mixer.

Look over on the far right of the big screen shot.

Click on the output that you are using for monitoring (A 1-2 is selected in the screen shot).

Unmute whatever inputs you want to monitor directly to that output (screen shot has Analog 1-2, Digital 1-2 unmuted, and playback to output 1-2 unmuted).

Each output pair has it’s own monitoring settings.

<!–QuoteBegin>

Quote
Click on the output that you are using for monitoring (A 1-2 is selected in the screen shot).

Yeah - I’m not sure I fully understand those monitoring buttons. I’ve got 4 of them on my Layla3G.

I ran the unit through it’s paces last night - recording 3 long sets. It will be interesting to see how it came out. I’ll keep you posted.

I’ll make a screen shot or few of the Layla20 tonight.

I use the Layla20 for an odd combination of monitoring. I like it better than the Layla24 for tha since it has 5 pairs of analog outputs and the Layla24 has ony 4 pairs. Ther are other tradeoffs that make the Layla24 better though than the Layla20 (other than the 20 and 24 bits difference).

The mixer almost idenitical to the Layla24 and I assume the LaylaG3 (I haven’t seen any of the G3 versions in real life yet). It’s pretty easy once you get it, but it IS confusing at first and I don’t think the docs go into enough visual detail to ease the pain.

Man - I just don’t understand this new unit. I recorded almost 3 hours of live music at 44.1/24-bit and when I play it back it’s chipmunk music. How on earth did this happen?

When I play existing nTrack projects, 44.1 or 96, they all seem to work just fine.

Is there anyway I can salvage what I did, i.e., can I resample it or something? Also, how do I get this thing to record correctly?!?!

I never had any of these problems with the Gina24.

<!–QuoteBegin>

Quote
when I play it back it’s chipmunk music. How on earth did this happen?

That’s mentioned in the docs, too.

It can happen if system sounds are turned on and one is triggered to play while recording. Any sound that plays may degrade the clock to the least common sample rate. If you are recording at 44.1k and a sound get triggered that is a 22k sound then the clock drops to 22k, but recording continues as-is. You end up with a recorded sound that is double speed when it’s played back. I’ve hit it once in the last year. If all system sounds are disabled the is should never happen (that’s the theory).

Anyway, that’s what it sounds like.

The other thing is that the sample rate in the EchoConsole might not match the samplerate in n-Tracks. I don’t know if that’s possible when not using the digital inputs, but that’s the problem I needed to talk to the Echo tech about. It was directly related to the preamp and digital inputs being set to 48k and n-Tracks blindly recording at 44.1k because that’s what I though the samplerate was. n-Tracks can’t tell what the soundcard’s clock is, so you have to tell it that the soundcard is using whatever. (It’s sort of like ASIO buffer settings.)

That’s the only two times I’ve run across something like that.

The first one will knock you for a loop because the sample rate can change WHILE RECORDING. A wave might be fine - in pitch - correct speed - then all of a sudden it jumps pitch and playback speed midstream. There’s got to be some new explative for when that happens because none of the existing ones seem to fullfill the feeling it creates.

If the whole wave is consistently out then it should be salvageable by doing a samplerate conversion in a wave editor…maybe. It might take some experimentation to get it right. The conversion will probably be to and from know normal valid sample rates, which helps.

Anyway, it’s a two step process. The file format says the sample rate is one thing but the data is not of that samplerate. First you have to get the wave header to match what the data really is. Then you have to resample it to be the format you want.

If you recorded at 44k and it’s playing double speed try converting the sample rate to 22k so playback will be at half speed and lower in pitch - don’t preserve either. You’ll end up with a wave that is a 22k wave but plays at the correct pitch and speed (hopefully).

That’s not the end of it. You will still need to resample it so the final format is back up at 44k. That will mean converting it back to 44k in such a way that the pitch and length ARE preserved. Once that’s done it should be fixed. Of course, that will only work if the file is playing at exactly double speed.

Yes, that’s all a pain and may not work.

Right - that’s exactly why I turned off the Windows sound system to no sounds, as the manual instructed. Can I prevent this by locking in the sample rate? If so, that’s what I’m going to do.

I’m trying the resample route. When I resample to 22K, it won’t play on my system. I’m not sure how to re-sample it back to 44.1K and keep the speed the same?

I might add that this never happened with the Gina24 (which I’m still going to sell if anyone is interested).