RAM or CPU Speed?

Which is most important for nTrack?

I’m running 4.1 on an older PC (Celeron 1GHz, 256MB, Win 2000 Pro). It runs fine, but I quickly run into issues when working with a song that has more than 3-4 tracks. My question is, will increasing the RAM to 512MB give me a significant improvement in performance, or am I stuck until I get a machine with a better CPU?

Thanks.

The problem also would be the throughput of the machine.

But I think you can gain a lot by putting more RAM in.

256 is a little on the thin side.

W.

Generally the number of tracks is limited by the hard drive speed and the number of effects is limited by the CPU.

In general, provided that there is enough RAM for your PC to run comfortably it probably won’t make a great deal of difference to the number of tracks you get. (ie as long as the O/S isn’t swapping to disk all over the place). Audio recording reads/writes directly to disk so that is why drive speed is critical.

Saying that you should be getting much better performance than that (assuming you’re using 44.1/16). I used to do better than that on my PII 450 (10 tracks). Of course you haven’t told us what your cpu is running at and whether you are running any effects.

Something is wrong. Have a look at the music tweak sites, get rid of all unnecessary processes in memory, disconnect from the Internet, etc.

I can’t remember if Win2k enables DMA by on hard drives by default. Check that it is enabled as it can make a significant difference.

HTH

OK. Let me provide a little more detail…

The PC is an older Dell (OptiPlex GX1). It originally was a PIII 500MHz (I think), but the guy I got it from put in a Celeron 1GHz CPU. It has 256MB RAM. The hard drive is a 7200 RPM 40GB Western Digital drive that I just put in it within the last year. OS is Windows 2000 Pro. I’m not sure whether direct DMA access is enabled or not. The sound card is an external SoundBlaster MP3+ device which is connected via a USB 1.1 connection. I am recording at 48khz sampling rate because I read somewhere that this was the correct sampling rate for this device. I don’t know anything about the different drivers in nTrack. I think I’ve seen options for Microsoft Wave Mapper along with MME and WMD versions of drivers for both the SoundBlaster MP3+ and the onboard sound that’s on the motherboard. I’m don’t have access to the machine right now to check, so I’m not sure which drivers are selected. I also have a older SoundBlaster AWE32 Value Edition card laying around that I’m not using.

If any of this info gives you enough to provide further suggestions, they would be greatly appreciated. Thanks.

In a nutshell this is what contributes to what:

CPU: The number of effects you can run at one time
Hard disk: The number of tracks you can record/play back at one time
RAM: RAM will reduce latency… not such an easy thing to explain. More RAM makes everything smoother as the hard disk has to work less in paging, if using VSTi or samples, again, less hard disk work.

Any more, a plain old 7200RPM ATA100/133 drive is plenty fast for most things. The RAM and CPU are more subjective. I have 1.25GB of RAM on my DAW because I do a lot with samples and it pays to have samples loaded into RAM. The CPU I am not so nuts about. I have a 2.8Ghz P4 adn have never really maxed it out. The type of effects you use really determine how much the CPU is taxed. Those convolution reverbs are pigs where as other effects might not be so tough. Unfortuatly it is more of an art and experience type thing than a science thing.

I would attack it this way… take a look at Task Manager adn see what is being eaten up. Is the CPU constantly pegged at 100%? Or is the RAM contantly filled? is the page file gigantic? All of the above? This will tell you much more where to focus your upgrade dollars than a general rule of thumb we could give you.


Also, always always always enable DMA on modern hard drives… always.

<!–QuoteBegin>

Quote
ATA100/133 drive

Win2K does NOT enable support for ATA higher than 33 by default. There’s a registry key tweak to turn on on higher speeds.

Quote (Bubbagump @ Nov. 25 2005,14:11)
I would attack it this way… take a look at Task Manager adn see what is being eaten up. Is the CPU constantly pegged at 100%? Or is the RAM contantly filled? is the page file gigantic? All of the above?

Here’s what I get in Task Manager while recording another track in a song that already has five open tracks. I don’t see a problem according to this, but when I listed to the new track. The sync with the existing tracks get further and further out of whack the longer it plays.

<!–QuoteBegin>

Quote
It runs fine, but I quickly run into issues when working with a song that has more than 3-4 tracks.


OK. We’ve misinterpreted this question.

Here’s the giveaway in ddecjc’s last post…

<!–QuoteBegin>
Quote
The sync with the existing tracks get further and further out of whack the longer it plays.


This is a sync problem not a resources problem.

ddecjc, try recording a couple of tracks at 44.1kHz. You are right about some creative cards preferring 48k but yours may not be one of them.

Also in the Preferences in n-Track make sure you “Use System Timer” is unticked for both recording and playback. This will make n-Track use the Wave Timer.

Also try both settings of the “Keep Audio Devices Open” setting in “Advanced” under “Audio Drivers”.

HTH


Mark

EDIT::: Ahhh. I see that you’ve started another thread about this.

Hi Dave,

One other thing to check is which wave devices (in the Settings–>Recording Settings–>Audio Devices dialog) you have selected.
If you’d have both the onboard audio and the creative card selected here, you might run into sychronization problems.

I’m just guessing. Good luck!

<!–QuoteBegin>

Quote
One other thing to check is which wave devices (in the Settings–>Recording Settings–>Audio Devices dialog) you have selected. If you’d have both the onboard audio and the creative card selected here, you might run into sychronization problems.

This is very true. When devices for more than one physical sound card are selected and when NOT using the system timer there is no way to determine which card’s timer is getting used. If n-Tracks was smart it would use the timer from the actual card being used for recording and playback. I don’t know if it can be that smart in all cases. I suspect it does it does a good job but whatever it does the users can’t select the timer on a physical card basis except by selecting just the devices from one card at a time (deselect all others in the preferences). Folks with just one card in their machine don’t have to worry about this at all.
Quote (hansje @ Nov. 27 2005,06:13)
Hi Dave,

One other thing to check is which wave devices (in the Settings-->Recording Settings-->Audio Devices dialog) you have selected.
If you'd have both the onboard audio and the creative card selected here, you might run into sychronization problems.

I'm just guessing. Good luck!

Thanks for the info, but, unfortunately, I don't that's the issue. For both input and output, the only device I have selected is "MME - USB Audio."

Dave - unfortunately your computer is slow & is low on resources by today’s standards. However, you should be able to do more than 3 - 4 tracks of 44.1/16-bit audio. I would not recommend putting any more resources into this computer because it could be expensive & unproductive.

However, you might want to try some of the standard Win2K tweaks to help you get some more CPU cycles.

I just noticed you said you are using a USB soundcard, and have a PIII 500…

I had a USB card (tascam US428) and had all sorts of problems with pops and crackles and it worked fine on my flatmates PC.
Kinda narrowed it down to the fact that the USB controller on my mobo (VIA) was the culprit and a lot of people had had similar issues.

I ended up swapping the soundcard for a PCI card instead and paying the difference and haven’t looked back.

It may be something similar causing your issues.
Are you able to try your soundcard in another PC and install N and see if it behaves the same? Might isolate whether the issue is with the soundcard or the PC…

Rich

Quote (RichLum @ Nov. 27 2005,22:55)
I just noticed you said you are using a USB soundcard, and have a PIII 500...

I had a USB card (tascam US428) and had all sorts of problems with pops and crackles and it worked fine on my flatmates PC.
Kinda narrowed it down to the fact that the USB controller on my mobo (VIA) was the culprit and a lot of people had had similar issues.

I ended up swapping the soundcard for a PCI card instead and paying the difference and haven't looked back.

It may be something similar causing your issues.
Are you able to try your soundcard in another PC and install N and see if it behaves the same? Might isolate whether the issue is with the soundcard or the PC....

Rich

Actually, the PC is a Celeron 1Ghz, but I, too, have been wondering if that's not part of the issue. I have a laptop from work that I can try it on. It's a P4 1.3Ghz with 512MB RAM. I'll see if I can set that up tonight or tomorrow to see whether there is any difference.

OK. Installed the latest build on my laptop from work and connected my USB audio device. Everything worke fine! Now, I need help identifying what made the difference so that I can figure out what to do to get the other PC working…

The key differences between the two setup are:

CPU: Celeron 1Ghz (PC) vs. P4 1.3Ghz (laptop)
RAM: 256MB (PC) vs. 512MB (laptop)
OS: Win2k Pro (PC) vs. WinXP Pro (laptop)
Drivers: MME (PC) vs. WDM (laptop)
Bus Speed: I don’t know the specs on either machine, but I imagine there is a difference.

So, any ideas? Using the laptop for all my recording isn’t an option. Neither is running out and getting a whole new PC. Getting some more RAM or an inexpensive sound card could be a possibility. Would either of those do me any good? If the difference in drivers is significant, how can I get the WDM drivers to work on my PC?

Thanks for sticking with me on this. I really appreciate it!

Hrm, you tried WDM on the desktop?

Quote (Bubbagump @ Nov. 28 2005,14:52)
Hrm, you tried WDM on the desktop?

I had tried it earlier, and I kept getting error messages and couldn’t record anything.

However, now I have good news! I went back to the desktop PC, reinstalled SoundBlaster drivers, and, after doing that, nTrack started letting me select WDM drivers. I was really excited, but when I tried to record, nTrack crashed every time I clicked the record button.

So, having gotten that far, and not wanting to give up, I updated .NET runtime 2.0 (I was using a beta version), updated to the latest nTrack version, and tried again… BINGO! I opened my same song that I was having problem adding a 5th track to, and it works fine–no sync problems!

Thanks everyone for the help. I really appreciate it!