Record Midi issues

I have been using N-track for the last several years, recoding audio, and have been using piano roll for midi. I tried this week to record audio and midi, at the same, time from a Roland 500RD keyboard, without much success.
Asus p4p800E ? delux
Intel chip
P-4 2.9 Ghz
1 gig ram
Aardvark 2496 Soundcard
N-track v-4.1 build 1864
Using the Arks MME drivers = instant lockup as soon as I hit the record button
Using the Arks Asio drivers everything is great for about 15 seconds then it bogs down, drops out, records for another second or two and if I dont stop it will lock up.
It is probably an Ark driver issue (v-7.13). If it is I will have to get rid of it.
Question 1. See anything that would cause my problem?
Question 2. Anyone tried the RME fireface 800 with N-track?


Not sure what you mean by recording both audio and midi Larrye.

Normally midi is used to instruct your keyboard (in this case) what to play and you record the sound that comes from your keyboard’s box of sounds, or indeed any out-board or on-board gear.

I am trying to record a keyboard as both wave and midi, and vocals all at the same time.
Last night I was able to get it working a little but still not great.

First, I would download and install the latest version on n-Track. Next you might explore raising the buffers (latency) settings in the Ark control panel. Keep in mind when using ASIO drivers the buffer setting in n-Track Preferences are ignored. The ASIO driver has control over that. You MUST change those with the drivers control panel applet.

You should be able to record your audio from your keyboard and/or mic and the MIDI stream simultaneously. It takes almost no resources to record MIDI data. Also, fool around in n-Track Preferences (Ctrl+P) set the clock sources for Audio to NOT use the system clock. Use the wave clock from your Ark. Set the MIDI clock the same. The system clock is your PC clock oscillator and it is not very stable and prone to occasional hiccups.

Hope this helps… let us know!


Here’s the latest. I got it working last night. If the grimlins havn’t nailed it before I get home I think it will continue to work.
The config that wouldn’t work had Options: Use timer for recording and playback unchecked. I left them that way.
Went to pref>midi setting> and changed from wave timer to system timer and it works. I am using MME Drivers of the Aark and it seems to sync perfectly. Took me two nights to figure one simple check box.

I am using N-V-4.1 build 1864 and noticed it seems slow to open and close anything. Just changing a check box in midi pref. and then closing might take 5 sec. Anyone else notice this?