Recorded audio clips at 90%

Using Audigy card. SB Live card did 100%

I recently changed PCs, going from a Win98 machine with an SB Live soundcard to a new XP machine with an SB Audigy 2 ZS card.

In the previous PC, I could increase an analog input and the recording level meter (and the resultant recorded wave file) would not clip until it hit 100% (0dB). With the new PC, I hit clipping at 90%. The recorded waveform is hard clipped at 90% just like it was the 100% mark, leaving me with less dynamic range for recording. This problem occurs regardless of what program I use for recording.

I have tried all possible combinations of record and playback level adjustments on the Audigy and Windows mixers and it always clips at 90%. It is as if the conversion to digital within the soundcard is limited to 90% instead of 100%. Anybody know what may be causing this?

What is your signal chain? Perhaps you are clipping elsewhere.

Does it sound like clipping? Is there any form of compression or limiting in the signal chain?


Mark

more info needed. Which version of 2ZS? Platinum Pro with the breakout box? If so, I have this, and I can assure you it clips at 100% on n-track’s VUs not 90%. I presume you mean 100% = 0db. One thought - which input are you using. If you are using a breakout box, one of the inputs has an indepenent gain control. This may be clipping first, but I would have thought the signal would have been red hot in that case!

Which driver are you using? the 2ZS is really designed to use the ASIO driver - the WDM driver only allows a single stereo pair at a time, the MME driver is s**t. If you are using the ASIO driver, the creative mixer has no effect on inputs, but the channels must be enabled for direct monitoring. AFAIK the WDM driver does work thru’ the creative mixer, so that is another place where gain may be introduced into the signal chain.

hth a bit.

Here is the setup:

My Audigy card in the PCI Audigy 2 ZS and I am using the WDM drivers.

I am feeding the line-in of my Audigy card with the line level out from a Behringer mixer board. If I start with the default setting of all Audigy mixer sliders set at 50% and increase the audio output of my Behringer board to the point where I see clipping on my nTrack record level meter, that clipping occurs at 50% of full-scale, or -7dB. If I then increase the Audigy analog mix slider to 100% the clipping point moves up to 90% of full-scale, or -.9dB. According to the Audigy mixer tooltip, moving the slider to 100% is adding 6dB of gain.

Now, I do understand that I would not normally run the output of my Benringer to the point where the Audigy card clips. I am doing this only as a test to reveal the clipping point. When I decrease the audio level leaving my Behringer to normal, there is no clipping, but the recording peaks out below the clipping point, so no peaks make it to 90%, or -9dB.

With my previous SB Live card setup, I could easily set recording levels to record a clean waveform with peaks that made it to 100%, or 0dB, before clipping occurred. With proper level setting, I would end up with the highest peak at about 98% and no clipping. With the Audigy the best clip-free recording I can get has its highest peak just below the 90% point where clipping would occur.

This characteristic is not limited to nTrack. I see the exactly same behavior in Goldwave (that is where I get my % figures from) and on a standalone VU meter program.

<!–QuoteBegin>

Quote
Audigy mixer sliders


If you use the ASIO driver, this control has no effect whatsoever. The gain is affected only by your input signal level. This is what I do.

have you tried the ASIO driver? the audigy 2zs is principally designed to use this driver. (If you have the breakout box, you can actually get the audigy to record 6 channels simultaneously on ASIO. )

I have a feeling this is connected to the WDM driver. Not sure what is going on tho’. Try the ASIO driver and see if you get the same result.

I’m curious as I had problems along this line with the ZS…

Go into N or Goldwave and arm a track to record. Bring up your creative mixer. Set the record input to 50%. Note the Level in N or Gold. (in the creative mixer) Go to the playback area and move that line-out up or down (changing volume on the playback output).

Did this affect the meters?

KingFish

Quote (KingFish @ Nov. 24 2005,15:44)
I’m curious as I had problems along this line with the ZS…

Go into N or Goldwave and arm a track to record. Bring up your creative mixer. Set the record input to 50%. Note the Level in N or Gold. (in the creative mixer) Go to the playback area and move that line-out up or down (changing volume on the playback output).

Did this affect the meters?

KingFish

I did as you asked. Yes, moving the playback line-in slider does affect the record level in Goldwave. It appears that the signal path is from the line-in connector through the ZS playback circuitry, including the Creative Mixer. From there, the Creative Mixer selects which playback source you want to record. In this case, I have selected Analog Mix as the source to record. Moving the record fader or the line-in playback fader makes a difference in the recorded level shown on the VU meter and the resultant waveform.

Are you seeing the same behavior?

Now, if you could try this. On the Creative Mixer, set record to 100% for Analog Mix. Then feed some signal into the ZS line-in and go into record with Goldwave. Watch your VU meter and move the line-in playback fader up until the VU meter shows peaks near 100%. Stop recording and zoom into the waveform and look at the peaks. What I am seeing is a flattening at the 90% level with only an occasional spike making it to 100%. The behaviour is as if there is a hard limiter in the signal chain that is holding all but a few fast attacks of the waveform to 90%. Do you see this in your setup?

I don’t have the card setup for recording right now but I went through lengthly discussions with Creative about this. This is the way their card works. Who would think tieing the line out to the line in would be a good thing? I came across these problems as I would listen to something on a media player or such and change volume levels for listening to different things and found that when I went into record I would have to go through a lengthly process of figuring out why my levels had dropped when the analog record slider had not moved.

Since I need to use sound fonts for midi (my computer is junk) I had to go with the Creative card. When I get a more powerful computer the audigy is history.

The smartest thing I did was add a M-Audio 24/96 card to record audio. Major improvement. Quiet, clean, a simple mixer and the software isn’t bloated like Creative. Just look at the resources the creative mixer uses if you run it in the task bar in the lower right of your screen!

My advice would be to add another card of better quality.

KingFish