recorded tracks are playing back off-time/late ?!

i recently upgraded to the newest version of n-track (from 3.1 or something ancient like that)… and every time that i record a new track, it plays back as though everything was performed later than it actually was. in other words, the recorded track will be offset by quite a few milliseconds in relation to the rest of the song. .

this has been happening when i try to record additional parts for songs that i recorded on my older versions, and when i try to work on fresh songs in the new version.


again, the difference is not of a second or probably even a quarter of a second… but it is definitely noticable.

has anyone else experienced this?

is this related to some buffering setting?



-r andrew scott
[ myspace.com/moddrug ]

You’re not using a soundblaster live or similar are you? If so, those cards work internally at 48kHz and convert to 44.1 on the fly - and get it a bit wrong at times!

Alter n-Track’s preferences so as you record at 48kHz and the problem might go away.

If you’re not using one of those cards then it’s something else !?!?!

i actually am using the echo layla24 and am only recording at 16-bit 44.1 . . (i’m not quite ready for the big switch yet.)

i never ran into this issue with the old version of n-track… maybe it’s a setting that i’m overlooking?


there’s nothing like playing a part precisely over and over again just to find that it’s not the performance that was wrong, but an offset on the whole thing…

i’m running an AMD 64 3400+ with 1GB of top of the line RAM. .


anyone?


-r andrew scott
[ myspace.com/moddrug ]

Toggle “keep audio devices open”. Whatever it is switch it and see if the problem is affected. Also, toggle which timer is used for wave playback and recording. N-Tracks defaults to using the system timer. Most of the time it should be set to be the wave timer. One more thing to check is whether or not synchronize the wave devices is on in the EchoConsole. Number four is to start recording at the very beginning of the song. Sometimes when starting anywhere besides the very beginning the new track will be out of sync, though not always. That’s four things that could be a factor. Change them one at a time of course. I use a Layla20 and a Gina24 at home and have a Layla24 at work. Let me know how it goes.

OH…one more potential thing, though I don’t think it’s related to your problem is that there is a bug in some AMD 64 machines that will cause the clock used by the multimedia timer to run backwards. Applications and especially drivers need to compensate or there can be pops and glitches during recording and playback. Do a google search for “AMD QueryPerformanceCounter Bug” and there will be very few useful hits but some will be for apps that have done bug fixes to workaround it, and some posts asking about it with virtually no answers.

i did a test to verify that the recordings are not coming through properly. …

i sent channel 1 out of a free pair of outputs on my soundcard and ran it in as a new track… (just very short metronome clicks)…

i compared the waveforms in soundforge.

the recorded track was 3,055 samples late… which at 16bit is approximately .069 seconds.


i don’t want to remove .069 seconds of silence from every wave file that i record for the rest of my life, so yea… if anyone has any ideas, i’m all ears.


-r andrew scott
[ myspace.com/moddrug ]

How are your device configs set? I’ll see if I can repro it. Are there any plug-ins anywhere (plug-in compensation can cause sync errors in mixdown files by adding a bit of null wave data at the beginning of the mixdown wave)? Though, this sounds like a “keep devices open” issue. I don’t know why just a hunch.

>>Toggle “keep audio devices open”. Whatever it is switch
>>it and see if the problem is affected.

“keep audio devices open” is currently on. . what exactly
does this do?


>>Also, toggle which timer is used for wave playback and >>recording.

It was already set to the wave timer.


>>One more thing to check is whether or not synchronize
>>the wave devices is on in the EchoConsole.

Yes, it was already on.


>>Number four is to start recording at the very beginning
>>of the song.

All of these issues have been when recording from the beginning of a song.


thanks!

-r

i did several more tests with various “keep devices open” settings (ie: toggling “on/off” and also “on” with different reset times from 1-5ms…)

the results were varied. . the recorded file was off by different amounts ranging from 1,500 samples to 4,500 samples. and i never received the same result twice even when repeating the same test. .

with the same exact settings, i did three tests… the first one was 3693 samples late, the second was 3997 samples late and the last was 4051 samples late…



-r

i’m not getting the problem when mixing down, by the way… the timing is just off on every recorded wave file.

and these are just raw recordings. there are no plug-ins being used in this song file.

i never had this problem with my older version of n-track … even on this computer. so, i’m pretty sure it must be a setting somewhere…


-r

What driver are you using? MME, WDM, ASIO?

What timer are you using in the audio devices preferences?
System or soundcard? Try unticking the “use system timer” options if you have them ticked…

Quote (RichLum @ Oct. 23 2005,18:53)
What driver are you using? MME, WDM, ASIO?

What timer are you using in the audio devices preferences?
System or soundcard? Try unticking the "use system timer" options if you have them ticked...

i'm using MME .. WDM is apparently also available.

with WDM and "keep audio devices open" disabled, i got it down to 137 samples (or about .003 seconds)

i repeated the test with these settings and got the same result three times.. that's definitely a huge improvement.

can i get any closer to 0?

WDM will be heaps better than MME as MME uses a lot more system resources.
I don’t know the exact technical explanation, but esentially WDM and ASIO let your soundcard do more of the processing and MME requires your CPU to do more of the processing.
Which is probably why with MME you were getting variable lags (it would edepend on how busy your CPU just happened to be each time).


Not sure about that last 3 ms… Is it enough to actually notice when you record a new track over previously recorded tracks?
I would expect most peoples timing when playing would be out by more than that…???
Or am I just a crap player :)

I’ve never tested how in sync my system is by re-routing the metronome and recording over itself but I would expect there would be some lag introduced depending on how you have the routing of the signals… not sure…

Rich

yea. after about a half hour more of testing with changes in some variables, it is still always exactly 137 samples late.

can any improvement be made? or is .003ms my soundcard’s/ntrack’s idea of 0?


the way i tested this was by importing a click loop that i made. this wave file was adjusted so that the first sample that left the exact point of zero db would be the first sample of the file. i can visually recognize the sample where the sound starts as the sound has very fast attack.

this file plays as ntrack’s first audio track.

the outputs on this track are routed to layla24’s 7/8 outputs which run out of the sound card, into a patchbay and back into the patch bay for layla24’s 7/8 inputs…

those two inputs are recorded into a new stereo track… which is always .003 samples behind the original track…

the speed of audio running through a foot of cabling?

ha.

OR… maybe n-track somehow hits record before it starts playing?



-r

I don’t know, but I use MME as a rule – always these days. I’ve have had good luck with it, and that’s the only device that will work at 24 bits when using the Gina24 when using PureWave. I don’t need the better latency at WDM and ASIO give you. I have not had good luck in the past with ASIO or WDM, but that was long ago with older Echo drivers. The latest have been good and what little I did with with WDM and ASIO worked fine at 16 bits. I ran into that 24 bit limitation with the Gina24 and stuck with MME-PureWave over there.

137 or so samples isn’t a lot in the big scheme of things at 44100 per second but it is a huge amount in the world of “sample accurate” recording. Since it’s always the same with you current config I suggest emailing Flavio (support page). It may be a bug or he may have better suggestions, or may know whys it’s doing that.

I also keep a little click at the beginning of each track and visually line them up. This is necessary when trading files that wee recorded on other machines as those files could be off a little anyway. I wouldn’t have noticed this kind of thing in my day to day usage since the way I work would mask it.

I have had this problem as my track count reaches 12, with effects. I use MME and ver 3.3. I work around by mixing down several tracks to one to reduce my overall track count.

Can you duplicate this with just two tracks not being in sync in a new song?

From the n-Track Help (lag & sync issues):<!–QuoteBegin>

Quote
If you notice a sync problem in which recorded tracks sound constantly (i.e. with equal delay during the whole length of the recording) too early or too late with respect to existing tracks in the song you can use the compensation parameter in the Preferences/Wave devices/Advanced dialog box to compensate for the problem.

So, since your lag is constant at 137 smpls, this should solve the problem.

"recorded tracks are playing back off-time"

yeah, i’m having the same problem. I’m using Layla 20.