Recording latency

buffer settings?

there seems to be some sort of latency problem, when I record a new track I usually have to drag it forward a few milliseconds to have it line up with the rest of the tracks. I know there is always going to be latency in the signal path, but I thought the buffer setting tells the program what the latency is and it compensates for it by automatically moves the new recording forward when it writes to the disk.

do any of you have the same problem? and how do you solve it


thanks,
K.R.

There is a setting in n-Track to manually compensate for this. I think it’s under the “advanced” button on the input selector box (?!?). put in a negative number to have your recorded tracks shift to the left, and a positive number to have them shifted to the right. I don’t know what the number signifies…

Here’s what I did:
1-record a click track to a wav file
2-send the output of that wav file to one of the ouputs of your soundcard
3-plug that output into one of the inputs of your soundcard (loop them together with a cable).
4-set that channel to record - you should now be recording a new track of audio of the click track.
5-zoom in to check the alignment between the two tracks.
6-change the compensation setting in n-Track.
7-repeat until it’s as close as you’re comfortable with.

I had to use a value of -2060 with my laptop and MOTU to get it to line-up properly.

Think of it as part of a “tune-up” for you system.

Hope this helps!
:cool:

We generally call this a “sync” problem. Strictly speaking, we call “latency” when you play a note and hear it played back after a delay. The two things can be unrelated, although sometimes, reducing latency can reduce a sync problem.

Yes, the system is supposed to compensate for it automatically. Evidently, sometimes this doesn’t work.

Here are a few things to try. I’d try these before using the manual latency compensation, because the manual compensation might need to change if you adjust certain settings.

STEP ONE – true for ALL problems on a new DAW: Be sure you’re using the latest drivers from the soundcard manufacturer’s website. (That’s if you’re using an aftermarket soundcard. For built-ins, this may or may not apply; the manufacture might not have any driver downloads.)

In “Preferences -> Options”, uncheck both “Use System Timer” boxes. These are defaults because they work with most soundcards, but they don’t work WELL with most soundcards (especially ones made for recording).

Try ASIO drivers. Sometimes this helps simply because it’s a low-latency driver, and if your sync problem is latency-related, it reduces (but doesn’t eliminate) the problem.

Also try WDM and MME drivers. Some soundcards/systems work fine with one driver but not the others.

For each setup you try, try both settings for “keep devices open”.

I think there might be one or two other things, but can’t recall off-hand.

HTH :)

thanks I’ve made the changes to my setting, haven’t had the chance to actually try out recording yet, but we’ll see how it goes

K.R.

Well, you may have to try a bunch of different settings before you hit the golden combination. Take notes, be methodical, and save yourself a lot of time & frustration (with a little luck).

Please tell us what you did?

THis is a Forum, and if you dont share then we dont gain.

so I finally have a chance to do the loopback recording john suggested. after making the setting changes learjeff suggested I’m still getting about 1047 samples of latency. now I’m not sure where to set the manual compensation setting that John talked about… any ideas?

K.R.

<!–QuoteBegin>

Quote
now I’m not sure where to set the manual compensation setting that John talked about… any ideas?


Preferences–>Audio Settings–>Advanced

There’s a compensation box about a thrid of the way down.

ok thanks I’ll try that

K.R.