Reset all, still having MIDI problems

I’ve done everything I can see to do

I had a minor fiasco after installing my MIDI USB interface and the ASIO4ALL driver…I got Flavio’s help (thanks Flavio!) and all is well with nTrack again.

But…I still can’t use any of the MIDI instruments in N.

I can use my MIDI controller to play through Fruity Loops, and when selected in nTrack, I CAN get the general MIDI Roland Sound Canvas on my soundcard to play.

But when I try to “Insert” an new MIDI track, and then a new Instrument Channel, nothing happens.
I’m not getting error messages, I’m just getting nothing at all.

I’ve tried all the possible configurations I can think of, I’ve followed the instructions in the Wiki (thanks Diogenes) and experimented left and right, and still nada.

FruityLoops is working just fine with
MIDI in - USB Midisport In
MIDI out - Microsoft MIDI Mapper
Audio - Primary Sound Card Driver (SigmaTel C-Major)

I hear everything, and get VERY low latency.

But those same settings in nTrack don’t work.
(Flavio had me reset to default Settings)

Here are my nTrack settings;
MIDI devices - In = Midisport USB, Out = MIDI MAPPER
Keep devices open = checked
I to O echo = Manual
Output Port = instrument plug-in (FL Studio, NDrums, DaHornet, etc.)
Channel = 1

Audio Devices;
Both set to MME Wave Mapper

Thanks for any help you can offer.

You have the LIVE button enabled right? I know it’s obvious but sometimes I forget myself. That won’t cause your MIDI tracks to not get inserted in the timeline though… Let me experiment a little and get back to you.

D

OK. Try this from a new, clean project…



You should get DaHornet’s GUI popped up… now do this…



You should get a blank MIDI track on the timeline and a MIDI channel in the mixer. Now right click the MIDI track on the timeline and choose Properties OR click the track “label” at the top of the mixer strip. You should get…



Notice that I have chosen the OUTPUT for the MIDI track to be “Instrument Plugin - daHornet”. The RECORD from selection depends on your MIDI interface. It could be XYZ_Brand_MIDI_Port_0 or similar. Now open the Master mixer view by pressing F3. If you don’t see the master output, two aux channels, a MIDI track and a synth track, right click a blank part of the mixer to turn them on like this…



I am assuming you have the latest version of n-Track? If so, those screenshots should get you started. Make sure the LIVE button is illuminated and finger a few keys on your controller keyboard. Since you are using MME: Wavemapper, after a horrendous delay, you should hear daHornet making some noise.

IF you do not get a MIDI channel or Instrument channel inserted at ALL… I’m kind of at a loss here…

Lemme know…

D

Diogenes, you are the MAN.
I haven’t tried it yet, but that “LIVE” button thing seems to be the only thing I was missing. Your excellent screenshots confirmed I was doing everything else correctly.

I’ll be sure to include you in the liner notes of my first release :D

Include him in your will too…

No need for the will… just glad to help. Plenty of these other fellows on here showed me the way. Returning to the community, that’s what this place is for…

D

OK, so Diogenes’ suggestions worked like a charm.

Now…
Diogenes, you called it - I have TERRIBLE latency using the MME MIDI Mapper driver in nTrack, even when using FruityLoops as the VST instrument.

Keep in mind…I have perfect audio and low latency within FruityLoops itself with the factory soundcard driver.

So…I downloaded ASIO4ALL again.
My SigmaTel card seems to be working with it (I get the little green light in the Asio4All interface) - and my MIDI is working fine, I can see signal into nTrack and the latency between striking the key and the VU meter spiking is extremely low…

My soundcard is working with other applications…

But…
No sound is coming out.

I do have the ASIO4ALL listed in my audio devices as both the Input and Output driver.

Any ideas?

Look at this graphic…



Maybe that will help. You may find the latency to be usable with the SigmaTel WDM driver. Set the buffering lower in n-Track Prefernces and you may find it usable. Keep in mind though… when using ASIO drivers, you MUST set the latency with the drivers control panel. Changing the buffers within n-Track Prefs are ignored.

Hang in there James. We’ll get you sorted out…

I will add though… if you can pony up a couple hunnert bucks for a decent USB or FireWire interface for your laptop, you’ll probably be happier. My Dell lappy has the SigmaTel chip in it. Best thing ever did was get a Tascam US-122 for portable use. Later, I bought a Presonus FireBOX FireWire interface, it blows the Tascam out of the water in features and sound quality. So far, it has worked great with everything except my Compaq notebook. Despite several attempts with tech support, the FireBOX drivers WILL NOT work with the Compaq… dunno why ???

D

Thanks Diogenes, you’re awesome.

I should reinstall SnagIt on my laptop so I can post screenshots, I’m sure that would be easier :D

The two things that are different between your screenshot and what I’ve been doing:

1. I’ve been setting my audio output in the track dialog to the VST instrument, not the ASIO4ALL. I’ll bet that’s it right there.


2. I’ve been inserting a new MIDI track at the beginning. Should it be a new Audio track instead?
My goal is to play back all my other tracks and play daHornet or FL along with them and record a new track in real-time. I have no use (yet) for MIDI mapping of changes, piano roll sequencing, etc. I just want to use these VST’s as live instruments in real-time for right now.

3. I noticed, too, that when inserting a new track, I actually got three - 2 audio tracks along with the MIDI track. I see that in your screenshot above.
Problem is, I get horrible noise and hiss - it’s picking up signal from my laptop’s mic.
Should I leave those tracks in place and deselect my computer mic as a recording device?
Or can I delete those two tracks?


I’ll play with the nTrack latency settings, hadn’t even gone there yet.

Thanks again.

Keep in mind what TYPE of track you are dealing with in the mixer when you pull up the properties. If you have MIDI tracks in a song, you’ll want the MIDI out from the track sent TO the VSTi. If you are dealing with the audio output(s) for the VSTi mixer strip, you’ll that output property pointed to your soundcard driver or a group that is pointed to your soundcard driver.

Think about the flow of signals/data. Their origin, the destination you want etc… Then this might make a little more sense. It doesn’t matter if you are talking audio signals or MIDI data. Think about WHERE the signal/data is coming from then WHERE you want it to go. Also, remember MIDI is nothing but commands that tells a hardware or software synthesizer what note to play when, how long, how soft/loud, etc… Key point is, that data has to be told where to go to trigger some kind of sound and can come from a keyboard/controller, MIDI guitar, a pre-recorded MIDI file or notes entered in a sequencer with the mouse/keyboard.

Hang in there.

D