Hi, folks –
Downloaded the demo and tried to put together a sample song. Only, every time I try to add a VSTi or DXi, n-track starts scanning plug-ins. This either takes several minutes or everything locks up. I decide to try a different instrument and, there it goes scanning endlessly again. Is it really supposed to scan EVERY time? Am I doing something wrong?

Don’t know about version 4, but it should be the same as on 3 (and before).

It should scan only once in a session (the 1st time you open the plugins dialog). After that it should be fine.

Do you have any other plugins ? It might be a problem with one of the other plugins.

other than that I don’t know.

Well, I’ve got dozens of plug-ins, and it’s possible that N-track just doesn’t like any number of them :D . I’m looking for an alternative to Cakewalk’s Home Studio and their VST-Adapter. Just wanted to give n-track a try…

create a second folder called “vst2” or something and move all of your vst plugins to that folder.

start n-track. if it scans ok then you’re dealing with a bad vst plugin.

shut down n-track and move your plugins back to the original folder one at a time, starting n-track after moving each plugin. if n-track hangs then you know which plugin caused it.

this process is only going to identify vst plugs. if n-track hung the first time you tried it after moving all your vst plugs, then you’re dealing with a direct-x plugin problem. they can be a little tricky to deal with. usually involving an “un-install” of the plug.

the analog-x website has a d/x manager utility that is great for uninstalling direct-x components. google it up. be forewarned though, some d/x components are part of the o/s and should not be messed with. tread softly.



There’s a file that gets created when the scan is done, named vstdat.dat. It’s in the same folder as ntrack.exe.

If that file can’t be saved (Is that file write protected?) or is getting corrupted or anything else makes it seem invalid to nTracks then the scan might happen every time.

Are you logged on as administrator? Not being an administrator will restrict file writing to some folders.