Screwed with USB 2.0

Hello everybody,

I bought myself a USB 2.0 interface (Alesis IO|2), but seems that my machine cannot do high speed despite that it should. I figured this mess is because of SiS 7001 USB controller that I have. Has anyone tackled this problem successfully? I’ve read all over internet about it, tried to delete USB-drivers and install them again but it didn’t work. My machine is FC laptop, Amilo A1630. I think I’m going mad, I just sold my firewire interface to get bus power possibility.

P.S. It isnt’ that I don’t have USB 2.0 installed, since I have the ‘Sis PCI to USB enhanced host controller’ in my USB-drivers section.

i have read too in recent week bout the usb this an that,have you read that sometimes theres a setting in the bios,and to make sure that in device manager under serial bus controllers it has the word enhanced on at least one,somethings you read almost make ya think ya can download the enhanced usb,but this is not so ,an then the if ya dont have xp service pack 1 and 2 (updates) well then ya wont have the drivers and it wont work,and on and on,i found a program from intel that identifies the chip yer using an then it can tell ya what ya do have.,like ich2 wouldnt support it but ich4 would ,awww man ,it can get ya to spinnin,good luck

Thanks for the reply woss. This things can really twist your nerves. What was the Intel tool you were talking about?

sorry i dont have a link,but if ya go to the intel site its a proggy that determines what chipset ya have,an then fro mthere ,with more reading of course was able to determine what i had on that older machine,

i have looked at the Alesis website at the Alesis iO | 2
Portable 2-channel 24-bit/48k USB audio interface -

1…there is no indication that this is a USB 2 device
2…neither do the specifications indicate this is a USB 2 device (you need USB 2 for 96k and above sample rates)

My OS of choice is win2k which does not know about USB 2 -

i have 2 USB devices a Roland SP606 and a creative NX 6 channel USB sound card (which has more inputs and outputs than the Alseis unit and it works perfectly on USB 1) -

the Roland unit handles bi-directional stereo channels and midi control data at the same time again on USB 1 -

so i must ask - have you actually tried your Alesis unit or did you fight shy when windows threw up a blob saying ‘this device can work faster’ -

if you have installed the drivers correctly the device will apear in both windows sound settings (via control panel) and in N tracks preferences as a USB audio device (it may not have the Alesis name next to it) if it shows up in N then its there -

if its not there then the drivers are NOT installed correctly -

this can be confirmed through control panel/hardware manager/system - look for yellow question marks - these are problem devices

to see if its out putting audio plug a suitable device into one of its inputs - in N arm the recording meters, click on live and the meters should work - you have to set keep audio devices open in the advanced section of Ns audio devices or else you wont see it work untill you start recording - and at the same time do the same for MIDI devices in the midi section -

it took me three atempts to get an Edirol keyboard to install correctly (i missed out a point in the instruction manual which i thought only refered to winXP it seems it refered to win2k as the drivers loaded into an XP PC without any problems or special settings ? )

you say you have firewire experience (that shows that the drivers where good) -

OH i nearly forgot - that free copy of Cuebase LE you got with the Alesis, hang the CD by a piece of thread in the garden, it will make a great bird scarer (dont like Cuebase)

yours Dr J

Oh, My, God. Dr J, thanks a million, it really isn’t an USB 2.0 device blush. I was looking to buy Tascam US-122L before, I must have confused with that. But my problem with USB 2.0 still exists with my MuVo, although it’s not a problem now really, I don’t need it to run so fast.

I solved all my problems with IO|2, it used to garble the sound seriously and insert loud static in the middle of of playing, even in winamp. Changing samplerate from 44.1kHz to 48kHz seems to require a reboot, otherwise the sound is unspeakably garbled. So all it required was to 1. set the asio sampling frequency to 48kHz, 2. reboot the machine 3. start N-Track/Cubase. This is ok for me since I never use 44.1kHz mode. Plus the sound was awful with 44.1kHz, now It’s heaven… :)) I’m so goddamn happy, just singing to my mic here. Great!!!

By the way, the processor use of this device is 0%, if you compare this to my last device which was firewire, it took 4-7% CPU all the time. Even N-Track (4.21, build 2099), seems to work better and smoother now, at last!

edit:// it seems to require a reboot after every time you set the latency. It’s now 7ms, working fine after reboot/ releasing/reconnecting the USB-plug.

edit:// there is mixed info about whether this device can do 96kHz. Every other website says 48kHz, even Alesis website, while the manual says 96kHz. So it can do 96kHz, but only with directsound/WDM/MME. For ASIO 2.0, maximum is 48kHz.

edit:// recording works fine, crystal clear sound, no artifacts, with 24-bit 48kHz.

Scythe, so you are liking the Alesis better than a regular mixer/soundcard setup? or did you jump to this from a soundcard/interface and no mixer?

I like my interface very much and no, I never owned a mixer. It’s always been software mixing only for me. But I’m merely a hobbyist so that’s why I don’t need hardware mixing, apart from the shiny knobs on my IO|2 . :cool:

Ana DaSilva of The Raincoats produced a record with only 2 mics and a Yamaha all-in-one recorder. Even with your “hoobyist gear” you can learn to do some very impressive work, dude!

And it’s hard to argue with shiny knobs! :D

I got a Tascam M-30 because I wanted ‘colored’ sound. I mostly mix in-the-box too, but I want to track with an older vibe. Probably just because I don’t know any better- but I like the idea of phase-distortion and older circuitry. I have issues… :)

<!–QuoteBegin>

Quote
I have issues… :)


:D :D