Scrub causes n-Track to stop play mode

I was in build 2202 and tried the audio scrub mode by clicking play and left-clicking the mouse while the cursor was in the space just below the top timeline. It would scrub for just a few back and forth passes, then n-Track would fall out of play mode (the play button popped out) and stop the scrub action. I could hit play again and scrub again, but after a few passes, it stopped again.

I upgraded to build 2225 and have the same problem.

Anyone else having a problem with the scrub feature when dragging the mouse cursor in the area under the top timeline?

the play button pops out when N cannot access the hard drive fast enough to stream audio correctly to the soundcard, this is a great improvement, as before N just crashed if you scrubed to fast -

Dr J

I thought the wave files were loaded into memory.

My PC is a P4, 2.8GHz dual core with SATA drives and 1GB of RAM. I would think it represents near the high end of the scale of PC power. If I can’t do even gentle scrubbing in n-Track, certainly no one with lesser power will be able to.

By comparison, I can quickly scrub video and audio in Sony Vegas Movie Studio on the same PC with no problems. If n-Track can’t handle even gentle scrubbing, then it probably is not implementing it in the way that Vegas does and perhaps it should.

N track is not RAM based tracks are kept on the hard drive - i have software that is RAM based and as you say you can scrub at very fast speed - but these are waveform editors not DAWS and i would class Vegas as an editor with limited DAW capabilities not a dedicated DAW -

Dr J

Ok. BUt how do you get Nrack to play again. In 2225 I did something, I think left clicked when I was trying to move a file and the play button no longer worked at all…

do the play button or the pause button “flash” when you try to playback ? -

Dr J

No, it jsut did not respond. The computer was not frozen, just could not get it to play.

look at the two headed arrow (track speed control) on righthand side of transport bar - if arrow is locked to the left then N will try to play at zero speed which will give no playback - near the arrow is some small text indicating the track speed, left click on this text, a popup will appear, reset track speed to 1 - it should now play OK

Dr J

build 2227 - just found a right click option when using scrub which sets scrub speed (may have been there for ages) when set scrub to 1 can now scrub back and forth as many times as i like without the play button jumping out, if i set it to any other setting, (say 4) then it works OK as long as i go from forward to backwards quite fast, if i drop the speed (scrub too slow) then the playback stops, seems that there is a problem around zero speed (see post above) that N cannot recover from without restarting playback -

Dr J

Thanks Dr. R. I will give it a try. Keep us posted on what you discover - unfortunately, right now it seems to be what can be discovered, and I just want to be able to record and mix - the excitement of discovery is not formost in my mind at the moment. Flavio is fixing and changing things practiaclly every day, and I’m sure it will be great. I’m just looking forward to reading the documentation that fills me in on what this and that do. I wonder if we are not getting so many features that the learning curve will out run the usefulness.

What I am finding is that the scrub mode will continue working unless I pause my cursor on the vertical dotted line that indicates the current play position. As long as I am to the left or right of the vertical line, n-Track plays, but when I hold it over the white line, the play botton pops out. This seems to be more of a bug than a disk streaming problem.

I sent a support message to Flavio and he replied that playback should drop to zero (as expected) when the mouse is over the playback cursor, but it should resume as you move the mouse away from the playback cursor as long as you continue to hold down the mouse button. He has not been able to duplicate the problem I have where the playback button pops out when the mouse is held over the playback cursor in scrub mode.

Since I see this on two installations and it appears that Dr. Jackrabbit is also seeing the problem, it would be helpful if others give it a try and post the results here.

Do this:

1. In n-Track 5x, start playback of a wave file by clicking the play button.

2. Place your mouse in the area just below the timeline scale at the top of the timeline window. I will call this the scrubbing space and this is where the entire test should be made. The mouse cursor should show a little right-pointing arrow along with the usual mouse pointer. While staying in the scrubbing space, move the mouse cursor to the right of the playback cursor (vertical dotted line that indicates playback position). Hold down the left mouse button and keep it down for the remaining steps.

3. Now, quickly move the mouse pointer to the left of the playback cursor and playback should reverse, verifying that you are in scrub mode.

4. Finally, move the mouse pointer directly over the playback cursor and playback should stop. Be sure you continued to hold down the mouse button throughout this entire test.

When playback stopped in step 4, did the play button pop out and playback stopped for good, or were you able to move the mouse pointer to the right of the playback cursor and get playback to resume again without having to hit the play button?

Hi n-Trackers:
I just installed build 2227 on the Studio P4 '98SE Desk… I am checking the “Scrubbing” on this build on '98SE Intel P4…

I was at build 2205 before I up-graded n-Track… on this particular machine…

I have checked this build and it’s “Scrub” feature and how it works with this setup…

I found it behaves quite inconsistently depending on which direction you are moving the “Scrub”. Then at different intervals a Pop-Up Screen appears…


The error screen says…“Error signaling from disk loading to mixing thread”

Could that be of any help to Flavio?


i havnt picked up that error in 2227/26/25 - but had it occur in the past with N freezing, proir to the error message era N stopped windows completely -

on this PC i use WDM drivers as have no ASIO card installed at the moment and have STOP WDM DRIVERS ticked in audio prefs - this is what could cause the play button to jump out as the drivers are halted automatically by N with no error messages displayed - if not ticked, then if using WDM one would expect to get an error message asking for them to be stoipped -

the disk error does not seem to popup with only i track in timeline but may with more tracks as disk streaming is more involved as track count increases -

for reference - in a mono track all the samples follow in sequence - in a stereo track the samples are interleaved - first sample is left track, second sample is right track, third sample is left track, and so on, so it is no harder for N to read a stereo track as it is a mono track, in both cases there is just one track -

trying to read two tracks (or one track that is fragmeted over a drive) or a track(s) from another hard drive, is what may cause the disk reading error - DEFRAG may help of tracks are on same drive -

have just tried it again, button jumps out when passing slowly through ZERO speed - as far as i can see nothing is going to start N playing on its own when that button jumps out -

Dr J -

Hi All:
This was/is my first v5.0.4 install on this studio P-4 '98SE Desk… The last build that was on this desk was v5.0.3 build 2205…

The install wasn’t without it’s issues… The first attempt froze the install-and desk just as it was un-installing the previous build… (b 2205)… I had to do a cold boot (Lock-up) restart… (Blue Screen) Scandisk, and all… The second attempt went through the install process and Launched build 2227 without any issues, of any kind… However… the install process left the shortcut to build 2205 on the desk… I also received a Registration Read Error on the first attempt at installing b 2227… Remember… this is '98SE…

I’m going to attempt the 2227 install-and-check the XP Desk later this evening and check the scrub to see if there is any change from the '98SE desk, in it’s behaviour…

Anyway, after I posted my earlier reply I went back to the '98SE desk to play with the scrub… The scrub was somehow locked and not able to be stopped… I even rewound the and restarted the timeline at it’s beginning. the timeline played at approx. 1/4 of the normal speed of the song… There is about 11 stereo tracks on this test song,with a number of plug-ins on various tracks. The only way to take the timeline out of “Scrub” was to close n-Track and re-launch n-Track… I had n-Track minimized to the task-bar while I replied to the thread… Maybe that had some Bering on how n-Track was behaving … with the “Scrub”… Who knows??


I forgot to add…

Stability with the test song on the '989SE P-4 desk with the Lexicon LDI-12T audio hardware and using the ASIO Dreivers is Just great… No issues that I can see…

Bill please confirm - leftclick and hold mouse in a track, does the timeline stop ? - it does on this PC, also stops pointer (green display) readout, have no way here of testing MIDI sync on this PC but if MIDI sync also stops when left clicking in a track this could lead to problems where syns is omportant -

also if track plays at wrong speed or even backwards look at the position of the green arrow on the right hand side of the transport bar - it gets confused easily - if it gets locked to the left then N will not play at all, you have to double click on it to get it back to its proper position -

and yes its great fum when the music plays and N is completely frozen - you never know when you hit the off switch if your tracks are going to be there when you re-boot or have been shreaded by a drive error -

Dr J

Hi Doc Vivona:
I have build 2227 installed on the XP Desk now… I’m playing with the scrub and all… I’m just getting the feel of this build on the XP desk…

I “left-click” and hold the mouse on a track… NO Timeline Stop… It works as I think it always has… orry… Still checking-and-playing…

The scrub works quite differently on this XP Desk… It takes a while to begin to scrub… It’s like the scrub i “Loading”, or something… Then it begins to work… and Both Ways… it appears to work O.K. on this XP Desk… ?? Still plying with it behaviour and all…

I’d like to see the “Scrub Margin” occupy a bit more “Real Estate” on the timeline margin… Then I could get the cursor to act better?? is that a good description??

I’m checking this timeline as to the number of tracks and plugs… This timeline has 11 stereo track … A Master Pro Limiter om the Master Strip and a reverb and Master Pro limiter on one of 4 Group Strips…

The CPU Usage meter in the n-Track Left-hand corner reads 28.5% Showing Fractional %-age dropouts… The plug-ins total latency is 23 ms = 1000 samples… The soundcard is a SoundBlaster Live 5.1


I forgot to add… the error reading the registry message appeared during the install as I loaded build 2227 on this XP Desk… I’m just sluffing it off… But I hope it don’t come back to bite me… :O ??? :p :laugh: I’ve seen this screen on the P-111 and now on the P-4 machines…

Error reading root folder from the registry…

DR Jackrabbit - If I click on a track waveform while the track is playing, the playback cursor stops moving, but the track keeps playing. Is this the behavior you are trying to verify with others?

Bill - You say you can scrub both ways, but what happens if you, while in scrub mode with the left mouse button held down, hover over the playback cursor. Does playback stop and the play button pop out? Or, after hovering over the playback cursor, can you simply move the mouse to the right of the playback cursor and playback resumes?

CORRECT - thank you for confirmation

Dr J