setting up MIDI to use DaHornet inst plug-in?

OK - as per my previous thread…

I got my M-Audio Midiman 2x2 USB MIDI interface.
Installed the provided drivers, new hardware found.
Plugged everything in - keyboard to Midiman, Midiman to laptop via USB.
Hit the keys, and could hear the sound of my soundcard’s built-in soft synth just fine, so I know all the connections are working.

However…
I can’t figure out how to get the keyboard to trigger the “DaHornet” VSTi instrument plug-in that came with the latest nTrack. I’ve been through all the MIDI settings on the Preferences menu and nothing seems to be working.

The MIDI settings do show the Midiman’s Input and Output as choices, so I know nTrack is recognizing its existence.

Also, I was previously able to play the keys on the DaHornet using my mouse and get sounds - now I can’t, in addition to the keyboard not triggering it.

Any ideas? Thanks for helping a MIDI newbie!

Try THIS thread… and look at page 2. See if that will get you going.

D - (gtr4Him in a cynical mood)

OK - I’m totally lost now…

I followed the instructions in the Wiki for using a VSTi instrument with MIDI.

Here are my settings:

File -> Settings -> Recording Settings -> Audio Devices
* Audio playback devices = WDM SigmaTel Audio
* Audio recording devices = WDM SigmaTel Audio
((My other choices are:
MME SigmaTel Audio
MME Wave Mapper))

File -> Settings -> MIDI Settings -> MIDI Devices
MIDI Input Port: In-A USB Midisport 2x2
MIDI Output Ports: Microsoft GS Wavetable Synth
Keep devices open checked
Manual mapping: Instrument plug-in: daHornet
(I also can select Microsoft GS Wavetable Synth)

When I go to insert a new Instrument channel and select the VSTi instrument “daHornet,” I get the following error message:

"Recording format not supported by the hardware. 24 bit recording/playback may only work with WDM or Asio drivers…etc.etc."


The problem is:
* I installed the Asio4ALL driver. When I selected it as the Audio Device, nothing happened - no sound.
* I also tried the MME and Wave Mapper audio devices and got the same error.
* I also tried all the other options for the MIDI Output selection and nothing worked.

The funny thing is:
It worked for a minute.
I hadn’t downloaded the ASIO or made any changes in the “Settings” menu yet, and I followed the exact instructions in the Wiki for a VSTi instrument.
At first, it was going through the Roland VSC and I heard piano…then I chose the DaHornet synth and I could hear that too.

The problem was that the latency was HORRIBLE, so I went to get the Asio driver to try and fix that.

As soon as I started messing with the Settings to use the ASIO driver, it got all fouled up.

I tried “restore default settings” but it didn’t have an impact on the Audio or MIDI device menus.

So my questions:
* Any good ideas on how to fix this?
* Any good ideas on taking nTrack back to the way it was so I can start over? At least it worked for a moment before I started playing with the Preferences, at least I can start from scratch.
* Any ideas as to why even after I selected the ASIO driver as the Audio device, I got no sound at all, even though everything else was correct?

Thanks…all this MME, WDM, ASIO stuff is completely new to me. I’ve been all through the Wiki and the ASIO4ALL online help, and I can’t figure it out.


edited to add…
I downloaded the demo version of FruityLoops, and the ASIO4ALL driver again to see if it was soundcard, driver or MIDI/USB interface related…and it’s not. FL works great, no latency, didn’t have to fiddle with it much. So it’s obviously my stupidity in dealing with nTrack itself.