Something Rotten

and it ain’t Johnny

I need some advice.

Rebuilt my computer to get a quieter one to make music with. Installed n-track v6, must have been build 2441. It worked so-and-so, had problem was with some VSTi’s that I had only copied from the old installation, and not installed anew. After re-installing fxpansion dr-008 n-track now crashes when trying to play back a song tat uses that particular plugin. Crashe severely, locks up the computer pretty bad.

I’ve moved my music-folder to a different directory than in the old installation. The song files point to the old place, but that has not been a problem before, n used to query for missing files.

Also, doesn’t n-track recognize plugins in subfolders anymore? Somethin rotten there also.

I’ve got a bunch of half-finished songs and really need to duplicate my old set-up in order to finish them.


Iwont Tell

First I see on some of the boards that DR-008 may not be Vista friendly.
U using Vista?
What I would try is - get Chainer @
Chainer download
Load up DR-008 in Chainer and make sure it works OK (stand alone)
Chainer works as a stand alone and/or a VSTi.
Then load Chainer as a VSTi on a track in N and load DR-008 into that
Chainer VSti. You can do that. In other words once Chainer is loaded as
a VSTi on a track - you can open it like the stand alone and add any other
VSTi instrument.

Sometimes it’s easier to fix something broken when you have serious help.

If you could register at the above link and post your problems, it would be appreciated.


I’ve recently had a similar rotten experience that took weeks and a lot of effort to fix. The problem was caused by a certain VST effect (actually, a few vst effects caused the rottenness).

If you’re using Windows XP:

Try logging on under a different account…like the administrator account (being in the same group wasn’t adequate for me).

Does the problem persist?


Thanks for the replies.

Now, after fiddling around with the registry and a few re-installs things seem more promising. I did re-install n-Track once, but the main thing was to set up the plugins corrceltly. I removed some plug-ins
from my collection, re-installed some and entered some lines into the registry for one called Loopazoid. I have only free plug-ins, but some of those do need registration or installation. If such a plug-in,I.E the .dll-file, is present but is not installed n-track seems to have problems. Luckily, there is a log file for the VST re-scan function that can be found via preferenses/paths. The log helped me pinpoint the trouble spots.

It is an Xp machine. I’ll have to try the the account trick if I get into more trouble of the same kind.


P.S. Also, the VST-path specified in the registry might have something to do with the stability issues as well. Some plug-ins seem to be able to re-write that when installing. It was problems with the paths that made me re-install n, actually.

Cool, Iwont. Keep us posted.


The problems are back with build 2461. I downloded and registered that one as an upgrade. So I have v4 sitting on the computer, too. It was not removed during the install. Dunno if that is the way it is supposed to go.

I got the demo of a previous build
up and running, I think. With all the reinstalls, I’m no longer sure… but that one apparently had some serious Piano Roll problems.

Anyhow, I’ve registered at Bugzilla and posted a bug report. It seems to me that n-Track is
no longer works with fxpansion!DR005 drums plug-in. It just crashes and hangs the system.

Speaking for my self, that a major problem:-(

Thanks for the updated info on your probs IT - I’ll check the bug report for details, I’m not familiar with the drums plug-in you’re using but do know the piano roll and midi has been a problem.

Thank’s for the reply!

DR005 was the forerunner to the more well-known DR008. It has multiple outputs and choke groups, other than that, its a pretty simple piece of virtual drumkit.

Of course, there still might be something wrong with my system despite all reinastalls and whatnot, but I think the biggest bug is that n responds to plug-in problems by crashing.


Yep - went through that using EZDrummer with n - compatibility is the issue. Hope Flavio can find the problem for you.

Update: I’ve tried using a differnt account, as suggested earlier. No joy.

I also noticed an error in my first post in this topic. I meant DR005 there, too. So I can
´t say if its bigger brother DR008 works with n-Track or not.

I’m trying the Chainer-approach, now. At first, DR005 was loading up fine in the stand alone host. I dont have MIDI keyboard as of yet, so I could not try playback.
Using Chainer inside n-Track as an plug-in and loading it with DR005 causes the usual chrash and hang. After that I’ve also tried starting n-track, then starting Chainer in stand-alone mode in order to use MIDI to connect the two. Loading DR005 into Chainer caused Chainer to crash. And after that, loading the stand alone version with DR005 and no n-Track running also causes Chainer to chrash, even if I re-booted in between.

This does not look good. If Flavio can’t help me out, I’m gonna have to rebuid my unfinished songs with another drum sampler. As that means most of my music, its something I
´d rather avoid.

The plug-in might be corrupt. Gotta try a new dowload.


Quote: (Iwont Tell @ Mar. 08 2009, 10:47 AM)

The plug-in might be corrupt. Gotta try a new dowload.

Nah, that
´s not it.

I installed EnergyXT just to test the offending plug-in in another program. Look and behold, DR005 chrashes that one, too!

This seems more and more like som weird hardware or driver incompability. Man, I’ve spent enough time already on rebuilding this computer, this is getting ridiculous.


I wasn’t able to find DR005 anywhere on the net, it looks like it dates back to several years ago. Do you know of somewhere (legal) where it can be downloaded?
FXpansion kindly sent me a license for DR008 and that seems to work correctly with n-Track.


Quote: (Flavio Antonioli @ Mar. 10 2009, 9:48 AM)

I wasn't able to find DR005 anywhere on the net, it looks like it dates back to several years ago. Do you know of somewhere (legal) where it can be downloaded?
FXpansion kindly sent me a license for DR008 and that seems to work correctly with n-Track.


The installer can be found at:

under DR-005.

the codes can be found at:

I don't know about the legal bit. DR005 had gone freeware when I downloaded it years back, the regcodes were provided.

Yes, it's old. That also means a lot of music has been made with it.

An update:
My internet connection is via a moblile phone, that is connected to USB. I've had USB-related issues with nTrack in the past, so I suspected something might be tied up there. I also have let Windows update the USB device drivers to get USB2 functionality, that might have something to do with the problems, too.
So I uninstalled Nokia PC Suite with its drivers. This caused DR005 to work on energyXT. nTrack would still crash, but in a more controlled manner. It no longer hangs the system and exits to a problem report/dump... that might be due to new audio drivers as well. Who knows? I get confused.
I tried removing all gear connected to USB-ports and re-installing nTrack and the plug-in. This did not help.
Reconnecting the USB-gear (mouse on an old and USB1.1(?)hub-equipped Nokia CRT monitor) did nothing for the behaviour of nTrack or energyXT. Reconnecting the mobile phone and re-installing the Nokia PC software did not alter nTracks behaviour either, but it brought back the chrash in energyXT. The mobile is connected via the hub.
The motherboard is an Asus A7N8X rev 1.04.

A tale of woe, this. I really hope you can help!


Just downloaded and installed. (dr005) from the above site
Works for me with Chainer, and also works fine in N ver 6.0.3 build 2459 (on my laptop)
No crashes.
Anyone else verify?

BTW thanks - now I got another toy to play with. Not much different than NTD though as far as I can tell. NTD has more options. plus built in reverb.

didn’t get a serial # or email just a download :disagree:

Use this: 5707-7538-4409-6997

D/L dr005 here:


n-Track can’t find it - I rescanned 3 times where I installed it and I get nothing.