Speed is varying on recording!!

I’ve been using Ntrack for years, but have recently come up against a strange problem. I installed version 5.0.3 on my new laptop and did a quick and dirty multitrack to check it out – to my surprise the 2nd, 3rd etc tracks didn’t sync properly with the 1st on playback. They gradually got ahead! It was very subtle but after 30secs or so, the tracks would drift out of sync!

I thought maybe it was something buggy with this new version, so i went back to 4.x and same problem! So then i thought maybe something screwy with the internal clock of the laptop, so i tried it out on my new PC, and same problem!! This must be a setting or something; but i cant get my tracks to stay in sync! when i look at the wave shapes, it is visible way out of sync after a few minutes; so the playback is true, but the recording seems to be operating at a different speed. Its extra strange, cos the pitch is correct, so i cant understand how the recording is operating faster than it should!

Whats going on!?

Hi GryphonKD:
You might want to check in the Prefs.>Settings>Options to see if you have the system timer Boxes checked… Try them borth ways… Some setups needs the boxes checked some don’t…

I hope this helps your setup…


When i start recording the second track, i can see it being drawn into the timeline and keeping up with the vertical playback line of the first trak… but as time goes on, the graphing of the second track, and hence the recording falls behind the first track playback – which when you stop and playback, has the second track gradually getting ahead of the first track.
My machines have heaps of processing power and are hardly being taxed at all – so why cant the recording keep up? I’ve tried giving the program highest priority and playing with the system timers on and off, but no difference.
Is it a buffering or live input processing thing? I never had problem with this on much much less powerful machines.

I’ve just noticed that this too happens on the first track, i.e. when recording the first track, the timer (vertical bar) eventually gets more and more ahead of the plotted wave for the first track, so it seems to be that the recording of any track just can’t keep up with the clock!

are you using an external device to record / playback through

Dr J

Im using a SoundBlaster AUdigy Live Value.

A bit more poking through the forums seems turned up the resolution to my problem, as it seems a few people have this issue. I just needed to set the recording sample rate to 48Khz, not 41.1.

Looks to be fine now. :D

check that you are recording at 48000hz thats the rate that the Audigy uses, if you have N set to 44100 you will get a sample rate mismatch -

Dr J