Strange CPU activity

I am confused. A not unusual condition for TusterBuster, but this is lasting longer than usual so I’m asking you, dear friends, for help and advice.

I use n-Track 3.3 build 1516 on a Toshiba Satellite A60 notebook with Celeron 2.8GHz processor, 1GB RAM, Windows XP SP2. Tascam US-122 with ASIO drivers, 44.1kHz, 16 bit. The PC is tweaked according to XPmusic recommendations and is free of nasties according to all scans.

I have a song with 11 audio tracks and 2 midi tracks. Four tracks have the Classic Compressor plug-in and there is Classic Master Limiter and Equalizer in the master section and Classic reverb on Aux 1. Until a few days ago it played normally. Now the CPU usage peaks during the song, always at the same places, lasting for about 30 seconds, causing pops and crackles. Buffering is set to High (default). N-Track responds sluggishly, with delays of several seconds before reacting to a mouse click on the stop or other buttons.

I have checked and there does not seem to be anything running that shouldn’t be. Network is not connected and antivirus disabled.

I used the Task Manager performance monitor to graphically show CPU activity while the song played through a few times and captured the result using alt/print screen. The pattern is the same each time, which says to me that it’s activity within n, not something else. CPU usage is around 25% idling, rises to 60% as the song starts, peaks to 100% three times during the song, then one time for just a few seconds, before finishing at 60%.

I note that the n-Track indication of CPU usage constantly shows 20% less than Task Manager.

The tracks in the song don’t change much; there are volume envelopes, but no obvious events at the time the CPU activity peaks.

Other songs play normally, and n-Track responds normally.

Sorry for the long description. Any ideas?

Thanks, cheers
T.

Quote (TusterBuster @ Sep. 14 2005,16:00)
Until a few days ago it played normally.


Any Windows Update, new Software, drivers?
Do you have any old version of the same project in order to test?

Are you using the N-track built in EQ? That had some bugs that caused excessive CPU usage. The bugs were fixed in 4.x . Try loading the song into the 4.x demo and see what happens. (Just don’t save it. Once you save the song as a 4.x format, there is no going back to 3.x)

Do you have Windows update set on Automatic? An update applied semi-unknown to you could be the culprit if you know nothing else has changed. Also, for grins, you might try the revert to defaults thang then tweak n-Track back to way it was before.

I dual boot my DAW PC, the “real work” config has no network junk on it. If I don’t install software from a CD, memory stick or portable hard drive, it ain’t gettin on there!

TG

PS One other thought… does the same spiking occur when playing back through either the US-122 or the onboard sound?

PPS BTW, you know if using the ASIO driver you MUST set the buffering in the US-122 control panel right? n-Track’s settings are ignored if using ASIO.

Thanks for the speedy replies.

1) No new updates; I have turned off automatic update, I do it manually, haven’t done one for a few weeks. No new software. The song is an old version, recorded months ago without any problems.

2) I don’t use n-Track eq; I use the Classic one. I think the n-Track had to be paid for with v3.3, Classic was free, no contest.

3) The internal sound card has been disabled since I got the laptop. I just tried re-installing the built-in sound card (Realtek) and Windows said it was enabled OK, but the sound is very distorted and low level. However, no CPU peaks.

I guess I’ll try re-installing everything (n-Track, US-122 drivers, plug-ins) and see what happens.

Any thorts as to why there is a difference between the n-Track CPU meter and Task Manager?

Cheers, nighty-night (bedtime here in sleepy Switzerland)
T.

Any volume curves fading the volume down to near zero in any tracks? Some plug-ins don’t like that as it causes floating point division to use smaller and smaller numbers, and when that happens the CPU usage goes sky high. There was a problem with some versions of n-Tracks that would hit it too, but I don’t think 3.3.1516 had any issues.

TusterBuster, Hi
I have been having that problem for some time now and don’t know what is causing the problem.
My problem is not only with n-track, I use an online guitar tuner and get the same slow mouse response.
If you find an answer to the problem yor having let me know…

Best regards

Don

Just to be clear, I have no problems with any other songs in n-Track, only this one. I have progressively deleted all effects, and even without a single plug-in effect the problem still occurs. I have removed the only two volume envelopes, no change. I have removed the two vst instruments, no change. I suspected there might be a wierd corruption somewhere, so I copied the wave files into Cubase LE and the song played fine with steady 35 - 40% CPU activity.

I guess n-Track thinks this song is rubbish. I’ll leave it as one of life’s mysteries and move on. ???

Have you tried making a complete copy of it to another section of the hard-disk (no just moving folder, but a real copy). Could it be a faulty hard-disk that tries to read a bad sector in a wave ?
Ludo

TB,
You said you had a couple of MIDI tracks in the project? I had some issues with a song with some MIDI along with the audio tracks. Someone else had done the MIDI tracks and I imported them. n would lock on that project on playback, until I converted all MIDI’s to audio. Upon examing the MIDI tracks I found some sysex data that was probably the culprit.

Flavio has done a lot of work on the MIDI parts of n-Track since version 3.3.

Don

Yaroo, yip-daps, hoorah and so forth, I believe that the cause is isolated. Dontuck, you were closest. Turns out that there is something wrong with the two midi files. They were recorded in n-T, not imported, and they play OK, but when I remove them the song plays normally with steady CPU activity around 40%. I’ve converted them to wave as suggested by Dontuck and everything now works fine. I guess they got corrupted somehow.

Thanks to Dontuck and all who tried to help.

Don, this won’t solve your tuner problem, sorry. Probably best to start a new thread, see if any of the gurus here can help.

Cheers
TB

I use 3.3 and have had this problem for some time. I think it’s a hard disk problem. I can find the offending track by muting each track and watching cpu usage. The problem sometimes occurs with only 3 or 4 tracks in the song and at other times I can get to more tracks with no problem.
It is annoying as I usually use a lot of tracks and I have to produce quite a few reduction mixes. If anyone has a potential fix for this problem I would appreciate it.

Hi Ledg. I use an external Western Digital firewire hard disk which checks out OK, so I am not convinced about it being a hard disk problem. Also, when I tried putting all the song files in a different location (I used another hard disk), as recommended by Ludo, the problem still existed. I think n-T includes the midi track data in the .sng file, 'cos they don’t seem to appear separately, so I can’t try playing them on another player. Maybe a hard disk problem could cause the symptoms you experienced but not, I think, mine.

Cheers
TB

Yeah, TB, I’ve had the same happen in the past, it’s frustrating, we have about the same setup.

Two work arounds I found.

I have started with a new song and imported all the wave files and started over. A real pain as the files do not always start where you want them, so you gotta move 'em around.

Another suggestion is to mix down some of the tracks to one wave file, say combine all the guitar tracks, or percussion, or whatever, to cut down on the total number of tracks.

I was unaware that n’s built in v3.3 EQ was buggy…

I haven’t used n-track for a while but I do remember having a problem with midi files during playback/mixdown.

The problem is that cpu usage skyrockets and the thing grinds to a halt. It seems to happen at a point in the song, I think it’s always the end, where there is no midi info being sent from a particular midi file.

I sent a report to Flavio but we didn’t really sort it out. In the end I simply took care not to play or mixdown the tracks as far as the “quiet” section.

Might be worth looking at what’s happening in your midi files at the point the problem occurs, on the other hand…

Mike

oops, I meant "only as far as the quiet section"

Mike

Thanks for the observation, Mike. I’ve only experienced trouble with this one song. There are two midi tracks, one playing the Lallapallooza vst soft synth and the other playing a synth-pad soundfont through sfz. When playing the song there are three distinct, repeatable points where the cpu activity soars for about 20 seconds. By playing with each track deleted I’ve established that two of the cpu peaks derive from one midi track, the third from the other midi track. I’ve solved the problem by individually converting each track to a wave file which worked fine. I’ve since tested midi recording and playback several times with sfz and various soft synths in n-T and Cubase LE and I have not seen the problem again. I’m assuming some sort of midi file corruption within the n-T .sng file.

Cheers
TB

PS: I’m still wary of upgrading to the latest version. From what I read on this excellent forum, it doesn’t seem quite stable yet.