Stretch a wav file track

Get tracks in synch

I have a tune I recorded on an older version of N which is basically a number of midi tracks. However, when I play them back now because they are each being sent to different VSTs, I cannot bring them together in synch.

I have a mixed down version of the same tune and it seems that I managed to get each of the tracks converted to individual wavs and, when brought together, they are all in synch. But what I want to do is change just one of the tracks which is a Kick Drum. When I go to the midi version and try converting just the Kick Drum track to wav and then importing that into the mixed wav version, the wav file is too short

I have tried using the time stretch method but the file (tried changing the original and creating a new file)will not change length

I have no idea how I managed to get the original tune so well in time - I am really struggling with just one track now

Weird. If I understand you correctly, you are using wav files rendered in the older version of n-T? Or rendered in the newer version? Do you have the BPM set properly? Do you just want to replace the kick sample, or is the part changed?

Hi TomS

Yes, both rendered in an older version of N. The BPM is set the same in both the midi and wav versions of the tune/sng file and so should be the same. I think I have too many VSTis on the tracks for my quite old computer to handle which is why I get synch issues on playback of the midi version. However, the Kick Drum track is played back through the midi mapper - no VSTi used.

I also tried exporting the pure midi to a new sng file with no VSTis playing. This was all in synch but when I tried converting the kick drum to a wav file and importing that, it is still shorter than the original kick file in the wav version of the sng file. I can only assume that when I rendered it all that time ago, I must have used a fairly large buffer/latency setting which has essentially made all of the tracks slightly longer. I’m using ASIO now, but maybe I was using MME or something back then. It was the same sound card

I think I have found a way around this problem. If you can’t beat em, join em…

Put the drum tracks through a drum VSTi instrument so that all midi tracks are going through VSTi and this just about gets around the synch issue

Seems like a better way to do it anyway. :agree:

I’ve got a feeling the midi drum track isn’t full-length. Or you are only converting a part of it. Also, you may need to re-align the midi tracks after export/import.