Stuttering when recording

I haven’t posted in a while. Hope everyone is doing well. I’ve been really busy at work and with some live music projects and producing tracks for a CD for a local singer. But a really weird issue seems to have reared its ugly head at me recently.

Well, I’ve never had this one before. This started a few days ago. On a simple project with 5-10 audio tracks, maybe a MIDI drum track or two playing through one instance of sfz,and only a reverb plugin on Aux 1, my CPU usage is around 6%. Periodically, n-tracks will jump to 100% usage (as shown in task manager) for a few seconds then return to normal. During that time, the music stutters as if stuck on one sample, then after a second or so it goes on as if nothing had happened. CPU usuage returns to normal. This happens every 3-5 minutes while recording, not at the same place on the timeline. The track being recorded does not fall out of sync with the rest. Sounds like Mel Tillis on steroids!

I’m on build 2172 on my Dell Dimension 9100 with 3.0GHz PIV and 1.5GB RAM, dual SATA drives (1 for OS and Program, other for files). Audio cards are Delta 410 and Audigy 2ZS. The Delta is used for all recording and playback in n. The Audigy is for system sounds, CD playback, etc.

Prior to installing 2172, I had been having some trouble with tracks being out of sync with previously recorded material (this was build 2170 I believe). I had always used the WDM Delta driver with good results, but all of a sudden I started getting tracks out of sync. So, I switched to the ASIO driver. It would be OK for a while then the problems would start again. My next step was to download and install the newest Delta driver from m-Audio. Got some burps, so I increased latency setting in the ASIO control panel to 1024 samples. Still got some burps. So I went up to 2048, the highest setting. Now I’m getting this 100% thing described in the first paragraph. I guess I’ll play with it some more tonight and install build 2174.

Has anyone had anything like this on the newer builds? Or does it sound like a driver issue? Could it be the video card? It’s the ATI 300XE or something like that (the one that came with the computer with digital output)?

Man, after all the hassles with version 4.x, I thought I was stable with 5.1. Since everyone seems to be having pretty good luck with 5.1, I thought maybe it was something else on my system interfering. The only new software I’ve installed recently is Norton Internet Security 2007 (upgrade from NIS 2006, which never caused any problems running inthe bacground along with n). This is really annoying!

Thanks in advance.

Don

<!–QuoteBegin>

Quote
Has anyone had anything like this on the newer builds? Or does it sound like a driver issue? Could it be the video card?


Yea, it could be a vid driver. Could also be a problem with the midi and soft-synth. How is the performance with only audio tracks?

I’m having good results with the latest build, WDM drivers and default buffering. Haven’t tested the midi yet, I think I’ll use another app for that because I had too many problems with n’ and midi (softsynths) in the past.

Thanks for the response, Kenny,

It does the same thing with just audio tracks. Today I was watching the screen and doing some mixing tweaking of some tracks recorded a few days ago, and it did the stutter thing. Since I was looking at the screen at the time I noticed that “autosave” came up. I have n set to record automatic backups every 10 minutes. So, I now suspect that when the “stuttering” occurs, it’s when the automatic backup is done. The time interval would be about right. My backups go to the music drive, in the same directory as the song. If the song is playing or recording, it would be accessing the wave files in that directory. It’s likely that the few seconds it takes to write the backup .sng file could be causing the sticking I’m experiencing. Maybe someone else has had this happen??

I’ll try turning off the automatic backup and see if it stops.

Don

Try increasing buffering too. Any plug-ins running? Or programs in the background? Did you try defragmenting the disk?

Well, I finally got a chance to get back in the studio and check out the auto save. I unchecked “save backup every xx minutes”. That stopped the sticking as far as I can tell.

Since I’ve been having some latency and sync issues lately, I wonder if there’s not something else going on on my computer. I’ve updated drivers, defragged my data drive, etc. Has anyone else had a problem with the automatic backups? I’ve written to Flavio describing what’s going on. Haven’t heard back yet. I’ll post his reply if it’s anything that might benefit others.

Thanks, Kenny, for your help.

Don