Suspect bug

With the latest build I still have the delay in playback if I have the “compensate for plugin latency” box checked (with all drivers, settings, buffering, even with NO PLUGINS etc…)…NOW? If I have this box checked my recorded wave files are delayed by the same amount of time as the aforementioned playback delay…a few seconds. Uncheck the box and everything lines up perfectly while recording and playback starts quickly…My plugins are reporting 1 ms of total latency (and I only have a few on this project now, a reverb, delay and 2 comps )so it is not a function of actual latency but how ntrack tries to compensate for it Even if I turn all the effects off with the master button…sigh. I still can’t get N to stop creating peak files while recording regardless of the preferences setting. As soon as I am done typing this I will begin the laborius task of porting these 3 songs over to R (I know how to use EDL but it doesn’t seem to get my aux’s and plugins over correctly) as the artist is coming by for a session tomorow and I won’t have the luxury of messing around settings all day…Of course I will have to burn some midnight oil getting more proficient at R and routing…I am reaching the end of my rope!!!


I’m very intrigued by this bug, so forgive me if I asks questions already answered, or seem redundant. I’m wondering because many of us aren’t having these delays and you are still seeing them with no plug-ins. Yes, I know you aren’t a noob…that makes it better because I know your answers will be meaningful.

You said this happens on all of your machines, and that they aren’t the same.

What IS same on them? (besides n-Tracks) ANYTHING that’s the same (net connection, brands even if the models are different …)

We need to find out what’s common, since it happens on all your machines, but many of us don’t have this problem at all.

I can’t help you with n-Track Ray, but I will pass along EDL basically saves you a lot of time manually aligning tracks and edits to items on the tracks. There’s a bit more than that, but basically that’s the biggest time saver. You’ll have to do your routing and plugin inserting manually.

Sorry you’re still having problems.


EDIT: You can get an idea of what EDL does by opening the file in Excel. It’s just a text file with comma separated values. The header in row 1 will tell you what the column of values is… Fun to look at and learn a bit.

EDIT Zwei: If I recall correctly, the Sony EDL *.txt option worked best for me when I was moving stuff over.

I just loaded build 2385…NOW if I try to record whilst the “compensate for plugin” box is check in prefs…it just crashes with a fatal error…if I uncheck it and use the ASIO drivers from M Audio it seems to work although I get terrible popping and dropouts (always have using ASIO with Ntrack regardless of the ASIO settings in the Delta control panel)…If I use the wdm drivers I get the delay in the recorded track…The only thing in common between the machines is Win XP sp3 and the processor…a 2.8 P4. I can’t record on the internet machine…My DAw is an IBM 2.8 with a gig of ram, two hard drives (both defragged, one for system, one for audio)and a Delta 66 with the latest drivers…seems like these problems creeped in around the time I “upgraded” to sp3…be nice if I could roll back and see what the difference is without a total reinstall…


I doubt if SP3 is the problem Ray. I have it on all my boxes and noticed no difference other than maybe slightly better performance.

Q: Do you have an OLDER version of the M-Audio driver you can install to try? You say you never could use ASIO with any driver version or any version of n-Track?


Well, I just tried an older driver to no avail…and rolled back to SP2. I have never gotten ntrack to play well with the Delta ASIO drivers and I have had them all going back to Win 2K pro…makes me long for my old AMD 1.4 machine with win 2k pro, N 3.3 and no Waves Plugs…I was running smooth as a gravy sandwich for 4 years…never had a problem until I got the waves, noticed the envelope bug (well then…the 1.4 machine died and I didn’t feel like repairing a dinosaur)…sigh…I am 1/2 way done with porting over to R…now I gotta learn to run it…tonight!



porting over to R..

This brings up the bottom line question of "Why will Reaper run so well on systems that n-Track has problems with?"

Anyone have any theories as to what exactly the underlying issue is? And why?

I'm with D on this - brutal honesty will get more done than 10,000 work-arounds.

Well, Reaper runs well but has a flickering of the gui…which seems to be a redraw problem according to the forum over there…so far is doesn’t effect playback or recording…I cancelled today’s session (didn’t mention DAW trouble)so I could get to the bottom of these problems…



I'm with D on this - brutal honesty will get more done than 10,000 work-arounds.


Ray, that flicker problem seems to be hit or miss. I have ATI, nVidia and Intel graphics cards on my various machines and (knock wood) I haven't had it occur. Go figger...


Anyone have any theories as to what exactly the underlying issue is? And why?

Yep. I can't PROVE a single one of them though other than my own experiences... besides 99.9% of the peeps here don't want to hear about it anyway.


You’re missing the point, D.

Most of us don’t have any problems, yet a few do, and those few are having issues that are so drastic they have to point out to the rest of us that they are having so many problem that they can’t use the application.

What I’m trying to narrow down is what’s different between machines that work fine and machines that don’t work.

Since n-Tracks is installed on all machines that is not the answer. We know it’s on the machines that work and it’s on the machines that don’t work.

Ray has two machines that he has previously said were different but he had the same problem on both machines. What IS different? The list needs to be very specific.

I have n-Tracks running on three machines, and all three is DRASTICALLY different, yet there are no problems on any of them. I’m doing nothing special on any of them and have to do no special workarounds to get n-Tracks running.

I’m trying to get to the root of the problem, D.

Jesus Christ Man…It really gets old to see you post yet again that n-Tracks does work for you yet Reaper does. So…use Reaper…but be constructive. Yes, it should work, but obviously it doesn’t. Let’s not complain yet again…let’s try to get to the bottom of it. It’s not that we don’t want to hear it, as you say, it’s that we’ve already heard it so many times…MANY MANY TIMES.

Ray and D…What are your hardware specifics? What chipsets are in you machines? What brand
and model motherboard…need all hardware and driver versions.

My main DAW is an ASUS A7V600 Mobo, VIA KT 366 (I think) chipset with an AMD AthlonXP 3200+ processor. 2GB of PC3200 RAM and two WD 7200 rpm/8MB cache hard disks. nVidia something or other graphics. EVERY OTHER audio app I own works great. n-Track runs… it just doesn’t run worth a d@#n and is too buggy to fool with. Upgrade my hardware? Why? When I still get value out of it using apps that work?

The solution IMO, is to get rid of the years of BS legacy code that is hiding in n-Track and drag it into the modern era with a major re-write. Since Flavio is a one man shop and n-Track is a “hobby app” for him and aimed at beginners, that is unlikely to happen.

Phoo, you’re right! I apologize. They say if you don’t vote, you can’t complain about the outcome. Since I no longer have a vested interest in n-Track, I have no right to piss and moan.


This brings me to a point of thought that arose in my little bwain this morning.

“What would I do if I owned this company?” That evolved into "What if n-Track was a ‘user owned’ software?"
That birthed “Is there a business model for a user owned software company?” That of course went to "I wonder if Flavio would sell n-Track?"

It’s just the way I think sometimes.

We need to get this fixed, now. That’s the only thing I could come up with, If I owned this company. I have no idea ‘how’ but that’s beside the point.

Quote: (Poppa Willis @ Sep. 15 2008, 10:35 AM)

"Is there a business model for a user owned software company?"

Maybe, could be,

I think this guy kinda did it.

lol :laugh:


DOS = “Diogenes Operating System” til that con man STOLE IT!


Quote: (Diogenes @ Sep. 15 2008, 9:26 AM)

Phoo, you're right! I apologize. They say if you don't vote, you can't complain about the outcome. Since I no longer have a vested interest in n-Track, I have no right to piss and moan.

You can continue to piss and moan or insult n-Track as much as you want in other forums. This forum is for constructive discussion. I, and the people who report problems or give feedback, are trying to build something.
I've renamed this topic to 'suspect bug' because a strange behavior happening to one user doesn't necessarily make it a bug.


This forum is for constructive discussion.

You sir, are correct. Again, my apologies!

Good luck and best wishes!




Your chipset is KT600

Are the WD harddrives SATA or IDE? Some folks are having flakiness with SATA drives and that MB.

Many folks have had odd problems with VIA chipsets through the years. I can’t say that’s related in the least, but other folks have gone away from VIA motherboards because of past experiences.

As a side note, I just happen have one machine with an ASUS A7V???. It works well most of the time, but has never been good for audio because of general instability. It showed up in the kids games first. It works fine as long as it’s surfing the internet, but as soon as any thing puts a lot of throughput to the hard drive is reboots. (I posted about this machine in another thread…before I figured out what it was…and I still don’t know why it does what it does…I suspected it was the power supply, but that’s been ruled out). I haven’t been able to install Xp SP3 because it shuts down while accessing the hard drive. This machine has had minor issues like this since day one. It seems fine then something happens and it needs to be rebooted. Usually an app will just hang. Recently, it’s been used for the GuitarPort and internet only. It’s been doing fine with those two.

Searching for D’s problem has been enlightening.