Sync & Lag Issues - Offset recording parameter

value of offset recording has no effect

I have rerouted output from the sound card to input and played my drum track, so recorded track wave form is exact as played one. That way I was able visually to confirm delay that can be adjusted with value of offset recording. Note: while performing this adjustment time stamp of xx.xx:xx is not accurate enough.

Result - no matter what value I used - there was no effect. I am always measuring the same delay even after the adjustments.
Could you please let me know if there is some procedure to correct this?
I have tried ± 100 ± 1000 ±5000 the same delay exists (visually confirmed).




From Help

5.3. Sync & Lag Issues
With some soundcards, new recordings don't sound perfectly in sync with the previous tracks because of the inability of the soundcard to start the recording and the playback at the exact same time. If you notice a sync problem in which recorded tracks are constantly (i.e. with equal delay during the whole length of the recording) too early or too late with respect to existing tracks in the song, you can use the Offset recording by parameter in the Settings/Audio devices/Advanced dialog box to compensate for the problem. Use a negative value if the new tracks sound delayed or a positive value if new tracks sound too early (the program will shift new tracks to the right by the amount specified; if the compensation is negative, the shift will be towards the left). The default value of 0 will work on almost all systems.



Usually, there's no need to worry about the compensation settings, so read this only if you can hear a shift between the recorded tracks. If you experience sync problems try unchecking both the Preferences/Options/Use system timer for checkboxes, then set the Preferences/Recording settings/Hide lag indicator… parameter to 1.



During a recording, notice the value that appears near the “lag” label on the time window on the program's toolbar. If the lag value is constant throughout the duration of the recording, you can compensate for it using the compensation setting discussed above. If the lag value grows constantly during the recording, the problem is most likely caused by the soundcard sampling frequency not being perfectly constant or by a difference in the soundcard's recording and playback sampling frequencies. When this occurs, the problem can't be fixed using the compensation parameter and the program may not work properly, so it may be necessary to use a different soundcard.



Note: the lag values reported are based on the recording and playback position information reported to the program by the soundcard. This information may be incorrect so it may lead to think that sync problems exist while it's just that the recording and/or playback times are being reported incorrectly. It's very important to double check with your ears if the lag values reported make sense.

mmihalj,

I was indeed able to find a problem with the ‘Offset recordings by…’ Audio devices -> Advanced settings, which made it have no hearable effect.
The next build which will be online within wednesday will fix the problem.
However note that that is a ‘last resort’ way to fix a condition that shouldn’t occur, i.e. that the audio device appears to have a problem synching playback and recording.
You can obtain the same effect by manually shifting the recorded parts by a set amount. To be able to make very fine adjustments you can enter the offset using ‘samples’ unit in the part properties box that appears double clicking on a track’s waveform.
If you’re using MME drivers please try to see if the same sync problem occurs when using WDM/WaveRT or Asio drivers.

Flavio.

Flavio, thank you for the prompt response. The idea was to automatically adjust for the recording latency by the software so that I don’t have to manually shift every take I make. I believe there is such a feature in cubase - measure the latency and then enter the number of samples in an ‘auto adjust’ box, and from there on, I don’t have to worry about latency any more - the software should shift the take by the preset number of samples automatically. This would be tremendously helpful. Imagine doing 50 takes of the same thing, it is painful to have to adjust this manually every time, and also very easy to forget or lose track of what has been shifted and what not.

After latest update, [2949] I was able to adjust my Lag. Magic number -1250.
Thank you for addressing this!

:agree: