Sync Issues. I'm facing a disaster.

At first I thought I might have nudged a track out of position while I was editing but it seemed as soon as I placed the time line over the area that sounded out of sync it played fine from the point on till the end of the song. There is something much worse happening. Over the last few years when making my albums I ran across this all the time but like I said as soon as I clicked on the time line it was back in sync.

Now I’ve investigated this fully. I have a 32 track song. On one track only, I have n-Track reverb and it’s on a leed track. I run only one VST on the master channel that being Ozone 4 for mastering. Beyond this I have no VST’s at all. I run with as many buffers as possible, run n-Track with “High” priority and I can record just fine, both on my main PC and my laptop. Playback and mix down is in big trouble.

I have tested on two machines winXP/Win7 32 and 64bit versions of n-Track including older versions and the new version 7 and all builds across all platforms are doing the same thing. At about 3 1/2 to 4 minutes into the song when started from the beginning it begins to fall out of sync. Every song is doing it. Some songs it’s no so noticeable but others it becomes evident. Moreover, anytime I thought a part was out of sync I would click on the time line and poof! I could find no evidence of it being out of sync.

I tested muting all the tracks except for 2 and removed the check mark in preferences “read data from tracks even if muted” and it still falls out of sync.

My conclusion is as follows, when playing back a song from the start with no interruption till the song finishes the tracks will fall out of sync ever so slightly, in addition this translates also when you create the single wave file during the mix down process.

My thoughts: This is the a disaster of biblical proportions. This sync problem must be solved, in addition songs created in version 6 need to work in V7 as well as I run across issues during testing with songs not loading in newer versions to out right crashing while attempting to do it. Ozone 4 refuses to work as a VST in V7 but will work as DX plugin but with no option to load a preset, thats a disaster all by itself. Even if the sync issue is solved I can’t load my preset for Ozone4 in V7. I might as well just hang myself. The only way this is going to work for me is all my songs created in V6 must work in V7, Ozone 4 must work as a VST in V7 so I’m able to load my presets and the sync issue solved. If this doesn’t happen I just kissed 7 months of work down the toilet. I’ll take months to transfer all my settings to another DAW. Case in point, the 30 hours of work for just the bass volume envelopes alone will have to be redone.

PACO

Paco, I was under the impression that version 7 would co-exist with version 6. I’m a bit lost on this: The songs were recorded with verson 7 and you can’t use version 6 or are you saying that it does not matter what version you are using? I’d sure send this to Flavio to look at. What you are discribing is indeed a problem. I will load up the newest version 7 and see what happens to the 16 tracks I have recorded with version 6. If I figure out anything I will post ( I use Ozone 4 also)
Bax

Quote: (bax3 @ Apr. 25 2012, 3:13 PM)

Paco, I was under the impression that version 7 would co-exist with version 6.
I'm a bit lost on this:
The songs were recorded with verson 7 and you can't use version 6 or are you saying that it does not matter what version you are using?
I'd sure send this to Flavio to look at.
What you are discribing is indeed a problem.
I will load up the newest version 7 and see what happens to the 16 tracks I have recorded with version 6.
If I figure out anything I will post ( I use Ozone 4 also)
Bax

Everything was recorded with V6 v2691 32 bit. I only tried V7 v2923 to see if the sync issue was present there and it was. V6 v2691 32 bit song file refused to load in V7 (crash) so I installed v2870 64 bit the last build of the V6 series and saved a song there. It would run in V7 but had issues with an error that it was unable to draw the left control windows directly beside the tracks. V7 v2919 64bit refused to load any V6 songs and would just crash.


PACO

I’ve posted a video about
this sync problem that I discovered. Here’s the link.

http://m.youtube.com/watch?v=IGlQ_7hVcSI

This was a very difficult problem to find because any time that I discovered something was wrong with sync
I’d simply go to the time line where I thought
I had sync problem and play it back to see what the problem was and it would be gone, just like in the video. This is a very serious problem. Flavio sorry to be one to bring on the bad news.

PACO

Paco,

please check that all of the tracks speed settings and the global song speed settings are at exactly 1x. Note that in the track properties box there is a speed slider for both the whole track and the part you clicked on.
Also make sure that the preferences sampling frequency setting is the same as the frequency at which the tracks were recorded, I.e. that no track has the Resample sign.

Flavio.

Paco,

as for the other problems:
- we have tested Ozone 4 and 5, 32 and 64 bit with version 7, and they appear to work correctly. What is exactly the problem you have? If you can’t even see it in the list of available VST plugins please make sure that the folder in which the plugin VST dll file is located is listed in the n-Track list of VST folders. Specifically version 7 may have not picked up all of the VST folders that you had configured in v6, so you may have to re-add the folders manually in the VST folders pane (Preferences -> Paths -> VST plugins folders).
- if you still have a .sng file that works in v6 but fails to load in v7, please email it to me so that I can check what is causing the problem. Version 7 should coexist in the same computer with v6, and the .sng file format should be backward and forward compatible (i.e. new versions load old files and old versions load newer files) with versions down to 4.x.

Thanks,

Flavio.

Quote: (Flavio Antonioli @ Apr. 26 2012, 2:33 AM)

Paco,

please check that all of the tracks speed settings and the global song speed settings are at exactly 1x. Note that in the track properties box there is a speed slider for both the whole track and the part you clicked on.
Also make sure that the preferences sampling frequency setting is the same as the frequency at which the tracks were recorded, I.e. that no track has the Resample sign.

Flavio.

All track speeds Global and each track under properties report x1.0 for the track speed.
Sampling frequency for all tracks matches the project settings. Please note, the sync disappears the minute you attempt to re examine it by clicking on the time line in the area suspected of being out of sync as shown in the video. The problem occurs as a result of playing back the entire song from the start. In the video, on the last part, I mention you can really hear the sync issue and you can, simply clicking on the time line and playing back that part the sync issue goes away and you can hear that clearly in the video. it's effecting all the tracks so I thought.

I found the problem. PEW!! It's not a global problem so you can rest now but I did find out whats causing it. I have over the years used the transpose feature from the properties menu. I would add from +/- to -0.01 for example on one track. This would add a little depth to a pair of tracks. Although the transpose seems to works it does fall out of sync and exhibits the issues I have already reported. Can you fix it so the transpose doesn't fall out of sync over time?

I apologize for an inconvenience this might have caused. This issue was exceedingly difficult to track down. I am relieved to say the least that that all it is.


Thank you for responding Flavio

PACO

Paco,

do use any audio transposing in the song? (i.e. the transpose controls in the track/part properties box)?
It’s quite likely that it’s something in the song you’re working on that is causing the problem. n-Track normally reads sample by sample from the disk so there is no chance of loosing samples, unless some of the processing (transposing, time stretching or plugins) is altering the signal length.
If you can please email me the song (.sng + .wav files, i.e. zipping the whole song directory) so that I can examine the problem (you can use a file sharing service such as dropbox.com, memopal.com, box.net etc.).

Thanks.

Flavio.

Quote: (Flavio Antonioli @ Apr. 26 2012, 4:18 AM)

Paco,

as for the other problems:
- we have tested Ozone 4 and 5, 32 and 64 bit with version 7, and they appear to work correctly. What is exactly the problem you have? If you can't even see it in the list of available VST plugins please make sure that the folder in which the plugin VST dll file is located is listed in the n-Track list of VST folders. Specifically version 7 may have not picked up all of the VST folders that you had configured in v6, so you may have to re-add the folders manually in the VST folders pane (Preferences -> Paths -> VST plugins folders).
- if you still have a .sng file that works in v6 but fails to load in v7, please email it to me so that I can check what is causing the problem. Version 7 should coexist in the same computer with v6, and the .sng file format should be backward and forward compatible (i.e. new versions load old files and old versions load newer files) with versions down to 4.x.

Thanks,

Flavio.

I've the 32 bit version of Ozone, it won't in V7 v2923 gives me a nbridge error. I did download and install the 32bit version of V7 and it works fine. I'm not to concerned about trying to use the 64bit version of n-track with the 32 bit version of Ozone when it works just fine in in the 32bit flavor. At this point the majority of my issues are being worked out. I'm thankful for the support to say the least.

PACO
Quote: (Flavio Antonioli @ Apr. 26 2012, 9:17 AM)

Paco,

do use any audio transposing in the song? (i.e. the transpose controls in the track/part properties box)?
It's quite likely that it's something in the song you're working on that is causing the problem. n-Track normally reads sample by sample from the disk so there is no chance of loosing samples, unless some of the processing (transposing, time stretching or plugins) is altering the signal length.
If you can please email me the song (.sng + .wav files, i.e. zipping the whole song directory) so that I can examine the problem (you can use a file sharing service such as dropbox.com, memopal.com, box.net etc.).

Thanks.

Flavio.

I found the problem. PEW!! It's not a global problem so you can rest now but I did find out whats causing it. I have over the years used the transpose feature from the properties menu. I would add from +/- to -0.01 for example on one track. This would add a little depth to a pair of tracks. Although the transpose seems to works it does fall out of sync and exhibits the issues I have already reported. Can you fix it so the transpose doesn't fall out of sync over time?

I apologize for an inconvenience this might have caused. This issue was exceedingly difficult to track down. I am relieved to say the least that that all it is.

I'm uploading to drop box now, it includes the Ozone4 preset. Also the transpose is on Vocal 1 on track 22 and it's set to -0.01

I'll PM you when I have the link at drop box completed.

Thanks again,

PACO

Paco,

thanks for sending the song. It’s quite complex (lots of tracks and parts per track), it may come in handy to test how v7 performs agains v6.
Build 2925 should fix the crash loading the song with v7 64 bit.
The algorithm that n-Track uses for speed and pitch transposition sometimes causes loss of sync over long lengths. One possible work-around would be to use the part transpose setting instead of the track setting, so that each part is transposed independently and since the parts are much shorter than the track there shouldn’t be a noticeable loss of sync.
I should be able to fix the issue before the final version of v7 is released.

Flavio.

Quote: (Flavio Antonioli @ Apr. 27 2012, 3:31 PM)

Paco,

thanks for sending the song. It's quite complex (lots of tracks and parts per track), it may come in handy to test how v7 performs agains v6.
Build 2925 should fix the crash loading the song with v7 64 bit.
The algorithm that n-Track uses for speed and pitch transposition sometimes causes loss of sync over long lengths. One possible work-around would be to use the part transpose setting instead of the track setting, so that each part is transposed independently and since the parts are much shorter than the track there shouldn't be a noticeable loss of sync.
I should be able to fix the issue before the final version of v7 is released.

Flavio.

Ok, I've made a little head way. I took your suggestion of transposing just parts. If I transpose all the parts individually, we have the same sync issue, it falls out of sync regardless of the gaps, however if I leave a part out then it resync's after that part. What needs to be done I think, is when the transpose algorithm is operating when all parts are set to transpose the algorithm doesn't shut itself off despite the gaps and falls out of sync, it needs to shutoff/reset when a gap occurs just like when it reaches a part with no transpose because it does shut off and reset when it reaches a part that has no transpose on it.

The work around is going to be tedious affair. The file we were looking at Vocal1 is just one file with it's parts cut out. I'm going to have to create small parts in between each gap and put no transpose on them, thereby forcing the algorithm to reset after each transposed part. I hope you can fix this soon.

PACO

Just an update to this, The “put a Gap in” algorithm stop sign work around does indeed help, however it still falls out of sync, just not as bad. It’s in your hands now Flavio. I again, hope this can be fixed soon as it would be nice to finish up my Album.

Many thanks again Flavio,

PACO

An Update to this issue. I have discovered that the transpose sync issue becomes most evident after 40secs. Anything longer and the sync issue becomes very evident. As I mentioned, applying the transpose to parts as opposed to applying it to the whole track does minimize it, however any transpose will fall out of sync regardless of applying it to parts, that being said, applying it to parts does decrease the effect but only slightly when applying transpose to a single track.

I found a work around but it’s a lot of work.
Taking into consideration that things fall out sync after 40 secs where the ear car hear it, here’s an example of a work around, take the track that’s 4:30 secs long and divide that track up into 40 sec parts, take each part and move it to it’s own track, then apply transpose to that 40 sec part. Do this to each 40 second part on their own track and you’ll be able to use transpose with no real detection of sync issues.

This is what I did and I’ve have been able to rescue my album in this way. I must admit, this was a real issue, a ball breaker and for those wishing to use transpose, I suggest to not use use it until it’s fixed. This method is only a work around and time intensive.

Please note, any track part longer than 40 seconds will suffer from a sync issue when using the transpose feature. So keep each part to 40 secs or less on it’s own track and you can get by. 1 -40 second part or less per track.
It’s my opinion, that the transpose feature is definitely broken. Lets hope it gets fixed soon.

I hope this information helps,

PACO

Quote: (Paco572 @ May 06 2012, 9:49 PM)

An Update to this issue. I have discovered that the transpose sync issue becomes most evident after 40secs. Anything longer and the sync issue becomes very evident. As I mentioned, applying the transpose to parts as opposed to applying it to the whole track does minimize it, however any transpose will fall out of sync regardless of applying it to parts, that being said, applying it to parts does decrease the effect but only slightly when applying transpose to a single track.

I found a work around but it's a lot of work.
Taking into consideration that things fall out sync after 40 secs where the ear car hear it, here's an example of a work around, take the track that's 4:30 secs long and divide that track up into 40 sec parts, take each part and move it to it's own track, then apply transpose to that 40 sec part. Do this to each 40 second part on their own track and you'll be able to use transpose with no real detection of sync issues.

This is what I did and I've have been able to rescue my album in this way. I must admit, this was a real issue, a ball breaker and for those wishing to use transpose, I suggest to not use use it until it's fixed. This method is only a work around and time intensive.

Please note, any track part longer than 40 seconds will suffer from a sync issue when using the transpose feature. So keep each part to 40 secs or less on it's own track and you can get by. 1 -40 second part or less per track.
It's my opinion, that the transpose feature is definitely broken. Lets hope it gets fixed soon.

I hope this information helps,

PACO

Paco,

we're working to fix the issue, a build that fixes the problem should be online in a week or so. It appears to be related to using transpose on a track with multiple parts. A possible workaround is to use the n-Track Pitch shift plugin (or a 3rd party transpose plugin) instead of the track transpose control, they internally use the same algorithm but the plugin version process 'continously' and isn't influenced by the beginning and ending of parts.

Flavio.

Thanks Flavio,

I look forward to testing it.

Thanks again for your hard work and support.

PACO

Fixed in v2931. Thanks Flavio


PACO