System freezes whenever settings changed

Request for help

Have Ceative SB Audigy 4 soundcard installed and running WinXP on Pentium 4 processor and 1Gb of RAM. Installed 4.1.6 2066 build level of n-Track Studio 4 and have 24-bit activated. Anytime I change the settings for recording, playback and even in the preferences option, the system locks up completely and I have to reset / restart the system.
Flavio suggested I install latest drivers for my soundcard and video card (NVIDIA GeForce MX 440) which I did. Still resulted in the same situation.
I then installed the Beta version of n-track (again at Flavio’s suggestion): same problem still happens.
I’ve tried changing device drivers from MME to Asio and WDM, but I still get the same problem.
I’ve even uninstalled and reinstalled my sound card and its drivers, and n-Track: still get the same problem.
I’ve even had the system freeze when I’ve tried to Exit from n-Track.
I’m now COMPLETELY BALD and getting really desparate.
Can anyone please tell me what is going on here and how I can either fix the problem or avoid it, short of uninstalling the software and asking for a refund?
:O

Do you have any other sequencer to verify that the Audigy is working correctly?

Is your Audigy a PCI card and what slot have you installed it into?

Have you checked IRQ conflicts?

Have you set your video performance slider down to test for video conflict?

Just a few ideas…


KingFish

Under file/settings/preferences then the PATHS tab, is the mixer path set to your soundcard mixer .exe? I have a secondary sound card and if the mixer is set to the sound card my computer came with it will crash.

Hi KingFish and StuH!
Thanks for your thoughts and suggestions, to which I can respond as follows:
- I’ve got Cakewalk ScoreWriter installed and I can playback OK through the Audigy 4 soundcard, so that doesn’t seem to be a problem.
- Yep, the Audigy soundcard is a PCI plug-in one and its installed in PCI slot 1.
- Yep, I’ve checked the Resources of the Audigy soundcard in the Control Panel/System/Hardware/Device Manager/Sound, video and game controllers option and it says there are no conflicts.
- KingFish: when you say “set your video performance slider down to test for video conflict”, do you mean the hardware acceleration option in the NVIDIA GeForce MX 440 properties?
If so, no that’s one I haven’t tried yet.
- StuH: I had assumed that the Mixer Path was pointing (by default) to the Audigy soundcard. However, this is another option I need to check out, because there is actually an “internal soundcard” on the mainboard, so the path could be pointing to that, and maybe that’s causing the system to crash like yours did.
I’ll check these last two suggestions out and let you know how I get on (and if I get to regrow some hair… :D ).
Thanks guys.

Another thing I would like to mention. I had some other problems I think were related to my onboard sound chip.

The manual for nTrack says you don’t have to use the windows control panel to set up your secondary card. I’m not sure this is true. I went through windows control panel audio devices and set my secondary card as the default for recording, playback and midi. I also noticed my secondary card was not fully enabled in windows. That’s in the same control panel under hardware then properties. You may want to investigate this too. But maybe that only applied to my situation.

Hi MusicMaker:
I don’t have any Mainboards that have built-in audio cards… But I’ve heard of of these types of mainboards producing lots of issues… However, this is not on late versions of mainboards…

The “Fix” for some of these issues was to… Go in-to the BIOS and turn off the “ON-Board” audio of the Mainboard…

If you’ve already done that then you are many steps ahead of me…

I know you’ll get IT up and running… Keep at IT… you’ll be O.K. and all…

Bill…

[EDIT]

Go into the "On-Board audio card preffs. and “Check” do not map through that audio card… IT’s something like that… :O ???

I had this problem when going into preferences when there wasn’t an audio track already there. I just added a blank audio track to the song, then went into preferences and the problem disappeared (i.e. no hanging app).

Hope it’s this simple.

Ta
John

KingFish & StuH,

I tried moving the video acceleration setting to almost minimum and that didn’t seem to make any difference to the problem.

I ran a search to see if there were any other executable mixer control files and could only find the one, i.e. sndvol32.exe. So I specified the full path name to point to that file. When I checked in the View / Soundcard / Mixer Recording Settings and the Mixer Playback Settings they both pointed to the Audigy Mixer controls.

Something I have noticed though is whenever I’ve uninstalled and re-installed n-Track the Audio Devices ALWAYS point to the MME ones, which seems very strange when the user manual states on page 63, Section 4.16 Wave devices selection that “the program by default selects a WDM driver if any are found installed on the system, otherwise it selects the predefined MME driver”. I say this strange because Audigy does have a WDM driver which I can see listed in the Preferences/Recording Settings/Audio Devices, and yet it’s never selected.

Something else I’ve noticed is that with the WDM driver selected I can launch n-Track OK, but if I try to Exit from the application, the system crashes. Anything else doesn’t seem to cause a problem. The simultaneous input and output works OK, i.e. I can plug a guitar into the line-in socket of the Audigy soundcard and get a response on the vumeter and hear the output sound OK. However, if try to actually record, then the system crashes.

What I think I’ll do next is remove the Audigy PCI soundcard and see if I can get n-Track to work with the basic 16-bit “internal” soundcard on the mainboard. If it does, then I’ll know the problem is between the Audigy card and the 24-bit version of n-Track.

I’ll keep you posted.

That’s another thing I did. Wox. Ya that is in the hardware manager for audio devices too.

I thought it might help… sorry…

If the on-board audio has WDM drivers

Mabey, try turnning off the on-board audio in the BIOS while re-installing the Audigy drivers… Then go back in there and turn it back on after the S/B drivers are un-installed/re-installed…

That is… if it’s a conflict issue…

I know you’re gonna find it and then all will be O.K.

Bill…

I have had Audigy problems in the past as have a zillion others. Regardless of IRQ conflicts, when you’ve exhausted everything else you can think of, try uninstalling the software, shutting down, and moving the card to the last slot and reinstall the software. On my current system that’s exactly what I had to do to get the Audigy to behave with the onboard sound. I tried 3 different installation scenereos and believe it or not, each one yielded different dialogs and choices in Creative software. Someone else I know experienced the same thing. It’s worth a try if you want the card. BTW, the onboard sound on my motherboard had no “off” switch in the BIOS. The first 2 attempts at installing the Audigy did not turn it off but the 3rd install did. Then I installed an Audiophile 24/96 next to the Audigy and had that card up and running in minutes.

Maybe some of my adventure will be of help.

KingFish

Browsing the internet searching for driver issues for Audigy 4 and saw 2 things. Windows XP service pack 1 or better should be installed. Another fellow complained of driver conflicts with onboard Realtek AC 97 chipset. Said he disabled his onboard sound then reinstalled his Audigy drivers and all was fine. Believe this was already suggested.

Hi StuH, KingFish, and Woxnerw (Bill)!

I seem to have got around the problems I’ve been experiencing, so far, thanks to a suggestion from KingFish. Here’s how I did it -
STEP 1: I uninstalled n-Track Studio and cleared the Win XP Registry entries and the hidden files in C:\Documents and Settings…\Application Data, so that when I reinstalled n-Track it would look like a brand new install of the software to the Win XP OS.
STEP 2: I moved the Creative SB Audigy 4 soundcard from PCI slot 1 to PCI slot 3.
STEP 3: I reinstalled the Audigy drivers.
STEP 4: I reinstalled n-Track Studio 4.2.0.2087, and initially set up the following File/Settings/Preferences/Recording settings:
Audio Devices: Recording and Playback = MME: Wave Mapper. This seems to always be the default that n-Track selects for my Audigy 4 soundcard when first installed.
Options: Freeze files bit depth = 16 (default)
Paths: Sound card’s Mixer/Volume control path = C:\WINDOWS\system32\sndvol32.exe, which is the file for the Audigy soundcard.
STEP 5: I successfully opened and closed the File/Settings/Preferences/Recording settings, and Exited and then launched the n-Track application without the system crashing (freezing up).
STEP 6: I recorded a track OK without the system crashing.
STEP 7: I then changed File/Settings/Preferences/Recording settings/Audio Devices from MME: Wave Mapper to MME: SB Audigy 4 [C400], and then repeated Steps 5 and 6 again without any problems.
STEP 8: I then changed File/Settings/Preferences/Recording settings/Audio Devices from MME: SB Audigy 4 [C400] to WDM: SB Audigy 4 [C400], and then repeated Steps 5 and 6, again without any problems.
STEP 9: I then changed File/Settings/Preferences/Recording settings/Options from Freeze files bit depth 16 (default) to 24, and then repeated Steps 5 and 6 again successfully.

So far, since then, I’ve had no further problems.

I can only assume that moving the soundcard from PCI slot 1 to 3 and re-installing the device drivers for the Audigy soundcard must be what has fixed the problem, which makes me think that it must have been an IRQ-related bug, even though Win XP kept showing there was no resource conflict. Therefore, the problem must be somehow to do with how XP prioritises resource requests.

I’ve let Flavio know, so that maybe he can incorporate a fix in the next build of the source code.

So, a big thanks to you, KingFish, for your suggestion.
Maybe I sould now record a song called “Nine Steps to Heaven…” :D

Really happy to hear this. Enjoy.

Hmmmm.

I changed the setting from 16- to 24-bit in the recording vumeter and… the sytem crashed when I tried to Exit from the n-track application.
I didn’t change any of the other settings, which were defaulted to:
- Stereo -> two mono tracks
- Enable Live processing from this input
- Apply to all channels

Anyone got any good ideas or suggestions?

Does the Audigy 4 soundcard need to the use 24 unpacked, or 24 unpacked left justify setting option instead of the 24-bit (packed) format?

<!–QuoteBegin>

Quote
I can only assume that moving the soundcard from PCI slot 1 to 3

Usually PCI 1 shares with the AGP slot. That could have been your problem.