Tascam 224 digital recorder

drivers wont load

HELP! I have off this Friday and I planned on spend a few hrs over the 4 day weekend to record. Hope this isn’t off topic. I desperately want to record and can’t. Obviously, ntrack is the software that I use. Any idea how frustrating that is?

Here’s the deal - MY PC went haywire Friday nite - As a result, I had to do an FDISK and reload my OS - have done it before. Everything reloaded except for my Tascam drivers. I run the .exe file and there are no errors (Win ME file).

In the folder in C:\Programs" called “US224_install” there is a file named installlauncher.exe - I assume you have to run that to have the drivers/program load? Is that correct? When I do that I get 2 errors:

1st "C:\Program Files\US224_InstallLauncher.exe. A device attached to the system is not functioning."

2nd "Error Starting Program The INSTALLLAUNCHER.EXE file is linked to missing export SETUPAPI.DLL:CM_Get_DevNode_Status."

When I go into Settings\Control Panel There is an icon for the US-224 but when I try to open it I get the message "US-224 Control Panel Startup Error - Can’t find the US-224 driver."

Why would an icon be there if install file won’t run? How did it get there. Why would it be there if the driver isn’t present?

Main question: How can I fix this? Should I contact Tascam? Are there any IT geniuses in here?

Note: I did try to remove and reload the US-224 program - many times.

Please help!
Jim :(

INSTALLLUANCHER.EXE will run IF your US-224 is detected on the USB buss AND the driver has not already been loaded into memory. You should run the driver update/install package from TASCAM either off the CD or a net download. Then plug the 224 into a USB port. IF the USB system is functioning properly AND the 224 is detected, INSTALLLAUNCHER.EXE will load the drivers. Manually running INSTALLLAUNCHER.EXE WILL result in the error messages you posted.

It sounds to me like the unit is not being detected on the USB buss.


It’s fixed. I downloaded the app from Tascam in case there was something wrong with my CD. But on the install directions page it mentions having my unit off whn I 1st load the software, and then turn it on when it reboots - can’t believe that was it - but it’s fine now.

Thanks for the reply!

The idea is to get the drivers installed and ready to go before the hardware is there since plugging in the hardware automatically pulls up the drivers. That’s the way USB works. It’s sort of backwards from installing a PCI card.

Aside from that some USB hardware has minimal support in Windows in-box, but not enough to be full-featured without installing the full-featured drivers. Just plugging in the USB device will automatically install the Windows in-box drivers, leaving the device not working the expected way. Occasionally it’s a real booger to get the correct driver installed once that has happened.

THAT can be an issue with some PCI cards as well.

Yeah but, I loaded 2 other devices and their software on Saturday - a Minolta Film Scanner and an Epson 2200 photo printer - I deliberately had them on so that I would get the pront to search for drivers - you know “Windows ahs detected a new USB device and…” AT which point I would browse to the CD drive and the software would be loaded. It worked for the printer and scanner - not the Tascam - I’ll remember that for the future.


Yep. I have a US-122. It works that way too. You MUST NOT plugin the interface until AFTER you run the install CD. Once the CD install is done, plugging in the unit in a USB port loads the correct drivers in memory and bingo! It works.

Glad you got 'er going!