Time format problem

After resampling all track files

I goofed and resampled all of my 96kHz track wavs to 44kHz using r8brain then saved the whole song. I then decided to move my 96k track files back into the song and remove the 44Hz files. Now my time format bar (m:b:t) will not sync with the wav files. No matter where I set the offsets, it’s always 2 measures or off. Anything I can do other than live with it?

Many Thanks,
Rick

I tried this with another song I recorded in 96kHz, only I made a backup of the song folder first and never saved on exit. Even with the built-in wav file converter, The track wav moves in the timeline. It’s actually shorter and moved closer to the start. I also locked the wavfile’s offset previous to the conversion.

If this is normal, how would one resample their 96kHz tracks to 44.1kHz without losing the timing? Do you have to live with the original sample rate until you’ve mixed all the tracks to stereo? ???

Rick

I don’t understand the problem.

Just turn on the grid and slide the wave parts two measures, if they’re really exactly two measures off. I don’t see why that would be, though – must be something else going on.

Do you always record from the beginning? If so, the files should line up correctly (assuming you’ve set n-Track to the proper sample rate). But if not, you should still be able to shift them manually provided you have some kind of timing reference in the tracks to line them up visually.

If you started recording at various times and you’ve ditched the info in n-Track explaining the proper start time for the file, you’re hosed unless you can do it manually.

Some of my tracks are recorded from the beginning, others are not.

I can drag the tracks and line them up to their starting points, but they don’t play when they should, or where they are shown to be starting if you follow the mbt grid.

I believed earlier that the tracks were 2 measures off, but that’s not exactly the case. In my update post, I explained it better. It looks to me like the wav file changes length after resampling it to 44.1kHz. So if it’s a different length and the time bar is not, they will not ever synch up.

So I guess my question could be phrased as why does the wav file change length after resampling?

Thanks,
Rick

That could be the way r8brain works. Some programs do that. For example, encoding to MP3 and decoding will add about (but not exactly, and not always the same) 25 milliseconds to the beginning of the song. But I didn’t ever hear anyone mention this with r8brain.

BTW, to line up the tracks, don’t start based on where the box begins, line up based on looking at the waveforms themselves. If the sound doesn’t match the visual then something is messed up! (gee, takes a genius to figure that out!)

Finally, try using ASIO or WDM drivers rather than MME (the default). That’s set in “Preferences -> Audio Devices”.

Yeah, I know about lining up the waveforms, and btw the same wav file shortening takes place whether I use r8brain or the NTrk wav converter, so I know it’s not a function of resampling software, or if it was they would all do this and this would be a known issue.

On your NTrk, if you resample a 96khz wav file to 44.1kHz, does it shorten the wav-timewise? If it does, can you line that wavform back into position on your timeline and does it play the entire wav file in sync with the remaining 96kHz wav files?

If so, there is definitely something wrong with my NTrk.

I use ASIO drivers with a MOTU828MKII. I haven’t used anything else, but I don’t see how drivers would affect what’s happenning in the wavfile conversion process.

Thanks for your help, though.
I will contact Flavio.



Rick

When you change the file type are you also changing the sample rate in N’s Preferences?

If not, that would cause the shortening. You should also get a message from N that the file doesn’t match N’s format and asking whether to change it. I don’t remember whether “Y” means to resample the file or to reset N’s sample rate, but I suspect it’s the former.