Time Issue - Like big time!

Overdubs turn into chipmonks

I’m new here and just started PC recording. My limited experience is with a Roland VS1680. A great musician friend of mine turned me on to nTrack and I’m slowly getting hooked. And the idea of collaboration across the county by passing files around is too much to pass up. Anyway…

I’m getting some very wierd things happening with time. As an example, I had two guitar tracks originally recorded on the Roland. So I passed these over to nTrack. No problem. Getting everything set up was another story. Anyway, playback was just fine. So, I decided I wanted to add a reference vocal using the Roland as my mixer. Seemed to work just fine until playback. My reference vocal turned into Alvin and the chipmonks. The same as if I sped the vocal track up by a factor of 4.

So, as a test. I started a new session and did a test vocal using the Roland. Then overdubbed another test vocal. No problem. So, I’m thinking just do the whole thing over. So, I created a new session and recorded the guitar tracks. This time when playing back, one of the tracks slowed down to like 1/2 speed.

This is perplexing. Any ideas?



Right click on the individual tracks and check the properties. See if they are all at the same the race that bit rate. Let us know what you find out.

Yep. Make sure your imported VS1680 files and your n-Track session are the same. For example, if your VS files are 24/44.1 make sure your n session is set to 24/44.1. I think n use to prompt the user if there was a settings and file mismatch? If indeed you have mismatched sample rates and n didn’t alert you to it, this is yet another BUG that needs reported and addressed!


Bax/D - Thanks. I’ll check that out. I’m sure the Roland is set at 48. I used to leave it at 44.1 and decided to bump it up as I recall when I did the guitar tracks. I’ll let you know what I find.


A few questions… How are you getting your tracks into the PC from the Roland? Wave export via CD? Or are you just recording the analog output of the Roland into your PC via a soundcard? Which soundcard/interface are you using?

Just trying to help… :)


I appreciate the help. The sound card on my pc was part on the mother board, so I picked up a basic Sound Blaster. I’m running from the Master Out of the Roland (RCA’s) to the Line in of the sound card. Line out from the card goes to my monitors/phones.


Quote: (gnoub @ Sep. 05 2008, 12:33 PM)

I appreciate the help. The sound card on my pc was part on the mother board, so I picked up a basic Sound Blaster. I'm running from the Master Out of the Roland (RCA's) to the Line in of the sound card. Line out from the card goes to my monitors/phones.


Then your n project should be set for the SAME sample rate and bit depth for both your recorded VS tracks and your overdubs. Hmm... another thing comes to mind... many of the SoundBlaster cards operate natively at 48khz. They resample everything "on the fly" internally. This is known to cause problems such as timing drift and other anomalies. Try re-recording everything into a fresh n-Track project with a 48khz sample rate setting so there is no need for this SoundBlaster internal resampling "thang". When you are finished, remember to mixdown your songs to 16/44.1 to burn to audio CD.

Lemme know if that does the trick. Since you mentioned Sound Blaster, I'm pretty confident that resample issue might be your problem.

Stupid question: The Roland tracks are at a sampling rate of 48 and the it’s a 24 bit machine (I guess). I found that I could not monitor anything at all on nTrack unless I set bit to 16. Does this mean that the Blaster is 16 bit only and I should have picked up a 24 bit card instead? Or will this not make any difference?

Appreciate the help. As you can see, I know not what I do!


Well… this is kind of a weird situation… :) but not uncommon. As a matter of fact, I found n down the same path except I had/have a Tascam 788 Digital Portastudio. I exported my waves from the Tascam via CD into the PC and n-Track thus avoiding any “re-recording”.

In the scenario you described, your 24/48 tracks recorded in the Roland are being converted twice. Once by the Roland where the digital 24/48 audio is converted to analog, then again where the analog signal is converted to 16 bit 44.1 (or 48) by the converter on the SoundBlaster. While not “life-threatening” by any means, it ain’t GOOD either. There will be some loss of quality. If it’s noticeable or not is something only you can answer with your ears.

If you want to keep using the Roland basically as a mixer, why not look into a soundcard/interface like the Tascam US-122 or 144? About 150 bux will get you a USB2.0 connected 24 bit, up to 96khz sample rate interface with a pair of I/O. The 144 has an additional pair of I/O in the form of S/PDIF digital. If your VS has an S/PDIF output, you could get the 144 and keep it all digital. The US-XXX jobbies are also extremely portable should you decide to do some location stuff with a laptop or sumthin’. Lotsa good choices out there without breaking the bank.

While the SoundBlaster stuff is serviceable, they ARE designed primarily for gamers and entertainment use, not music production. I know I wasn’t very happy with PC based recording/mixing until I got a nice, app specific card. (EMU1820M)


EDIT: Forum dude “Poppa Willis” has a US-122 on eBay I believe. It’s the first generation US-122 and only does up to 24/48 but they are fine units.

I was using a Fast Track Pro (M-Audio) at first. I couldn’t get the thing to work properly on the playback. S/PDIF in from the Roland went no where. No signal at all. I could get from the Roland Master Out to the Mic/Inst in of the Fast Track with no issue. But had to click the pad (30 db) to not blow the meters up, and that send my levels way down. I could never monitor the tracks overdubbing either. Well, I managed once and when I could monitor tracks and overdub, there was a big delay. I made myself crazy for three nights doing that. But, maybe I was setting up wrong somewhere. You would think that this would have worked. I thought M-Audio was good stuff, but what do I know – must be all operator error.

As far as quality, I think maybe there is some degradation now that you mention it.

Anyway, I need instant gratification, as in this weekend. So, I’ll be uggin’ (literally) away. I’ll let you know what shakes out.

Thanks for the help!!


I’ll grab the Fast Track Pro PDF Manual off’n the ol’ webbernet and scope it over. If you still have it, we oughta be able to make it work.


I still have it. I’m getting hooked back up soon. Thanks!


Well, I figured it out. Basically, here was the issue and BTW, I went back to the Fast Track Pro.

The original guitar tracks were recorded on my Roland VS1680 with a sampling rate of 48000. When I was using the Roland as a mixer the sampling rate was still set as 48000. This would cause the overdubs to sound like I just took a hit of laughing gas. The nTrack guitar tracks were done at 24 bit. I couldn’t get any sound from the mic through the Roland at 24 bit. However, when I changed the Channel to 16 bit, the sound came through. I don’t get this since the Fast Track is 24 bit capable. Anyway, I changed the sampling rate on the Roland mixer to 44100 and set the overdub channel to 16 bit. All was well after that.


Cool Gary… BUT… but from what I read, you SHOULD be able to use the Fast Track at 24 bit? Lemme hit that manual again and we’ll get you all “ciphered out”. :agree:


PS Was this using the S/PDIF outs on the Roland to the Fast Track S/PDIF in?

Nope. Never got that to work.