Too Many Plug-Ins?

hmm…

So when I used to have a song with alot of plug-ins… I would start to get skips and blips and whatnot, usually once my CPU usage got over 80%.

So then I bought a new PC. It’s twice as powerful and works wonderfully. However… I still get lots of lag and blips and all that when I add lots of plug-ins… even though my CPU usage never goes over 45%.

So what exactly is wrong? I have a Sound Blaster Audigy 2 and a RME Multiface. It happens with both soundcards…

The lag and blips may be due to some other limiting factor, like the disk buss or PCI buss maxed out. Also, 45% on your new PC is still quite heavy, wow.

So how many tracks and plug-ins do you have going when the craziness starts?

Have you tried different buffer settings?
This makes a big difference for me. Of course, I am using WDM drivers, not ASIO.
You might also want to try the “muti-thread” plugin setting. Disabling this stopped some clicks for me.

it usually happens when i get over 30 tracks. usually i have a good 5-10 vocal tracks all with compressors and multiple instances of AutoTune.

I tried using higher buffers and that “multi-thread” setting. neither of them helped really. anything else i can try?

geekformayor, Autotune in particular puts quite a heavy strain on the system, and even with the more sensible plug-ins, it all adds up.

Try rendering the tracks that need autotune and compressor separately, one at a time, with plug-ins added, save them with different names, and import them into the project. Mute the original tracks and see if this helps. (You need to remove the plug-ins from the original tracks for this to work, of course)

regards, Nils

it usually happens when i get over 30 tracks. usually i have a good 5-10 vocal tracks all with compressors and multiple instances of AutoTune.

Not directly related, but I have a similar problem when I use Obitune (which uses the Autotune engine) *if* my track is edited/spliced and has gaps. Bug in Obitune or N-track? ?

It seems that Obitune gets upset and the CPU keeps going up. Only solution is to render the spliced track to a new one then add the effect, or as Nils suggested, render the whole thing with effects.


Mark
Quote (geekformayor @ Jan. 20 2005,23:46)
it usually happens when i get over 30 tracks. usually i have a good 5-10 vocal tracks all with compressors and multiple instances of AutoTune.

I tried using higher buffers and that "multi-thread" setting. neither of them helped really. anything else i can try?

Yikes, that's a lot of autotuning! Since autotune is not really something that needs to be adjusted to fit the mix. I'm with the others, just process those tracks and imported the fixed version of them.

yeah… i figured this was going to be the best way to deal with it so i suppose i will.

however… im still curious what is making it happen? is it my soundcards? my processor? i just find it odd since my computer is working half as hard as my old one was when it had the same problem. i guess i was under the assumption that i wouldnt have issues until i was reaching 70-80% usage like i had with my old one…

45% is NOT a lot of CPU usage. This isn’t the cause of the problem. I’ve run just fine up to 80% or more. Far more likely to be PCI latency or something like that.

Try turning all FX off (the little green “fx” button in the upper right hand corner of the timeline view, at least, if it’s still there for V4). See if you still have problems. I bet you do, and so you’d be wasting your time trying to fix what ain’t broken.

when i turn FX off (the small green button)… everything works fine. it’s definately because of the plug-ins.

… or possibly because a CPU load over 40% causes problems, and the FX simply get you there. Hard to say which, but I’m guessing it’s more likely you’re right and it’s the FX themselves.

AutoTune is particularly finicky, especially when there blank sections in a track (no wave part). It sure won’t hurt to freeze those tracks.

I always have problems with autotune (or ob tune in my case, though it does it in the AT demo too) running with anything else. It garbles and makes all kinds of rude noises. But that is prolly not your problem. However, I can say that I auto tune my all offline, and find I prefer it better that way anyways. not really a reason why it should be a problem.

fish