Track length after mixdown of single trk.

effects chain is cut off durring mixdown

:heart-break:
v6 Beta 3, Build 2371. I wonder if there's anything I'm doing wrong or if there's a possible glitch. When I mixdown a single track into a single finnished wave track the mixdown stops at the end of that tracks information and not at the end of the overall song project. I have checked and unchecked the box in the preferences box that commands the reading of tracks even if muted. Seems like 'reading the tracks while muted' should save the effects chain that is currently clipped at the end of the mixdown trk; provided that the overall project extends into that boundary.
:D

LOOONGGG standing BUG!

At the mixdown dialog, try typing in extra length or add a dummy track longer than the actual song.

D

That’s a llooonnnggg standing bug in the application, across many different versions. Been that way as long as I can remember and I started using V2.0.

The workaround is to add a small clip of any kind of wave out past the end of the longest track, far enough out so that if the lat few seconds get cut off the parts you need are still there. n-Tracks detects that wave way out there and renders (almost) out to it.

There is no other fix…yet.

The other tracks are of sufficient length to cover the effects chain…Thanks for the replies though :love:

Make sure mixdown entire song is checked in the mixdown properties box,.

Thanks Yaz, I think you solved my dillema!! :)

:agree:

Well, Yaz I sent you an email cause I can’t find the mixdown properties box. Damn! I know I’ve seen it before. Anybody got a clue for me? v6 Beta 3, Build 2371. I checked the settings/preferences/options tab. :laugh:

The mixdown button is missing from the toolbar by default…bug?

Mixdown on the File Menu
Asks for a filename (I liked auto-name way that added mixdown to the existing songname…wish that was an option)
Choose a name and Click Save
The next dialog that pops up will have a More Options >>> buton.
Click that and the stuff you need should be there

Thanks Poo, really appreciate you!! HOORAH for nTrack Eh?? :O

The new builds have a “Customize toolbar” feature. Right click on the toolbar and select Customize toolbar to add or remove functions from the tool bar, or turn on/off preconfigured toolbars. Besides getting selections off the toolbar that I don’t use, I can set it up so that I do not accidentally click on the speed bar at the end of the Transport toolbar.
Bax

Quote: (LEPROCY @ Aug. 30 2008, 11:32 AM)

Thanks Phoo, really appreciate you!! HOORAH for nTrack Eh?? :O



Yes... HOORAH for bugs that have existed for years and have lasted all the way to Version 6! Woo-hoo! :p



Yeah... I realize that was not helpful at all. I just find it amazing at how many people are willing to put with up all the wonky work-arounds... :disagree:

D

PS Practically EVERY DAW out there except n plays the FX tails and renders the tails properly. WHY this crap is STILL in n-Track is beyond reasonable.

I guess I have not had the problem because I always leave open track at the beginning and the end of a file. My reason has been so that I can hear the tails, and so that I have room ambiance so I can apply noise reduction if I have to. Is that why I haven’t noticed the problem?

Quote:

Is that why I haven't noticed the problem?


Most likely so Bax.

D

PS I had a big rant written up... thought better of it... nevermind... I don't care anymore...

I have never had to deal with that ‘bug’. I never leave any less than 2 seconds of dead air at the end of any take or track. I honestly don’t know why anyone would try to mix to the end of the track and not the end of the effects plus 2 seconds. ???? ya’ll just wanna count on magic buttons too much and need to suck it up and work at it. :laugh:

If it’s been such a problem why ain’t it been fixed?

And D - when are you going to free your soul and be able to tell folks what you really think?
Don’t keep it all bottled up!
:agree:
Strongest force on earth is a volcano - I’d hate to see you blow up on us! :p

I appreciate your honesty buddy. :agree: You’re rather transparent to folks that know a lot about folks though. People don’t get as passionate as you are from not caring. So don’t gimmee that

Quote:

I don’t care anymore…
crap.

How do you think that the problem should be fixed?
* there could be a preferences setting and/or a setting in the mixdown box that specifies how much the program should lengthen the song to account for effects tails.
* alternatively the program could monitor the song output and stop the mixdown only when the sound level goes below a given threshold.
* vst plugins do have a “tail size” property which could be useful for determining how much tail to use, but not all vst plugins correctly implement the property and DirectX plugins don't have it anyway so there must be a way that is independent of this

Perhaps combining the two things would be best as the 2nd method alone could potentially lead to infinite length mixdowns if a plugin (or synth) ‘oscillates’ and produces non-silent output for silent input.
When non-silent output extends below the maximum tail length the program could perform a short fade before stopping.

Flavio.

Quote:

Perhaps combining the two things would be best as the 2nd method alone could potentially lead to infinite length mixdowns if a plugin (or synth) 'oscillates' and produces non-silent output for silent input.
When non-silent output extends below the maximum tail length the program could perform a short fade before stopping.


I can't say for certain Flavio, but I would bet a months pay that is how the other guys do it for off-line mixdown. Some combination of the above. Sonar has the the option to "Play FX tails", Reaper has "Always run FX" and I can't remember what Steinberg calls it? Anyway, the FX are always "on" and being calculated. You can see this in the per track CPU use. Of course, since the transport is not running, there is no input so the effect output is silent. You have to watch for denormals! I don't know how the off-line render process works but I assume that somehow the program "looks ahead" to determine when the last actual audio processing stops and renders out to that point.

D
Quote: (Diogenes @ Aug. 31 2008, 8:41 AM)

I can't say for certain Flavio, but I would bet a months pay that is how the other guys do it for off-line mixdown. Some combination of the above. Sonar has the the option to "Play FX tails", Reaper has "Always run FX" and I can't remember what Steinberg calls it? Anyway, the FX are always "on" and being calculated. You can see this in the per track CPU use. Of course, since the transport is not running, there is no input so the effect output is silent. You have to watch for denormals! I don't know how the off-line render process works but I assume that somehow the program "looks ahead" to determine when the last actual audio processing stops and renders out to that point.

D

n-Track currently always processes plugins when the Live button is active.
I'll add a mechanism (probably something similar what I outlined in my previous post) for detecting effects tails for offline mixdown to v6.0.1

Flavio.

I do not think the issue is just effects tails. I rarely use effects that will cause tails at the end of a song, at least past the end of the last wave.

Keep in mind that this was my experience for so long that I regularly insure there is wave data way past the end of the music.

—Have a song that contains 3:00 of wave data per track - starts rignt at 0:00.
—Do a mixdown.
—The length of the mixdown wave may be anywhere from 2:50 to 2:59.
BUT
—The length might be exactly 3:00, but there is some extra bytes at the beginning but the end of the misic is truncated.

It hass been so long since I looked into the specific symptoms that maybe they have changed, but there is no doubt some kind of problem still exists. I have been assuming the bug hasn’t been fixed, based on the number of posts that ask about it, and the fact that the workaround solves the issue for them most of the time. The workaround being to add some wave data out past the end of the music to trick n-Tracks into thinking it is longer than it is.

A test will be to put a short blip at the end of a song and see if it is always in the mixdown. (I will do this if I get a chance)

To add an extra bit of oddity to this. I have noticed some extra data at the very beginning of a mixdown as well. This dead air data is in the ballpark of the current VST latency. This makes me think that mixdowns don’t take into account VST latency, just as the envelops did not until recently (a GREAT fix).

It is possible that the calculated length of the mixdown is correct, but the fact that rendering is not taking into consideration is causing dead data to the added at the beginning, but the end is cut off by that amount or more.

As I said, I always have some wave data in a track out past the end of the song. I have done that since running into this in V2. Mileage may vary in later versions.

I hope this helps and does not confuse.

Flavo, I think a combination of the first two (have a property in the prefs, and monitor playback levels) may be the best bet, but I am strongly leaning toward just say let’s be able to choose a number. Monitoring playback level can get tricky as it’s hard to know what “no output” is. (We run into this dilemma at work all the time)