Track loses connection to wave file after record

There’s a track, but no waveform

When recording several tracks, the second or third track will sometimes lose it’s “connection” to the wave file during, or shortly after, recording. This doesn’t happen all the time, but at least 20% of the time.

When it happens during recording, the waveform will suddenly disappear even though the RECORDING indicator will continue to flash. If I continue to record, I can find the recorded wave file on the disk, but there is no wave file associated with the track that I recorded it on. Sometimes I can finish the recording and see a waveform on the track, but a minute or so afterwards the waveform disappears. Sometimes I can play the track and hear the audio, but there is no display of the waveform. Other times, I cannot even play the track. If I check the track properties for a wave file, I get an error message saying “Error opening wave file. Select another filename?” Once this happens, nTrack shows this error for all the tracks in the project. This problem certainly behaves as if the link between the program and its wave files gets broken.

I have been trying to isolate this problem so I can submit a bug report. At first, it only happened when I had already recorded files longer than 2 minutes, but it just happened while recording the third 10 second track. So far, it has only happened when I use the feature that requires naming a wave file before recording. In fact, I had never seen this problem until I turned on this feature. However, this may only be a coincidence. Because the problem is intermittent, I haven’t hit on the combination of actions that will reliably create the problem.

This problem also started concurrent with an upgrade (I think it was build 2042). I am on build 2062 now. That didn’t solve the problem. I am on Windows XP, SP2 with all the latest sound and video drivers. I check-tested nTrack build 2062 on a Windows 2000 PC with everything different, and saw the same problem, so I don’t think it is specific to my installation.

Has anyone encountered this problem? It sure would be helpful if several users tried to find the combination that would reliably duplicate the problem. My setup is to record audio only. I have no volume envelopes activated. I see the waveform being recorded until the problem happens, then it disappears. If you have seen anything like this, let me know.


This is no help to you at all, but the same thing happens to me a lot… :(

I found what is causing it! It took a lot of tests, but while I was recording I saw the Autosave message appear and BAM! the recording waveform disappeared. So to verify the problem, I changed the “Save Backup every” setting to “1 minute” in File>Settings>Preferences>Appearance so that an Autosave would occur every minute, then I tried recording. As soon as I saw the Autosaving message appear, the recording waveform disappeared.

Now I know why it only happens intermittently and seemed to only happen with longer files. I had the autosave function set to save every five minutes and it had to autosave during a recording to cause the problem. It had nothing to do with the number of tracks, or naming a wavefile before recording.

Please set your “Save backup every” setting to 1 minute and record for more than a minute and see if your version has the problem. Look for a small “Autosaving…” message and see if your recording waveform cuts off at that point. I don’t know how far back this problem goes in version builds.

It appears that this is a program bug, so I will report it to Flavio.


A bug, possibly, but I would be inclined to think not.
Do you have a separate hard drive for your audio files, or are you recording to the same drive where your operating system lives?
If you only have one drive, it is possible that your operating system is using the drive at the time NTrack wants to autosave. In this instance, the operating system would have priority, with the consequences you have seen.
Much better to have a second drive, used solely for audio files. Then there can be no contention.
Personally, I never use autosave, I just save at the end of recording.



Personally, I never use autosave, I just save at the end of recording.

Well I used to use it until a take got ruined while a save happened… those sng files can get quite big with a lot of MIDI tracks and effects loaded.

Perhaps n-track should disable autosave when recording or playing?



Perhaps n-track should disable autosave when recording or playing?

I like that idea. Maybe have it autosave OR prompt you to save after recording/playback stops?

D – don’t use autosave either. Just click the little floppy icon!

It looks as though Flavio has fixed the bug. Check the latest build. :D

HAH! Lessee you get service like that from Steinberg, Digi or Cakewalk!