Trouble dragging evolution nodes

Anyone else?

Is anyone else having trouble moving evolution nodes to where you want them? I try to bring it down to -infinity and it won’t move below some arbitrary number. I haven’t noticed it when I’m moving the node up, only down. Very frustrating!

Please, don’t suggest it’s my mouse - it’s not my mouse.

What’d be cool would be to right click on a node and have the option to send it to -inf.

It works when you use the ZOOM SELECTION button, but worse than that is that if you use a slope to make the volume rise or fall slawly you cannot add a node into the slope as you could before Flavio made ‘it easier to use’ it isnt - another very anoying thing is that the centreline of all envelopes pass straight through the resize handles of the track/clip so making it hard to set a rise or fall on leading or trailing edges of the track without moving the track in the process - the track resize handles need to be switched off when the envelopes are shown and reappear when envelopes are switched off -

Dr j

Are you guys using the latest build - 2187? I think this is fixed in that build.
I’d be interested in knowing what the situation is.

It is not fixed in
My workaround for Jackrabbit’s issue when I want a node near the handle, I grab it (creatte one) from somewhere clear of the handle and drag it to the beginning of the .wav where I want it. But yeah it’s a pain in the … Note that this is not related to the problem I described in my OP, which happens sporadically with new and existing nodes anywhere in the timeline.

Hi guys:
I hear you regarding this node resolution issue…

When I’m editing in this area, I usually expand the wave regions out to their maximum Horizontal and Vertical… Well, whatever is comfortable… But when I attempt to drag the node to .inf I think it works like you explain… But… I continue to drag the node below the visual window till I see the level I require or .inf… whatever… It usually falls off the screen at about -29-30 db… In the config panel, there is a “Level” config. there to adjust fader resolutions… I was gonna get in there some day and play with the config of the faders and then see how the "Node Dragging’ responds…

It might be something that Flavio could consider here… at this edit region of n-Track…

A “Click-on-the-Node” would open a dialogue box… This would allow the numerical entry of a db level to take the node to that position…

The dialogue box could be configured as Linear or a Log scale adjustment…

Maybe, that’s something that we could explore… What do you think??


also there was a very large difference in output levels after (i think it was) 2184 -

tracks recorded before 2184 when played back in N after that build, where before the faders sat at about 3/4 FSD. playing back in 2185 the faders where banging through the top of the meter and every track output was in the red -

nothing else changed just the build number (pref settings used from previous build) -

AND why is the state of the automation buttons not recorded on save - times i wasted a CD when i forgot to switch automation back on after loading in song (recording live to CD recorder) -

Dr J

Guys, at the risk of being a pain _ I really would like to know - are you using build 2187 - latest as far I know. It says it fixed some of these problems.
Are saying 2187 doesn’t fix these problems?

Hi Bax:
I am at build 2187…

I’ll be honest by saying that I haven’t done any volume editing with v5.0.2… I just remember from editing volume nodes on earlier versions that the dragging of nodes is exactly as the Cap, describes with whatever build he is using now…

Perhaps, I should call up an .sng file and do a “node drag”, on a track, to see how that edit operation behaves on the 2187 build I use, here… or see if there are any differences/changes to report… on this set-up…


A couple of suggestions:
The Volume Range is set up in the Setting Menu under the appearance tab - click on the Volume ranges button and set the rage so that you can drage down to inf.
A way to get around the sizing box gettting in the way, click on the Scroll bar on the bottom and move the display past the end of the file. That will give you room to make changes at the very end of the file with out catching the size box. That said, you are probably right, it might be nice if the drag box went inactive when you are using the volume change , but that could also be confusing if you had that tool seleced and tried to change the file size.
Anyhow, build 2187 fixed the problems I was having with the volume envelope as far as I have been able to determine.

build 2187 has not exactly fixed the problem - you still cannot add a node directly into a slope in the envelope, you have to create a node in the straight part of the green line and move it to where you want on the slope - it was better before flavio recently messed with it -

re jump in volume - as exactly the same prefs where transfered to new build and are still in use on 2187 there should not have been such a huge jump in volume - BUT saying that there was a lowering in volume levels a few builds before that, so it looks like Flavio put right whatever caused the volume to drop in the first place but did not say anything in the ‘whats changed’ when it was corrected -

those new handles at high rez zoom may not affect you if you are using a long track, but when building up a song from a lot of short clips where the relationship between the tracks above and below are critical, its all to easy while fighting with the nodes to accidently alter the length of the track throwing everything out of kilter and having to spend time lineing everything up again -

also have you tried to re-osition a clip at high rez zoom (when you want to butt one clip to another on the same track), once upon a time a long time ago, you clicked on a little icon and you could move the track from either end or in the middle or while out walking the dog, but now we have the cross and if the cross is not at the end of the clip you are working on you have to play ‘hunt the beginning of the clip’ and that means using a lower rez zoom so you cannot position the clip correctly, i asked Flavio to put the cross on both ends of a a waveform, but so far it has fallen on deaf ears -

Dr J

Yes, I’m on 2187. It’s safe to say I’m always using the latest buil with 5.0x. Playing with the volume ranges in prefs did not fix the problem. It’s not a setting issue, it’s definitely a bug. When I try to drag the node down it just stops moving at some arbitrary (or so it appears) number. It actually looks similar to when your mouse guts are dirty - where you move the mouse and the cursor doesn’t move. However, this is definitely not the problem as I mentioned in my OP.

Jackrabbit, if you hold down control, you can click and grab the wav file from anywhere to move it.

–ETA: just noticed 2188 is up for download. I’ll check tonight to see if that includes a fix for this.

Nope. Not fixed in 2188.

i’m sorry to say it, but if one issue causes me to abandon n-track, it is the volume nodes!! they drive me berserk. in addition to the problems described above, i have the following:

when i click on a volume node, n-track often thinks i am trying to highlight. rather than letting me grab the node, it starts highlighting the track where i click. it drives me crazy! the problem is especially bad when the volume node is at -inf, although it can happen just about anywhere.

i move the mouse over the node, the cursor switches to the volume node crosshair, but then it doesn’t let me grab and move the node. it just highlights! i have to keep trying this over and over again until i find the nodes magic “g-spot” that allows me to grab and move it.

does anyone else have this problem??

The envelope is working much better for me than earlier versions of 5.
However, I do find that it will sometimes not move all the way to where I want it - it may have something to do with how fast I am moving it, but I can’t be sure and in 4 that was not a problem.
I also notice the tendency of the crosshair to highlight the area of the track instead of moving the node.
ONother propblem that has existed for awhile is clicking on the volume envelop can change the setting that I had.
I’d like to have the use of the “crosshair” show the volume when it is moved over the envelope line Before you click to activate.

Hi Guys:
I had a quick edit session earlier today using the volume nodes. Build 2188 works O.K. for the amount of time I could spend on the edit… I expanded the timeline out to the resolution that was necessary to be able to attempt the node adjustment. I brought the area of the timeline down to .inf… Everything worked fine… with no issues that I could see that was anything out of the ordinary… If anything is not right, it didn’t show up on the edit attempt I completed on the timeline’s track…


Changing zoom level does not fix the problem for me. My workaround is to use the Fade In and Fade Out commands. There is no change in this behavior with build 2189.

Flavio just uploaded version 2190 - this version is designed to fix the problems we have been having with the envelope. It seems to work here.
It seems to fix the inf problem for me and a new node is now restricted from moving past a previous node (you have set one on the left and click to the right to make a new node - it will not drag left past the first node). I did not have trouble capturing at the end of a file. The problem of high lighting seems to work - if you click away from the enevelope line you can drag to make a highlight area - click on/near the line and it lets you drag the node without highlighting the wave.
If you try it, I’d like to hear how it works.

SWEET! It’s working great in 2190!
Flavio = Elvis!

Ok, build 2190 seems to be worth to download… Have been struggling a bit with the volume envelopes, so this is good news.