v4.02 upgrade stutters during playback

Automated volume/pan overloading system!

I recently upgraded to v4.02 from v2.0. (Skipping v3.) I have been using nTrack for ~7 years and know it fairly well. Since upgrading to v4 I can’t even playback a simple 5 track song. I’m not using effects; all I am using is automated volume/pan. I’ve set the buffers to MAX and disabled all the VUs. After 2 seconds of playback it begins to stutter. (Severely.) If I disable “Allow automated volume/pan for wave tracks” it works fine; even at “Low buffering”. (I don’t know if it would act the same with effects because I haven’t been able to get that far yet.)

I’m using a 1.8Ghz Dell Vectra with 768MB RAM running Windows 2000. (using ntfs) I have a Seagate 7200rpm IDE ATA/100 w/2MB buffer. I know it’s not my machine 'cause with v2.0 I’ve run 10 tracks, heavily loaded with automation and effects using light buffering. I’ve been through every possible configuration option in v4 with no change except for “Automated volume/pan”.

The ONLY thing I’m unsure of is whether or not nTrack is backwards compatible. (I’m assuming it would be!) I have both installed on my system and can go back to v2 and play the exact same “sng” effortlessly.

I have been a big fan of nTrack for the past 7 years, but my opinion is quickly changing. Can anybody help me?!?!

Also, how do I forward this issue to Flavio?


Hello! Anybody??? Could use some help here!!!

Other than drivers and buffer settings. I can’t see why you would be having such issues.
Have you tried to import each wave file to a new song, instead of opening the original .sng file?
Do you have DMA enabled on your hard drive?
You can use the Feedback Form to detail your issues to Flavio.

I’m trying that now… and I’m pretty sure that will work. Though it won’t do me much good cause I still need the Volume and Pan envelopes and don’t want to re-create them from scratch.

Is anyone else using v4.02 with Win2000? Does anybody know for fact that this works?? It would really help if I knew I was working with a “known good”.


I’m using N-Track 4.0.2 on a Windows 2000 SP4 machine, and it works without problems. It’s a weak machine, 900 MHz Celeron, but since it runs so well, I currently see no reason for better hardware (recording acoustic demos with few tracks & fx only). I’ve been using volume envelopes recently without problems. The only thing I really added to this PC was a reasonable graphics cards, since the poor on-board graphics were really slowing down N-Track.


Thanks for the reply OliHa. That information helps a lot. It’s good to know it’s not a bug between W2k/ntrack. Also I’m using a Nvidia GeForce2 video card so I don’t think that’s slowing anything down.

Here’s what I’ve discovered. If I flatten all the track volume envelopes it still stuttered. When I flattened the AUX send envelopes too it suddenly works fine. If I import the same tracks into a new song it works fine. It appears my problems are related to opening existing projects formerly recorded under v2.0.

I’ll try loading up other songs to see if I can narrow down the symptoms.

Does anyone know how to import/export volume envelopes?? This would definitely solve my problems! (Or at least be a work-around!)


I think I am right in saying that when updated versions are released Flavio usually suggests that .sngs recorded with previous versions should work, but not the other way around. However, I am sure this is not an exact science, so it could be as simple as v4 not being able to read your v2 .sng correctly.

Have you tried importing the .wavs into v4 and saving them as a new .sng file?

Incidentally, when my system stutters I generally end up having to decrease the buffers rather than increase them … i.e. go from high to medium or medium to low, rather than the other way around. Have you tried this?

Just a couple of thoughts.


Oops … managed to double post.

Are you sure you are adjusting the correct buffers? Check what type of drivers you are using. You wat to be using either WDM or ASIO drivers. MME are the old Windows compatibilit drivers and kinda stink almost always. Assuming you are using WDM, you would adjust your buffer settings in N-track. If you are using ASIO drivers, you will need to find your soundcard’s ASIO control panel and adjust your buffers in there. My bet is that the new version of N-track latched onto either the old MME drivers and they stink regardless fo what you do or it latched onto ASIO and you haven’t set the ASIO buffers. Beyond that, be sure you have the latest build of N-track and that DMA is enabled for your hard drive. Be sure in device manager it says that the hard drive is indeed using Ultra DMA Mode 5. If not and you have WIndows set to use DMA, check your BIOS. Dell machines often nee to have DMA enabled in the BIOS as well as in Windows. I added an audio only drive to my latest DAW and the BIOS tweak alluded me for a day or two while I cussed at my machine’s poor performance.

It appears my problems are related to opening existing projects formerly recorded under v2.0.

There was a problem opening V2 files in one of the V3 releases.... the file format changed iirc. The symptom was wacky numbers next to the Aux sends and pans - way outside the scope of the slider.

The solution was to move the sliders to a sensible place (for all tracks and all auxes).

This may not be the same problem but maybe....

Quote (steale @ Nov. 21 2004,16:52)
... It appears my problems are related to opening existing projects formerly recorded under v2.0. ...

It's reasonable to expect backward compatibility for consecutive versions (eg v3 .sng files open OK in v4) but I don't think it's reasonable to expect broader compatibility than that. In other words, don't expect v2 .sng files to open correctly in v4.

Worst-case, you can "cascade" the old files up by opening v2 files in v3, confirm they still work ok then save as v3 files, then open these files in v4.

Thanks all. Sorry I hadn’t checked this in a couple days. All this messing around with different releases got my plug-ins all messed up and I’ve been trying to straighten them out before I moved on.

A couple things. DaveC - If I create a new song and import the wav files, or just simply flatten the envelopes, it works great. But then I loose all my volume envelopes and that seriouly sucks. Decreasing the “Playback” buffer makes it studder faster, but I know what you mean about moving the buffers the other direction. That’s worked for me when the buffers were max’ed out.

BubbaGump - I am adjusting the playback buffers. As far as the drivers go you may have something there. When I get home I need to straighten out the plug-ins on my home DAW. Once I do, I’ll check which drivers I’m using. I believe I WAS using the MME drivers. I think I tried the others also but don’t really remember the outcome. I know I haven’t checked the BIOS DMA mode. I will do that when I get home.

Mark - The files load just fine. In fact everything looks good until I hit play. I’ve run it with Task Manager open and watched the CPU load. It hits and sustains 100% CPU usage. You’d think I was running a 486.

I’m currently working with Flavio on this but I’m afraid he thinks I’m crazy. :D Evidently no one’s ever had this issue before. Then again, I don’t think anybody’s ever jumped straight from v2 to v4 before either. Personally I think that’s what’s wrong.

What I do know is that this issue is extremely consistant and repeatable over both Win2k and XP. Thoughout every “.sng” file I load with heavy envelope usage. It would be great if anybody still had some v2 .sng’s around that they could try loading into v4. I’m beggining to think this is a legitimate bug. Hopefully Flavio will give me a copy of v3 so I can test my theory.


Anybody got a copy of nTrack v3.x? I’ll work out a license with Flavio.


You can find 3.3 and some other old versions here.


Thank you!!! I could kiss you!!! :D

I knew it was somewhere on the site, I had seen it before, just couldn’t find it.

Thanks again!!

THANK YOU “MARK A”!!! Turns out the problem was in the AUX sends like Mark said. I downloaded v3 and it didn’t work either!

The reason it worked if I flattened the tracks is because the AUX sends are tied in with the volume envelopes, therefore when I turned off the “Allow automated Volume/Pan” it also stopped sending to the AUXs as well.

Your a GENIUS Mark!! Your “doubtful little clue” saved the day!! :laugh:


Your a GENIUS Mark!! Your "doubtful little clue" saved the day!!

Thankyou for the thankyou. Not quite sure I'm a genius though - just mentioning something I had spotted..

Glad it got sorted.