Ver. 5.0.2144 Very disappointing!

Kinda long…

Maybe it’s my fault for not waiting, like I usually do. Usually, I wait a few weeks before upgrading, time for most of the worst bugs to get worked out. But I was asked to evaluate n-Track 5.0 for the BostonGeek.com podcast (for which I also write and record music and promos), and so I downloaded build 2144 and proced to check out the changes from 4-point-whatever.

Before I continue, I want to state as clearly as I can that I love n-Track. It is unquestionably the workhorse of my studio. I have been using it in a professional and semi-pro manner for more than five years. I have recommended it to friends and colleagues. I use it not because it is inexpensive (though, certainly that is appreciated) but because it does what I need it to reliably and simply. It has allowed me to work without having to fight. And that’s what kills me the most about this.

Because 5.0.2144 just doesn’t work. Note that I’m not “putting it through it’s paces,” or trying to see how hard I can push it before it breaks. I’m just trying to work normally, even more carefully than usual, saving more often, taking notes.

This was a fresh install, not an upgrade/overlay, and since I’m sure it will come up, all of my drivers for audio and video are up to date and my Windows updates are current as of yesterday. I used to test software functionality for a living. I can deal with, and in fact have come to expect that a programmer’s idea of a logical place for something might be very differnt from my own. So note that I’m not talking (writing) about menu items being moved or minor things like dialogs that always pop up in between my two video monitors. I’m talking about lots of totally new really buggy behavior much of which just stops me from working. I did not observe any of these behaviors in version 4.x or earlier:

• Removing a track in the timeline causes the remaining tracks to resize so that the song takes up the same screenspace. I don’t want that and I could not find a way to toggle it.
• No position numbers for the pan sliders. Mouseover popups that show the position appear inconsistantly and do not show the position while you are moving the slider – only after you’ve released the slider, moved the mouse away and back over the slider.
• The new Scrub feature worked last night, not this morning. That’s okay since I thought it was annoying that every time I dropped the cursor in a new position on the timeline I had to wait for it to scrub for a second before it would accept my play (spacebar) command. However, now I can’t find how to toggle it.
• The Scrub feature - at least I think it was the Scrub feature - caused random instances of backward play. (last night, again Scrub isn’t working at all today)
• Every time I opened a song file from 4.x I got a DirectX plugin error. I removed all plugins, replaced them, saved the file, closed it and opened it again and still got the error. I tried reinstalling the plugins (Sonitus plugin suite R3) - byebye all my presets - and tried again with a fresh new file and still got the error every time I opened it. The error dialog does not ID which plugin is causing problems.
• It gets better. When I start with a brand new, from scratch, 5.0 song file and put in one of the plugins I’d just reinstalled, save, close N, relaunch N and open the song again, I still get the DirectX error.
• After removing a plugin from Aux1 when I tried to save the file I got an error saying “Plugin corrupted, try removing it first.” There were no plugins anywhere in the song. I could not save the file, could not exit n-Track.
• If I move the new song speed control at all, it snaps to 20x and cannot be moved to any other position - not even back to zero (1x).
• Suddenly, I got no sound from a part of a track although the volume evolutions were all flat. Two of the four files on the track just wouldn’t make any sound. Yes, all files on the track were the same bitdepth and rate.
• Suddenly, none of the plugins are affecting any of the tracks and cannot be called up to be adjusted or even removed. I closed and relaunched n-Track, now they work.
• The mixer keeps behaving as if Auto Height was checked, even though it isn’t.
• A track channel effects dialog could not be closed.
• Fatal (full cold reboot) lockup while adjusting the n-Track Parametric EQ.

There’s more, but that’s most of the ones I could decipher from my angry handscrawled notes. There are features that I like and that work well including the file auditioning; the pitch shifing; the move-file handles; clipping data popups.

So now I’m in the position where I have to report on this tomorrow afternoon (Oct 8) and I cannot in good concience give it a good review. I will try reinstalling 5.0.2144, and if that fixes things then great! But I will have to report that sometimes you just need to reinstall. Again, this kills me because I love n-Track and have huge respect for Flavio.

Captain Damage

I think that most of your problems might stem from a bug in the song speed control. I’ve been using V.5.0.2143 fairly heavily for several days, and it has been stable. Then I saw your posting, and as soon as I used the song speed control -WHAM- nothing was working. I had to reboot to reinstall and I upgraded to V.0.2144 at the same time. All is well again in Merry Maryland.

On my computer V5 is a a real improvement over V4. Much more efficient in particular, and works better with VST and VSTi plugins. I dont use any Direct X plugins- so I can’t say anything obout them.

If I’m right about the playback speed control bug, it would seem that you should avoid using the speed control again until you fininsh your review so that your review isn’t colored too much by that one bug.

T

Unless using the speed control somehow damages n-Track permanently - even after closing and restarting (indeed, even after rebooting), regardless of whether you’ve saved your song file or not, I don’t think that’s likely. I did not try the speed control every time I had it open. I won’t use it again because it doesn’t work, but as you can see, the list of things that don’t work includes, well, n-Track 5.0.2144. Most beta software performs better than this. I’ve reinstalled and will begin testing again in a few minutes.

I agree that 5.0 works more efficiently. I actually wrote down the cpu use % for a few songs on 4.x before I installed 5.0 so I would have real data for my review. There is a slight improvement in overall cpu use, but the notable thing is a huge reduction in cpu use “spikes,” which usually result in pops and burps.

Hi Cap:
Flavio is at 2146 as of a few hours ago… I don’t think he’s getting much sleep… It’s tough to do fixes all at one time. Are you gonna continue reporting build 2144? or will you report on the builds that follows 2144 and continue with your review?

I presume that the issues you have with build 2144 are not causing “Close Exceptions”… Have you been able to create (what I call a work-around) or some alternate way of replacing the issue that happens in your navigation with build 2144 of n-Track?

If n-Track closes… Is the “Report Close Exceptions” feature working on the set-up you have build 2144 installed, on?

I was gonna install up-to-and-including build 2142 on the studio dual boot machines… However, I didn’t get the opportunity to get in there today… My thinking is now , why should I not install the latest builds as Flavio posts them?

It appears… and what I see is… Flavio is at the apex of concentration posting up-dates to builds… Again I say he’s not getting much sleep… I believe that as the builds continue to be posted, the “Code Errors” will continue to be “Ironed Out”… and the “build posting” will slow down…

I see Flavio up here on the Board at the oddest hours… So, he’s reading the “Threads” and got his “Finger on the Pulse”…

Bill…

CapD

Just tested effects on Aux channel. I also have problems when I insert and then delete effects on the Aux channels. No similar problems with effects added to tracks individually. Cannot duplicate the playback glitches you reported.

T

Tspringer,
I had problems with both aux plugins and channel plugins.
Bill,
I will load up 2146. After reinstalling 2144 I’m working very methodically and haven’t used any plugins yet so can’t report yet (I took a long break too). I have noticed that the timeline resizing I reported above has not occured. Perhaps there is a toggle for it somewhere that I didn’t click. Also, the Scrub feature appears to be working correctly. One thing I’m doing differently this time is I haven’t done any UI/skin tweaking which I previously did pretty soon after first launching.

Hi Guys:
I had a reply ready to post but instead I replied to some mail I had going with Flavio> When I came back to what I was ready to post on this thread I couldn’t find it anywhere… I must have been fibbing, or something…

Anyway, I had a re-sizing issue with the .npk files on the timeline… I still have the issue but no-one is able to re-create it… However, I know how not to make it happen… I have the work-around for it… That’s good enough for me…

If you want to try to make it happen on your setups… try this…

Open up a timeline… click on the “Show All Files” and then minimize n-Track to the windows task-bar… If the “Show-all Files” icon is hi-lighted (up on the n-Track tool-bar) when you minimize n-track and then maximize n-Track to your monitor screen you should see no .npk files on the n-track timeline… Well, that’s what happens on my set-up… If you wantta check back on a couple of threads from a week-or-so ago you’ll see some print-screens of what it looks like…

Version 5.0 is coming into it’s own… I see it as working pretty good on my set-up, over here… I need to be careful of how many applications I have open-and-or-working in the back-round while I am working with n-Track… That stands to reason… I need to watch and be careful and use “End-It-All” before I start any serious editing, while using n-Track…

Bill…

[EDIT]
This is the latest mix of the test project I’m using to try out the latest posted versions (build 2146) on n-Track that Flavio is posting…

Larest mix of the “Test Project”

#1 Rule of computing: NEVER EVER expect too much from a x.0 release of ANY software from ANY company. There will ALWAYS be bugs and glitches that need to be worked on. That’s why it’s a x.0 release.

And NEVER use a x.0 release of ANY software from ANY company for paid/important work.

(I’ve been around computers for way to many years…)

2146, still having problems, especially with plugins. I got the unclosable track plugin dialog again. This after I closed and restarted n-Track due to channel plugins not working at all during one session.
Another annoying thing: when you loop playback over a short section to adjust a plugin there are a lot of pops and burps during the wraparound and occasionally the plugin(s) drop out. So a text equivalent of the thing I’m working on where I have soudbites that I’m applying (trying to) various effects to might be: It’s so tasty! It’s so tasty! It’s so tasty! It’s so tasty! It’s so tasty!
This doesn’t necessarily happen when I’m physically adjusting the plugin. It doesn’t seem to matter if it’s VST or DX, or who made the plug - even the FASoft ones do this.

<!–QuoteBegin>

Quote
Flavio is at the apex of concentration posting up-dates to builds… Again I say he’s not getting much sleep

As I said in the OP, I have great respect for Flavio, but to be blunt his sleep isn’t my problem. 5.0 should still be in beta.

<!–QuoteBegin>

Quote
#1 Rule of computing: NEVER EVER expect too much from a x.0 release of ANY software from ANY company. There will ALWAYS be bugs and glitches that need to be worked on. That’s why it’s a x.0 release.
And NEVER use a x.0 release of ANY software from ANY company for paid/important work.


Yes, I know this and as I said in my OP, that’s specifically why I usually wait a few weeks before upgrading n-Track. I didn’t wait this time because I was asked to review it. These are not bugs and glitches. This software is unusable. I will continue to play with it and get some data, but I’ll be switching back to 4.x for work.

I wasn’t able to reproduce most of the bugs you mentioned.
It would be great if you could post or send me a repeatable procedure to reproduce the problems, starting from the program default settings and a blank song.

A few things:
- the timeline ‘auto zoom-all’ thing can be deactivated clicking on the ‘Zoom-All’ button. If you click once it will fit all of the song on the timeline and will remain pressed. When it is pressed after each editing action the zoom will be readjusted. To disable this behavior either click again on the zoom-all button to disengage it or click on any other zoom button (vertical or horizontal +/-).
- the drop-out when looping has always been there and it’s basically because n-Track stops and restart the playback at the end of each loop iteration. I plan to work on ‘seamless’ looping in a future 5.x version of the program
- about the song speed snapping problem: when in stop mode, the song speed control works as a scrub control, when you move it the playback starts and it stops as soon as you release the control. When you release the control the speed goes back to the setting it had before dragging it. To actually change the permanent speed the control must be adjusted during playback (i.e. when the control is not in scrub mode).
To reset the speed to 1 simply double click on the control handle. When the speed is x1.0 or x-1.0 double clicking switches between 1.0 and -1.0

Flavio.

Thanks for the response! I’ll try to get you some concrete datain the next day or two.

Hi Everyone on this Thread:
I spent some time in the studio today… I worked on bringing the dual-boot P-4 up to current and with the latest build 2146, of n-Track… on both '98SE and XP desks… Each desk had build 2135 installed on it… That’ll give you some idea as to the last time I was in there… Shame-on-Me… The XP Desk was a seamless task of up-dating the virus definitions and installing build 2146… I’m surprised… The CPU load for the same Test tracks run at 24 -25%. On my Editing /knockabout/Do-It-All P-111 machine runs at or about 48-51% for the same test project… As-well-as being surprised… I’m impressed…

On this timeline I have the Adwedia verb on a vocal group and the n-Track three-band compressor/limiter and a “Classic” limiter on the Master Strip… The Three-Band n-Track Compressor/Limiter uses in the neighbourhood of 15-16% of the CPU Load. That’s more than half of what the rest of the Timeline uses on this timeline… That’s on the P-4 1.7 mhz with '98SE as the DESK… The Audio Card is the Lexicon CORE-32 set-up… It wouldn’t work on an XP Desk… No Drivers… One track on this timeline has a number of things working it… So, I have “Frozen” it’s plugs…

Bill…