Plug in hosed

I installed the Beta of 5, built 2124, and when I tried to use version 4 I received a series of messages about the Plugins. The plugins are the Ntrack compressor and EQ that are on each track.
I have not tried to uninstall 5 and reinstall 4. Hopefully that works.
Just thought you guys might want to know because the notes on the Beta 5 say that 4 and 5 can both be on the same computer.

I say file a bug report because it’s supposed to work.

Since they are DX Plug-Ins, if Flavio didn’t change GUID of those two (and maybe some others) so they can both be registered independently then there may be issues. That’s the only way for both to be on the machine at the same time. BUT, that would cause both to show up. Maybe that’s part of the problem?

Of course, if the plug-ins are 100% identical it shouldn’t matter where they are registered, but if V5 reregisters them from the V5 directory, then V5 is uninstalled and those plug-ins are unregistered when V5 is uninstalled then V4 would have to be reinstalled to restore them. Since you have both versions installed that shouldn’t be the root of the problem.

I think it’s a bug regardless.

I haven’t installed V5 except once at work a few weeks ago, so I’m guessing.

The problem is being worked on. version 2025 is suppose to fix it. I don’t know because when I loaded 2025 my sound card, Layla 20, would not work with Ntrack anymore. Guess I better wait for the non-beta version.

I have a Layla20 at home. What was your symptom? I’ll give it try tonight.

Thanks Pooh. Flavio has emailed me that build 2026 should fix the problem: The problem was that I could not select the Layla in the Audio selection choices. IN the Settings if I picked the Playback Layla 1-2, then when I clicked on the Record the computer froze - Ntrack was listed in the Task Manager as “Non- responding”. Somehow, I managed to crash the Windows XP operating system trying to do a System restore. I hope, and believe, that was not really related to the Ntrack problem -
If you can let me know if you have similar problems I would appreciate it.

I went straight to 2026 last night since that was the only one up there at the time. I didn’t have any problems at all with it. I do see multiple instances of some plug-ins though.

Don’t let this get confused with your (former) problems.

I have found a problem when using devices, such as the layla, that have multiple input pairs that if “sync devices” is turned on in the soundcards control panel that there can be an apparent hang when recording if all the enabled devices are not selected to record from. Yes, that’s a mouthful.

Input pairs
1-2 (do not record from this pair, but it is selected in the input devices)

Look at this config, and assume all 4 pairs are selected in n-Tracks Input Device Settings. Also, have recording and playback NOT set to use the System Timer (the default unfortunately).

If you click the hammer and disable recording from 1-2 then when the record button is clicked pairs 3-4, 5-6, and 7-8 will sit there and wait for the clock from 1-2. Since 1-2 has been disabled from recording the clock ticks never start and n-Tracks just sits there acting like it’s stuck. The pairs are daisy chained in order.

I don’t see how this is what you were seeing in any case.

You won’t run into this is “sync devices” it turned off in Echo
s control panel or if only the pairs being recorded are selected in the n-Tracks device preferences.

Pooh, have you tried the new build to see if it fixed the Layla yet?

I haven’t had a problem with the layla. It worked fine with 2026. I haven’t tried it with 2027.

The problem I was talking about isn’t a problem with n-Tracks and isn’t related to any buikd or version. It’s the way the layla and some other devices work. I mentioned it because it has caused some folks to think that n-Tracks is hanging when trying to record.




Close enough…That’s how I’m shaped anyway. :)

One of my very favorite characters - and the song I was working on . . . Thanks!

Mine, too!