Voice Activated Recording

voice activated recording bug

My audio application captures real time radio traffic from my 911 radio network. I route fixed level audio from the accessory port on the rear of six Motorola radios (via a custom built audio isolation box) to inputs 1 to 6 on the Scarlett 18i20. All this works great, the levels are good and audio signals arriving in software seems fine.
Given the radio traffic is sporadic, I use voice activated recording feature to trigger the recording process with a trigger threshold of about -30dB.
All good so far — but here is the problem. Even though I select the voice activated recording feature, the feature only appears to work properly on 2 out of 6 channels. There is endless audio being recorded on the other 4 channels – in fact GB’s of dead air audio.
All set up features appear good. If I purposely insert test audio from one radio is starts and stops recording properly – but the dead air audio on the 4 tracks continues and does not appear to recognize the fact that I’ve selected voice activated recording.
I have disabled ‘windows sounds’ so there is nothing else entering this standalone PC
Any thoughts or insight would be appreciated.

Further to my post on this topic. I currently have 5 tracks active; track 1 and 4 are sitting idle while the other 3 tracks are constantly recording nothing but dead air. As I look at the screen the voice activated window clearly shows a correctly set activation level, hold time, the button is greyed down – showing it being properly invoked and the word is shown.
From my perspective, I have everything working correctly yet the voice activated feature seems to have a ‘track based’ mind of its own.

Help would be appreciated with this problem

Just in case: In the Recording VU meter, Click on the Monitor button and set it to "Record from all imputs"
See if that helps

Along the bottom row of the Recording VU meters I have:
- Monitor On or Off
- Set to which track recording is assigned
- Settings
- Add a channel


When I click on what I think is the monitor button, I don’t see the exact phrase but I do see Set all audio inputs to record to new tracks. Am I looking in the right place

When I click on what I think is the monitor button, I don’t see the exact phrase but I do see Set all audio inputs to record to new tracks. Am I looking in the right place

If I’m in the wrong place, please redirect me

For some reason one sentence repeats itself when I post

I think you are in the right place. You can try settings and then change them back if something does not work

So here is what I have been able to make work. Voice activated recording works properly if I configure my 6 mono inputs as 3 stereo tracks with mic 1/2 on track 1, mic 3/4 on track 2 and mic 5/6 on track 3. While this proves the voice activated feature works properly, it isn’t really what I wanted from the software. Given I’m working with mono radio traffic I would like to keep the radios separate and not recorded as stereo pairs. It is however clear to me that setting up say mic 1 and 2 as two mono channels causes the voice activated feature to crash – or just not work properly. Not sure what I will do next. The good news is at least for the time being, I do have everything working.
Thanks for pushing me in the direction that resulted in success

Forgot to say that – using the track configuration utility at the bottom of the recording VU meters I setup each left / right channel as left track 1 and right track 2, and so on through to track 6. Then I launced the voice activated recording utility and the result was the same. Some tracks waiting for input and others endlessly recording dead air – good thing I have 3TB drive.

you can always split the stereo tracks into separate mono tracks when done recording,

until this is sorted out…:slight_smile:

Quote: (FireComm @ Oct. 30 2013, 10:43 PM)

Forgot to say that -- using the track configuration utility at the bottom of the recording VU meters I setup each left / right channel as left track 1 and right track 2, and so on through to track 6. Then I launced the voice activated recording utility and the result was the same. Some tracks waiting for input and others endlessly recording dead air -- good thing I have 3TB drive.

FireComm,

thanks for reporting the problem. We've been investigating the issue and found a few issue with the level activated recording feature. The next build (which will be online later today) will fix the issues.
Please let me know if you still see the issue in the new build.

Flavio.

Flavio

I just downloaded and installed the latest 64-bit build.

I am very pleased to report that after configuring 6 mono tracks and launching the level activated feature (in Live mode) that everything appears to be working perfectly. My thanks to you and others for a speedy resolution to this issue. I will advise if I encounter any other issues.

Paul

I just downloaded and installed the latest 64-bit version and the voice activated recording feature does not work properly. Each time I configure the 6-tracks, and press start (in the voice activated window) all tracks start recording dead air. I tested it several times and could not make it work properly.
Given I had set a new restore point before installing the latest release, I backed out of the new install and re-installed the beta version (build 3103) which is now working okay.

Firecomm,

we are trying to reproduce the problem but so far we haven’t been able to. Could it be that it was some setting that you inadvertedly changed? We have made no changes to the voice activated recording function in the latest builds.
When you’ll be able to try again the latest build please try after reinstalling to answer ‘No’ when the program asks you if you want to keep the existing settings, so that the default settings will be restored so that if the problem persists we’ll know that it’s not a settings issue.

Flavio.

Flavio
I have just downloaded and reinstalled the latest version. It now appears to be operating perfectly. I will advise if I have problems.
Paul

Flavio
In the testing that I have done the process of starting the 6-channel recording is never a sure thing. It seems very hit-and-miss in terms of whether the process starts properly and by that I mean doing the same thing over and over again always generates a different result. Without fail the voice activated recording feature does not always work properly. With it activated in Live mode, sometimes the program records dead air on all 6 channels. At that point I stop the program and after several attempts I usually get it going properly. While this is hard to explain, believe me it’s even harder to deal with when the feature doesn’t start properly.
I usually run each recording for about 100 hours and each recording is saved to a 3TB drive. I think the problem might be how to start a new recording that uses exactly the same settings each time. Everything is always the same – so why should I have a problem restarting a new recording. With your program recording it’s using less than 2% of the CPU, the Focusrite Scarlett 18i20 board seems to be working great and the audio levels from the 6 radios is certainly okay.
I have Teamviewer on this machine if you’d like to connect to it at some point and do some testing for yourself. If so send me a message.
Paul

Firecomm,

we’ve tested “Voice activated recording” feature using the same device (Scarlett i1820). We’ve noticed that there’s a crosstalk on the soundcard between channels in each stereo pair, that can be experienced at high gain level (i.e if you’re using a mic on channel 1, you’ll see a small signal bleed in channel 2, even if there’s nothing connected to its input). To verify this, simply open the “Scarlett Mix control”, connect only channel 1, rise its gain almost to the maximum level and look at the signal meter of channel 2 . It may be that the combination of this issue and the mics’ background noise, makes the signal exceed the threshold you’ve set. If you can’t verify this issue, or think that this isn’t your problem, please write us using the n-Track support form (http://ntrack.com/support.php) and leave your team viewer ID so that we can establish a remote support session and make some further tests.

Andrea.

Andrea

Thanks for your comments.

The six Motorola radios feeding the 18i20 deliver identical fixed level line audio from two pins on the rear 16-pin accessory port of each radio. The gain levels on Mic 1 thru 6 on the 18i20 are all set at the 12-o’clock position. Given this simplistic setup, I don’t see the possibility of signal bleed and there is almost never a situation where more than one radio is receiving at the same time.

That having been said, I will submit the problem to the n-Track support form and we can go from there. I will get this done early next week.

Paul