VSTi latency - how do you get around it?

Can’t record VSTi MIDI in real time

OK, folks, I need some direction here. I use SampleTank and a few other software synths to generate my sounds but I have NEVER been able to record directly from my MIDI keyboard in “Live” mode. There is WAY too much latency, probably caused by the VSTi processing. (There is no latency on playback because of the plugin delay compensation). The time delay between pressing a key on the keyboard and hearing the VSTi output is 200ms or more. It’s unusable.

As a result, I have always created my MIDI tracks using the manual piano roll editing features. This is very tedious and not very spontaneous.

I would like to play my keyboard and record MIDI in real time. The only “workaround” I have is to use the sound module in the keyboard as a guide during recording and then apply the actual sounds afterword through the plugins. The drawback here is that I don’t really know what it’s going to sound like WHILE I’m recording it.

It doesn’t seem to me that’s it’s even possible to record MIDI live while monitoring through the intended VSTi sound module. How do the rest of you folks use VSTi plugins?

Hello Slowfingers

It all depends on your soundcard and drivers. I use emagic 2|6 usb audio interface, which allows me to get a latency of 30-40 ms. I also have a Creamware Powersampler which is working downto 7 ms.
You adjust the latency by setting the buffer size. But first you should check out which drivers your soundcard supports, goto File->Settings->Preferences->Audio devices.
There you can see the available drivers. You should use asio driver if possible or else DS (go and check under “Advanced” and check all driver types in the top of the form).
When you have choosen the right driver goto File->Settings->Preferences->Buffering. Here you can turn down the buffer size, i.e. latency. You have to find a balance, as low as possible, but too low will make sound click, because the cpu cannot calculate the output fast enough!

Chill and chill

Read this little tutorial, maybe helps you:


Thanks, folks - got it!

Yes, it was the buffer setting for “live/processed sound” that did it. I (wrongly) assumed that these settings only affected audio in/out but it affects MIDI data as well.

Works great! This is AWESOME!

Just to clarify: the buffering settings don’t affect MIDI data handling. They affect the audio output from the VSTi synth, which takes MIDI input but generates audio output. Anyway, glad you got the problem solved!